
XMLmind XML Editor - Online Help
Hussein Shafie

Pixware
<xmleditor-support@xmlmind.com>



XMLmind XML Editor - Online Help
Hussein Shafie
Pixware
<xmleditor-support@xmlmind.com>

Publication date September 29, 2011

Abstract

This online help contains, in addition to a short tutorial, the reference manual of all the menus, tool bars and dialog
boxes of XMLmind XML Editor (XXE for short).
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Chapter 1. Install
1. Installing XXE

1.1. Requirements

• Oracle (ex Sun) or Apple Java™1 runtime 1.6 or above.

• At least 1Gb of memory and a 1GHz CPU.

• 100Mb of free disk space; 200Mb for the self-contained distribution which includes a private Java™ runtime.

XXE is officially supported on Windows XP/Vista/7, on Linux and on Mac OS X 10.5 (Leopard) /10.6 (Snow
Leopard)/10.7 (Lion). It is possible to use it on other Java™ 1.6+ platforms, but without support from XMLmind.

1.2. Install on Linux (or manual install on the Mac)

Tip

On the Mac, it is strongly recommended to download and install the auto-installable .dmg file.

1. Make sure that the Java™ bin/ directory is referenced in the $PATH and, at the same time, check that the
Java™ runtime in the $PATH has the right version:

~$ java -version
java version "1.7.0"
Java(TM) SE Runtime Environment (build 1.7.0-b147)
Java HotSpot(TM) 64-Bit Server VM (build 21.0-b17, mixed mode)

2. Unpack the XXE distribution inside any directory you want:

$ cd
$ tar zxvf xxe-perso-5_0_0.tar.gz
$ ls xxe-perso-5_0_0
addon/
bin/
demo/
doc/
...

3. XXE is intended to be used directly from the xxe-perso-5_0_0/ directory. That is, you can start XXE by
simply executing:

$ xxe-perso-5_0_0/bin/xxe &

After that, you may want to add xxe-perso-5_0_0/bin/ to your $PATH.

1.3. Manual install on Windows

Tip

On Windows, it is strongly recommended to download and install one of the two auto-installable setup.exe
files.

1. Make sure that you have a Java™ 1.6+ runtime installed on your machine. To check this, open a command
window and type "java -version" followed by Enter. You should get something looking like this:

1Oracle and Java are registered trademarks of Oracle and/or its affiliates. Other names may be trademarks of their respective owners.
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C:\>java -version
java version "1.7.0"
Java(TM) SE Runtime Environment (build 1.7.0-b147)
Java HotSpot(TM) Client VM (build 21.0-b17, mixed mode, sharing)

2. Use a tool like WinZip, 7-Zip or Info-Zip 2 to unzip the XXE distribution inside any directory you want:

C:\> mkdir XMLmind
C:\> cd XMLmind
C:\XMLmind> unzip xxe-perso-5_0_0.zip
C:\XMLmind> dir xxe-perso-5_0_0
... <DIR> addon
... <DIR> bin
... <DIR> demo
... <DIR> doc
...

3. XXE is intended to be used directly from the xxe-perso-5_0_0/ directory. That is, you can start XXE by
simply executing:

C:\XMLmind> xxe-perso-5_0_0\bin\xxe.exe

After that, you may want to add a shortcut to "C:\XMLmind\xxe-perso-5_0_0\bin\xxe.exe" on your
desktop.

Note that the bin directory contains not only xxe.exe, but also an equivalent xxe.bat which may be handy
if you intend to customize the way XXE is started.

2. Contents of the installation directory
addon/

The addon/ directory is the place where XXE finds its extensions, whatever its type: configurations, plug-ins,
translations to languages other than English, spell-checker dictionaries.

This addon/ directory is recursively scanned by XXE at startup time. Therefore, feel free to organize it as
you want.

addon/config/
Contains configuration files for a few document types: DocBook, DITA, XHTML, etc.

The content of a configuration file, which specifies a customization of XXE for a specific XML application,
is described in detail in XMLmind XML Editor - Configuration and Deployment.

addon/spell/
Contains the bundled dictionaries used by the spell-checker. A dictionary is a file whose name is LL.dar,
where LL is an ISO code for a language.

The distribution of XXE only contains an English dictionary (with CA, GB, US variants). Additional diction-
aries, German, French, Spanish, can be downloaded and installed using Options → Install Add-ons.

bin/
Contains XXE code (.jar files) and many scripts used to start XXE and its associated utilities.

bin/xxe, xxe.bat
Scripts used to start XXE. Use xxe on any Unix system. Use xxe.bat on Windows.

bin/xxe.exe, xxe.jstart
Only when installing XXE on Windows using any of the *setup*.exe distributions. File xxe.exe is XXE
launcher and xxe.jstart is its (plain text, UTF-8 encoded) associated parameter file.

2Note that Windows XP has built-in support for .zip archives.
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bin/deploywebstart, deploywebstart.bat
Scripts used to generate a Java™ Web Start configuration (.jnlp file, signed jars, etc) from a possibly cus-
tomized XXE distribution. Use deploywebstart on any Unix system. Use deploywebstart.bat on Windows.

The deploywebstart command-line tool is documented in the Section 3.1, “The deploywebstart command-
line tool” in XMLmind XML Editor - Configuration and Deployment.

bin/xmltool, xmltool.bat
Scripts used to run xmltool. See The xmltool command-line utility for more information about this tool.

bin/csscheck, csscheck.bat
Scripts allowing to check the syntax of CSS style sheets written for XXE.

bin/convertdoc, convertdoc.bat
Scripts used to run convertdoc. This tool allows to execute XXE process commands from the command line,
exactly as if these process commands were executed from XXE.

See Section 3, “The convertdoc command-line tool” in XMLmind XML Editor - Commands for more inform-
ation about this tool.

bin/*.jar
All the (non-system) Java™ class libraries needed to run XXE:

• xxe.jar contain the code of XXE.

xxe_help.jar contains the online help of XXE.

xsc.jar contains the code of the spell checker engine developed by XMLmind.

• jh.jar is the standard Java™ help engine.

xerces.jar contains Xerces 2.9.1 XML parser. (The version included in the Java™ runtime 1.6 has bugs
which have been fixed in bundled version.)

resolver.jar contains Apache XML Commons Resolver which implements catalog-based entity and URI
resolution.

Substantial parts of xsdregex.jar, James Clark's XSD to Java Regular Expression Translator, have been
directly added to xxe.jar (which is why file xsdregex.jar is not included in the distribution). Download
original package from http://www.thaiopensource.com/download/.

Package com.jclark.xsl.expr contains the implementation of XPath 1.0 used by XT, James Clark's
XSLT engine. A modified version of this package, renamed com.xmlmind.xmledit.xpath, has been directly
added to xxe.jar (which is why file xt.jar is not included in the distribution). Download full XT from
http://www.jclark.com/xml/xt-old.html or from http://www.blnz.com/xt/index.html.

relaxng.jar is Jing version 20030619, James Clark's RELAX NG validator, slightly modified for use in
XXE. The details of the modifications are found in relaxng.README.

saxon.jar is Michael H. Kay's XSLT 1 engine. See http://saxon.sourceforge.net/.

saxon9.jar is Michael H. Kay's XSLT 2.0 engine. See http://www.saxonica.com/.

These excellent packages have not been developed by XMLmind. Copyright information is contained in
the corresponding .LICENSE file. Read the corresponding .README file to have more details about these
packages.

bin/icons/
Contains desktop icons for XXE.
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bin/mac/
Contains files (e.g. Info.plist) used on the Mac to create XMLEditor.app from a .zip or a .tar.gz distri-
bution.

demo/
Contains XML documents that can be opened in XXE to demo some of its features.

doc/
Contains XMLmind XML Editor documentation in HTML and PDF (Acrobat) formats.

legal/, legal.txt
Contains legal information about XXE and about third-party components used in XXE.

3. Acknowledgments
On Windows, XMLmind XML Editor installer (i.e. *setup*.exe) is built using Inno Setup™ by Jordan Russell's
software. XMLmind highly recommends this excellent and free-to-use tool.
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Chapter 2. Getting started with
XMLmind XML Editor

Note

Everything explained here applies not only to DocBook, but also to all the other document types (XHTML,
DITA, your custom schema, etc) supported by XMLmind XML Editor.

Creating a document

Use File → New, select DocBook v5+|Chapter, then click OK.

Figure 2.1. A newly created chapter

The text you see, Chapter 1, 1, etc, is automatically generated and cannot be modified. The square patterns you
see are text placeholders.

Type the title of your chapter in the first placeholder. Click on (or tab to) second placeholder and type the title of
the first section. Do the same for the first paragraph of the first section.

How do you know where you are? Answer: always keep an eye at the node path bar.

Figure 2.2. The node path bar

The node path bar shown above indicates that the caret1 is located inside a text node contained in a para element,
itself contained in a section element, itself contained in a chapter element.

The text selection

Select some text by dragging the mouse over it, as you would do it in any text editor.

Figure 2.3. The text selection

1The caret is also called the insertion cursor.
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You can now convert this text to an emphasis element. For that, select the emphasis item from the menu of the
toolbar button shown below.

Figure 2.4. The "Convert to emphasis" toolbar button

You'll not find all the elements you want in this menu. For example, you'll not find citetitle or uri. In the

general case, you'll have to use the  Edit → Convert (Ctrl+T)2 command to convert the selection. More on this
command later.

The node selection

The implicit element selection

Let's suppose you want to add a programlisting element after the para element. Click anywhere inside the para
element, except inside its emphasis child element. Even if you don't see anything special about it, this para is now
implicitly selected. This means that all the commands you may invoke will use this para as their subject.

Use  Edit → Insert After (Ctrl+J). Doing this activates the Edit tool. Type the first few letters of the name
of the element you want to insert, then press Enter.

Figure 2.5. The Edit tool

A programlisting element has been inserted after the para element. The caret is inside it. You can type some
text in it right away.

Note that you have used command Insert After and not command Insert.

Table 2.1.  Edit tool commands

DescriptionShortcut2Command

Replace the node selection by a newly created element.Ctrl+R (R like Replace) Replace

Example: you want to replace the title child element
of a section by the more comprehensive info element.
You cannot delete the title child element because the
content model of a section specifies that a section

2On the Mac, use the Command key instead of the Ctrl key.
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DescriptionShortcut2Command

must start with a title or an info. However you can
replace the title by an info.

Insert a newly created element before the node selection.Ctrl+H (I like Insert; H is
before I)

 Insert Before

Insert a newly created element at caret positiona.Ctrl+I (I like Insert) Insert

Insert a newly created element after the node selection.Ctrl+J (I like Insert; J is
after I)

 Insert After

If a single element is selected, convert this element to
another element which has a compatible content. Ex-
ample: convert an itemizedlist to an orderedlist.

Ctrl+T (T like Transform) Convert

If multiple nodes are selected, wrap a newly created
parent element around this nodes. Example: wrap a
blockquote around several selected paras.

A variant of command Convert. It always wraps a newly
created parent element around the selected nodes.

Ctrl+Shift+T Convert [wrap]

Example: a single para is selected. Convert allows to
convert it to a simpara or a programlisting. Con-
vert [wrap] allows to wrap a blockquote around it.

aIf the element containing the caret is not explicitly selected. If an element is explicitly selected, this command inserts a newly created child
element after last child element.

The explicit node selection

Let's suppose that you want now to insert a second section after the first one. If the programlisting is implicitly
selected, using Insert After, you'll be able to insert a subsection after it, but this is not what you want to do. And
if you click inside the para to implicitly select it and use Insert After, the Edit tool will not suggest section at all.

You need to explicitly select the first section in order to be able to insert a second section after it. There are many
ways to do that.

• Repeatedly press Ctrl+↑, while keeping an eye on the node path bar, until you select the desired ancestor element.
(Press Ctrl+↓ if you have gone too far.)

• Repeatedly click inside an element while holding the Ctrl key down, without moving the mouse, until you select
the desired ancestor element.

• Directly click on the label of the desired element in the node path bar.
• Click on the content generated for the element you want to select: the section number in the case of the title

of a section, the bullet in the case of a listitem, etc.

Note that unlike the implicitly selected element, explicitly selected nodes have a red box drawn around them.

Figure 2.6. Explicitly selected section
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Selecting multiple nodes

A number of commands, Convert, Copy, Cut, Paste, Delete, etc, can be applied to multiple sibling3 nodes.

The node selection can be extended to preceding sibling using  Select → Extend Selection to Preceding Sibling

(Esc ←) and to following sibling using  Select → Extend Selection to Following Sibling (Esc →). All the child
nodes of an element can be selected using Select → Select All Children (Esc ↓) .

Alternatively, you can extend the node selection using the mouse by clicking elsewhere (in the direction you want
to extend the selection) while holding down the Ctrl and Shift keys.

Other commonly used commands

• We have already seen that the DocBook toolbar contains a number of buttons which invoke the Convert command.
Most the other buttons (Add para, Add table, Add image, etc) invoke the add command.

Figure 2.7. The "Add table" toolbar button

The add command is very different from the three Insert commands. The add command will find out, where
after the caret position, a given element may be inserted. If an insertion position is found, the add command will
then insert this given element.

For example, let's suppose that you want to insert an itemizedlist after the first para of the first section.
Click anywhere inside the para, really anywhere, including inside any of its descendant elements (like its em-
phasis child element), and press the Add itemizedlist button of the DocBook toolbar.

• The  Edit → Copy (Ctrl+C),  Edit → Cut (Ctrl+X),  Edit → Paste (Ctrl+V),  Edit → Delete
(Backspace, Del or Ctrl+K) commands work as expected for both the node and the text selection.

Note that in addition to the Paste command (which replaces the explicit selection by the contents of the clipboard
or which inserts the contents of the clipboard at caret position when there is no explicit selection), you also have

 Edit → Paste Before (Ctrl+U) and Edit → Paste After (Ctrl+W) commands.

Also notice that the current content of the clipboard is displayed at the bottom/left of the main window.

Figure 2.8. The Clipboard tool

• Pressing Ctrl+Enter anywhere inside a list item (whatever its element type) or a paragraph allows to quickly
add the same element after it.

3Nodes having the same parent element.

9

Getting started with XMLmind XML
Editor



• Pressing Enter anywhere inside a paragraph splits this paragraph in two parts at caret position. This is the most

common form of command  Edit → Split (Esc Enter).

• Pressing Backspace at the beginning of a paragraph preceded by an element of the same type, merges the two
elements. Same behavior if you press Del at the end of paragraph followed by an element of the same type.

These are the most common forms of command  Edit → Join (Esc Backspace).

• Pressing Ins allows to quickly add a text node. This is mainly useful in the following situation: you are typing
some text in a para. You insert a literal at caret position and continue typing some text inside the newly in-
serted literal.

Figure 2.9. Before pressing the Ins key

Now you want to resume typing text inside the para. You press Ins to quickly add a text node after the literal
and then type text in the newly inserted text node.

Figure 2.10. After pressing the Ins key

• Press Ctrl+SPACE to insert a non-breaking space at caret position.

Specifying element attributes

Implicitly or explicitly select an element and use the Attributes tool to add or modify one or more of its attributes.
For example, select the chapter root element, click in the cell containing the value of its status attribute (found
in Value, the right column of the attribute table), type draft and then press Enter.

Figure 2.11. The Attributes tool

However, in most case, you'll want to use the small form found at the top of the attribute table. Example: give an
ID to the first section:
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1. Select the section.
2. Press  Tools → Edit Attribute (Ctrl+E). This activates the Attributes tool.
3. Type in the first text field (attribute name) the first few letters of the name of the attribute you want to add or

modify. Example: type "xml:id".
4. Press Enter to select the name and move the keyboard focus to the second text field (attribute value).
5. Type the value of the attribute. Example: type "introduction".
6. Press Enter to apply the change and move the keyboard focus back to the document view. After that, you can

resume the normal editing of your document.

Composing a modular document

Let's suppose you are authoring a book but want to edit its chapters separately (because coworkers are working
on other chapters of the same book or simply because working on small documents is more convenient). How to
assemble the separate chapters to form the book?

1. Open the document containing the chapter in XMLmind XML Editor.

2. Use File → New, select DocBook v5+|Book, then click OK. This will create the book master document. Now
you need to include your chapter document module in the master document.

3. Switch to the document view containing the chapter by clicking on its tab.

4. Select the chapter root element and press  Edit → Reference → Copy as Reference (Ctrl+Shift+C).

Command Copy as Reference allows to copy to the clipboard a reference to the root element of a document or
to any element having an ID.

5. Switch back to the document view containing the book by clicking on its tab.

6. Select the first, empty, chapter of the newly created book.

7. Use  Edit → Paste(Ctrl+V) to replace this empty chapter by a reference to the chapter contained in the
separate document.

Figure 2.12. A modular book including a chapter found in a separate document
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Notice how the chapter included in the book is displayed. It has a dimmed blue-gray background, which means
that it cannot be edited from within the book document4.

If you open the modular book and want to edit one of its chapter modules, click anywhere in an included chapter

and then use  Edit → Reference → Edit Referenced Document (Ctrl+Shift+E). This will switch you to the
(editable) document view containing the chapter. From here, you can switch back to the master document view

by using  Edit → Reference → Edit Referencing Document (Ctrl+Shift+B).

4The contents of the included chapter cannot be directly modified from within the master document view. However you can freely modify
the contents of the book. For example, you can remove the chapter reference from the book or you can cut and paste it elsewhere in the
book.
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Chapter 3. Menus
1. File menu
New

Creates a new document which is a copy of a named template.

This dialog box displayed by this command contains a list of named document templates (example: Article).
A document template is listed below the name of the document type (example: DocBook) to which it belongs.

Use the URL Chooser
If this toggle is checked, XXE will display an URL chooser dialog box [74] rather than the standard file
chooser dialog box each time the user needs to specify a file name.

This toggle is present only in XMLmind XML Editor Professional Edition.

Default: not checked.

Open
Opens an existing document. Displays standard file chooser dialog box or advanced URL chooser [74] dialog
box depending on the state of the "Use the URL Chooser" checkbox [14].

Note that XXE cannot load non-well formed XML documents but it can load invalid documents. See Validity
State [71].

Tip

• It is also possible to open a document by dropping its icon anywhere inside XXE main window
(except onto ̀ `drop sites'' such as images in a document view). More information in Drag and drop
in XMLmind XML Editor [15].

• Shift-click on this menu item to open a document in read-only mode. (This tip does not work on
the Mac.)

Save
Saves the current document, but only if it has been modified.

Behaves like Save As if the current document is a newly created document or if the current document has not
the write permission for the user.

Tip

At least for XXE, you do not have to save XML documents with a .xml extension. You can use more
meaningful extensions.

Save As
Saves the current document to a different location. Displays standard file chooser dialog box or advanced
URL chooser [74] dialog box depending on the state of the "Use the URL Chooser" checkbox [14].

Save All
Saves all modified documents.

Page Setup
Selects the page size and margins used for printing. Displays standard Page Setup dialog box.

Print
Prints the current view of the current document and this, no matter what is being selected. Displays standard
Print dialog box.
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Print Selected Element
Allows to print a subset of current document. Requires one or more nodes to be explicitly selected (see Select
menu [20]). If several nodes are selected, it is the parent element of these nodes which is printed.

Quit
Quit XXE.

Below the above menu items, a menu item is added for the last nine documents which have been opened in XXE.
Selecting such menu item:

• Loads the document into XXE if it is not currently loaded.
• Reloads the document into XXE, closing all existing views, if it is currently loaded. If the document has been

modified, the user will have to confirm that changes are to be discarded.

Tip

• Shift-click on a menu item to reopen the corresponding document in read-only mode.
• Right-click on a menu item to display a file chooser dialog box. This dialog box allows to quickly and

easily choose a file found in the same directory as the recently opened file clicked upon.

The above tips do not work on the Mac.

Drag and drop in XMLmind XML Editor

It is possible to drag the text or node selection in order to drop it elsewhere, by dragging it while keeping
the left button and the Alt key pressed.

The action associated to drop depends on the nature of the object being dropped and on the drop location:

• Dropping an URL or file onto an image element changes the source file of this image.

• Dropping an URL onto an external link element changes the target of this link.

• Dropping an URL or file outside a document view or inside a document view but on elements other than
images and links opens the corresponding document in XMLmind XML Editor.

• Otherwise, dropping some text or some XML nodes inside a document view pastes that data at or after
the drop location.

1.1. "Document Set" menu

Note

This submenu is hidden by default. You need to enable it by checking "Enable the 'File|Document Set'
Submenu" in Options → Preferences, Features section.

Open Document Set
Select a file specifying a document set [57]. Displays standard file chooser dialog box or advanced URL
chooser [74] dialog box depending on the state of the "Use the URL Chooser" checkbox [14].

After the specification file is selected, XXE displays the "Document Set" tool [57] in order to let the user in-
teract with this document set.

If the selected file is a DITA map then the members of the document set are the topics referenced in this map.

If the selected file is a master DocBook document (for example a modular book including a number of chapters,
each chapter being found in its own XML file) then the members of the document set are the DocBook docu-
ments included in this master document.
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In all other cases, the content of the selected file is not analyzed by XXE. Instead, the selected file specifies
a directory and a filename extension. For example, selecting file file:/home/john/site/buy.html specifies
the "file:/home/john/site/*.html" glob pattern1. In this example, the members of the document set are
all the files found in directory file:/home/john/site/ having an "html" extension.

A glob pattern is the simplest possible specification for a document set. It is generally useful when editing the
XHTML pages composing a web site. See also ".uri_list" files, another simple way to specify document
sets [17] for a simple generalisation of such glob patterns.

Tip

Shift-clicking on the "Open Document Set" menu item forces XXE to open the simplest possible
document set, that is, the document set specified by a glob pattern. For example, if the selected doc-
ument set is file:/home/john/docs/doc.xml, a master DocBook book, Shift+click will open the
simpler document set specified by "file:/home/john/docs/*.xml".

The above tip does not work on the Mac.

Below the above menu item, a menu item is added for the last nine document sets which have been opened in
XXE. Selecting such menu item:

• Opens the document set in XXE if it is not currently opened.
• Brings the corresponding "Document Set" tool to front, if the selected document set is currently opened in XXE.

Tip

Shift-click on a menu item to open the glob pattern corresponding to selected document set. For example,
if the selected document set is file:/home/john/docs/doc.xml, a master DocBook book, Shift-click
will open the simpler document set specified by "file:/home/john/docs/*.xml".

The above tip does not work on the Mac.

1It's called a glob pattern because UNIX-style wildcards which are used here. UNIX-style wildcards are more powerful than their MS-
DOS/Windows counterparts. For example, when MS-DOS/Windows limits you to specifying "*.html", you can specify the "*.*htm*"
glob pattern to match the files having htm, html, shtml or xhtml extensions.
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".uri_list" files, another simple way to specify document set [57]s

Selecting file:/home/john/site/buy.html to specify the "file:/home/john/site/*.html" glob pattern
is great but what if your XHTML files are found in different directories and/or have various filename exten-
sions?

In such case, you'll have to create by hand a text file containing a list of glob patterns. This text file must
be given a ".uri_list" extension and must be encoded in UTF-8.

Example 1:

*.html
*.shtml

Note that nothing forces you to use wildcards. A list of plain URIs works fine too.

Example 2:

index.html
_tutorial/add_math/index.html
_tutorial/basic_edit/index.html
...
_tutorial/set_attribute/index.html
_tutorial/setup_olinks/index.html

About the format of ".uri_list" files:

• A line contains a single relative or absolute URI. A relative URI is relative to the location of the
".uri_list" file.

• You may not mix URIs having different roots in the same ".uri_list" file. For example, an ".uri_list"
file must not contain both "http://www.acme.com/*.html" and "file:/home/john/site/*.html".

• You are not limited to "file:" URIs. Virtual drive plug-ins may be used to add support for URI schemes
other than "file:".

• The basename of an URI, and only the basename, may be a glob pattern. This means that something like
"*/*.xml" is not supported.

• Open lines and lines starting with '#' are ignored.

1.2. Folder menu

Note

This submenu is hidden by default. You need to enable it by checking "Enable the 'File|Folder' Submenu"
in Options → Preferences, Features section.

Open Current Folder
Open the folder2 containing the last opened document.

Open Home Folder
Open the Home folder of the user. For example, opens /Users/john on the Mac.

Open Folder
Select a folder2. Displays standard file chooser dialog box or advanced URL chooser [74] dialog box depending
on the state of the "Use the URL Chooser" checkbox [14].

After the folder is selected, XXE displays the Folder tool [62] in order to let the user interact with this folder.

2A folder is also called a directory on some platforms.
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2. Select menu

2.1.The selection in XXE

There are three types of selection in XXE:

• text selection (also called character selection),

• node selection (a node is either a named element or an anonymous text node or an anonymous comment node
or an anonymous processing instruction node),

• implicit element selection.

2.1.1.Text selection

The text selection is the type of selection supported by all text editors and word processors.

It is, of course, possible to select text across document nodes.

Selected text is displayed as characters drawn over a pink background.

The text selection can be seen as a way to specify a range of characters and descendant nodes contained in a
common ancestor node. The copy, cut, delete, paste, convert commands will copy, delete or replace the specified
characters and descendant nodes.

• Example 1: "<p>This is our <img src="logo.png"> new logo.</p>". Selected text starts at "This" and
ends after "new" and is to be deleted.

This delete operation gives "<p> logo.</p>".

• Example 2: "<p>This is <em>great</em>, really!</p>". Selected text starts at "This" and ends after
"great" and is to be converted to <strong>.

This convert operation gives "<p><strong>This is <em>great</em></strong>, really!</p>".

How to select text in XXE:

Using the keyboardUsing the mouse

• Shift+Left or Shift+Right extends the text selection
by one character.

• Click at the beginning of the text selection and drag
the mouse to the end of selection.

• Ctrl+Shift+Left or Ctrl+Shift+Right extends the text
selection by one word.

• Ctrl+Shift+Home extends the text selection to the
beginning of the line.

• Ctrl+Shift+End extends the text selection to the end
of the line.

• Shift+Down or Shift+Up extends the text selection
by one line.

2.1.2. Node selection

The node selection is unique to XML editors.

18

Menus



In XXE, you can even select several nodes at the same time if these nodes are consecutive children of the same
parent (contiguous range of child nodes).

Selected nodes are displayed with a thin red border around them.

How to explicitly select a single node in XXE:

Using the keyboardUsing the mouse

• Click inside the node to move the caret there. Type
Ctrl+Up until you reach the node you want to select.

• Click on the node.

If some text is near the place where you have clicked,
it will ``attract'' the caret and the node will not be se- Keep an eye on the Node Path bar [43] while doing

this.lected. In such case, you are forced to Ctrl-click in-
stead of simply clicking.

• Or use the Select menu [20] or any of the correspond-
ing keyboard shortcuts Ctrl+Up, Ctrl+Down,
Shift+Ctrl+Up or Shift+Ctrl+Down.

• Or Ctrl-click on the node.

Ctrl-click several times (without moving the mouse)
if needed to. Each Ctrl-click will select the parent of
currently selected node.

Do not Ctrl-click several times too fast otherwise the
editor will think you are double-clicking or triple-
clicking and therefore, selecting elements that way
would not work.

• Or click on generated content such as a list bullet or
a section number.

• Or Ctrl-click in the blank space found at the right of
the text of a paragraph.

• Or click on the name of the element you want to select
in the Node Path bar [43].

Procedure for selecting a node range using the mouse:

1. Select first node using any of the methods described above.

Make sure that you have selected the right node by looking at the Node Path bar [43], otherwise extending the
node selection will not work.

2. Shift-Ctrl-click on the last node of the selection.

If there is no ambiguity, you can even Shift-Ctrl-click anywhere past the last node of the selection.

Procedure for selecting a node range using the keyboard:

• Esc+Down selects all child nodes of explicitly or implicitly selected element.

• OR

1. Select first node using any of the methods described above.

Make sure that you have selected the right node by looking at the Node Path bar [43], otherwise extending
the node selection will not work.

2. Adjust selected node range: Esc+Right extends node selection to following sibling and Esc+Left extends
node selection to preceding sibling.
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Note Esc+Right (and Esc+Left) will first select element containing caret if there is no explicit node selection,
therefore typing Esc+Right several times is often the quickest way to select a node range.

2.1.3. Implicit element selection

The implicitly selected element is simply the element containing the caret (also called the insertion cursor).

Being implicitly selected, this element is not drawn with a red border around it but you know it because it is the
element which is displayed in the Node Path bar [43].

All editing commands except the most generic form of Split [25] and Join [25] can be applied to the implicitly
selected element.

Important

Almost all editing commands do not require you to explicitly select the element you want to act upon.
This makes XXE at the same time efficient and easy to use.

2.2. Menu items

Tip

Clicking anywhere in the document view or any caret movement has the side effect to cancel the selection.
It is also possible to explicitly do so by typing Esc+Esc.

Menu items:

Select Parent
Selects parent of currently selected node.

If there is no currently selected node, selects the text, comment or processing instruction node containing the
caret.

Select Child
Selects previously selected child of currently selected node.

If there is no such child, selects first child node of currently selected element.

If currently selected node is a text, comment or processing instruction node, cancels the selection.

Select Preceding Sibling
Selects preceding sibling of currently selected node, if any.

Select Following Sibling
Selects following sibling of currently selected node, if any.

Extend Selection to Preceding Sibling
Adds preceding sibling, if any, of currently selected node to the node selection.

If there is no currently selected node, selects the element containing the caret.

Keyboard shortcut (not displayed in menu): Esc+Left.

Extend Selection to Following Sibling
Adds following sibling, if any, of currently selected node to the node selection.

If there is no currently selected node, selects the element containing the caret.

Keyboard shortcut (not displayed in menu): Esc+Right.
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Select All Children
Selects all children of currently selected element.

Keyboard shortcut (not displayed in menu): Esc+Down.

Link menu items:

Select Link Target
An element acting as a link source must be implicitly or explicitly selected. Scrolls to and selects the element
which is the target of this link.

DocBook example: the selected element is <link linkend="foo">...</link>. Scrolls to and selects the
element having foo as its id attribute.

Select Link Source
An element acting as a link target must be implicitly or explicitly selected. Scrolls to and selects the element
which points to this target.

DocBook example: the selected element is <para id="foo">...</para>. Scrolls to and selects first
<xref linkend="foo"/> or <link linkend="foo">...</link>.

Select Preceding Link Source
An element acting as a link source must be implicitly or explicitly selected. Scrolls to and selects the preceding
(in document order) link pointing to the same target.

Select Following Link Source
An element acting as a link source must be implicitly or explicitly selected. Scrolls to and selects the following
(in document order) link pointing to the same target.

In some cases3, the above menu items allows to select an destination found in a document other than the one being
edited. In such case, the user is prompted to confirm that she/he really wants to open this other document. This
confirmation dialog box also allows the user to choose to open the other document in read-only mode.

3. Edit menu

Tip

A simplified Edit menu will popup if the right mouse button is clicked anywhere in a document view.
Some of the menu items of this popup Edit menu have more accurate titles than those of the menu bar
Edit menu (example: "Undo Convert" instead of simply "Undo").

Undo
Undo last command.

Redo
Redo last undone command.

Repeat
Repeats last repeatable command.

Commands requiring the user to specify an argument (e.g. Replace [23], Insert Before [23], Insert [23], Insert
After [24], Convert [24], Convert [wrap] [24], Change Processing Instruction Target [26], etc) are repeatable.

Command History
Displays a dialog box listing last ten repeatable commands from newest to oldest.

Cut
Cuts

3XHTML example: link <a href="conclusion.html#acknowledgments"> found in file introduction.html.
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• text selection

• OR explicitly selected node or node range

• OR implicitly selected element

to system clipboard.

Tip

It is possible to cut and paste nodes between two instances of XXE (of course if the DTD or schema
allows it).

Copy
Copies

• text selection

• OR explicitly selected node or node range

• OR implicitly selected element

to system clipboard.

Tip

Selected characters are automatically copied as system selection on platforms supporting system se-
lection (X-Window) and automatically copied to an internal clipboard on other platforms.

Paste Before
Pastes the content of system clipboard before

• explicitly selected node or node range

• OR implicitly selected element.

The system clipboard may contain one or several nodes or just plain text. The content of system clipboard, is
parsed as XML if it begins with "<?xml" otherwise it is considered to be plain text.

Paste
Pastes the content of system clipboard replacing

• text selection

• OR explicitly selected node or node range,

OR if there is no explicit selection, pastes the content of system clipboard into

• element containing caret, at caret position.

The system clipboard may contain one or several nodes or just plain text. The content of system clipboard, is
parsed as XML if it begins with "<?xml" otherwise it is considered to be plain text.

Tip

Clicking with mouse button #2 (middle button or mouse wheel) can be used to paste the content of
system selection on platforms supporting system selection and can be used to paste the content of an
internal clipboard on other platforms (if allowed by grammar constraining the document, of course).

By default, this very handing feature is not enabled. You need to enable it using the Options dialog
box [86].

22

Menus



Paste After
Pastes the content of system clipboard after

• explicitly selected node or node range

• OR implicitly selected element.

The system clipboard may contain one or several nodes or just plain text. The content of system clipboard, is
parsed as XML if it begins with "<?xml" otherwise it is considered to be plain text.

Delete
Deletes

• text selection

• OR explicitly selected node or node range

• OR implicitly selected element.

Force Deletion
Like Delete [23] except that deletion will be performed even if the grammar constraining the document forbids
to do so.

Example 3.1. A use case for command Force Deletion

The content model of element <a> is child element <b> or a sequence of child element <c> followed by child
element <d>.

A new <a> is by default created with the simplest possible content model, that is <b>. Then how to replace
<b> by the sequence <c><d>? Deleting <b> is forbidden because it would give us an invalid <a>.

The answer is:

1. Force the deletion of <b> using the command described here. This makes <a> temporarily invalid but also
relaxes the constraints on it.

2. Insert a <c>.

3. Insert a <d>. Element <a> is now valid.

Replace
Displays the Edit tool [46]. This dialog box can be used to specify an element or a text node replacing

• explicitly selected node or node range

• OR implicitly selected element.

Insert Before
Displays the Edit tool [46]. This dialog box can be used to specify an element or a text node to be inserted
before

• explicitly selected node or node range

• OR implicitly selected element.

Insert
Displays the Edit tool [46]. This dialog box can be used to specify an element or a text node to be inserted

• into the explicitly selected element, after its last child node

• OR, if no element is explicitly selected, into the element containing the caret, at caret position.
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Insert After
Displays the Edit tool [46]. This dialog box can be used to specify an element or a text node to be inserted
after

• explicitly selected node or node range

• OR implicitly selected element.

Convert
Displays the Edit tool [46]. This dialog box can be used to specify an element or a text node replacing

• text selection

• OR explicitly selected node or node range

• OR implicitly selected element.

Unlike Replace [23] which creates an empty new element, Convert transfers the content of the selection to
the new element which is the result of the conversion.

More precisely, in the case of the node selection:

• When a single element is selected, all its children, and also all compatible attributes, are transferred to the
result of the conversion.

Example:

<simpara id="p1">The <emphasis>little</emphasis> lamb.</simpara>

converted to para gives

<para id="p1">The <emphasis>little</emphasis> lamb.</para>

• When several nodes or a single non-element node are selected, all these nodes are given a new parent element
which is the result of the conversion.

Example:

<simpara>Once upon a time,</simpara>

plus

<simpara id="p1">the <emphasis>little</emphasis> girl.</simpara>

can be converted to blockquote and that gives us

<blockquote>
  <simpara>Once upon a time,</simpara>
  <simpara id="p1">the <emphasis>little</emphasis> girl.</simpara>
</blockquote>

See also Wrap [24] a variant of Convert.

Convert [wrap]
This command is a variant of Convert [24]. The unique difference between Wrap and Convert [24] is that,
with Wrap, when a single element is selected, the selected element is given a new parent element.

Example, with Wrap (and not with Convert [24]), it is possible to give a <blockquote> parent to the following
<simpara>, when this <simpara> is implicitly or explicitly selected:
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<simpara id="p1">The <emphasis>little</emphasis> lamb.</simpara>

That is, selecting blockquote using the Edit tool [46] gives:

<blockquote>
  <simpara id="p1">The <emphasis>little</emphasis> lamb.</simpara>
</blockquote>

Split
Splits explicitly selected element in two parts, the split point being specified by caret position.

Unlike almost all other commands, this command requires the element to be explicitly selected.

Keyboard shortcut (not displayed in menu): Esc+Enter.

Tip

A less generic form of the Split command is often bound to key Enter (for example, this is the case
for XHTML and DocBook).

Typing Enter inside a paragraph (that is, <p> for XHTML and <para> or <simpara> for DocBook)
will split this element in two parts.

Example: <simpara> is explicitly selected and the caret is in the middle of word "little". Splitting

"<simpara>the <emphasis>little</emphasis> girl.</simpara>"

gives us

"<simpara>the <emphasis>lit</emphasis></simpara><simpara><emphasis>tle</emphasis>
girl.</simpara>"

Tip

Therefore, typing Enter at the end of a paragraph will create an empty new paragraph after it.

Typing Enter at the beginning of a paragraph will create an empty new pagraph before it.

Join
Joins explicitly selected element to its preceding sibling, an element of same type. This gives a single element
containing the child nodes of the two joined elements.

This command is the inverse command of Split [25].

Unlike almost all other commands, this command requires the element to be explicitly selected.

Keyboard shortcut (not displayed in menu): Esc+Backspace. It is also possible to type Esc+Del to join explicitly
selected element to its following sibling, an element of same type.

Tip

A less generic form of the Join command is often bound (for example, this is the case for XHTML
and DocBook) to
• key Backspace when the caret is at the beginning of a paragraph
• and to key Delete when the caret is at the end of a paragraph.

Typing Backspace at the beginning of a paragraph joins this element to the preceding paragraph.

Typing Delete at the end of a paragraph joins this element to the following paragraph.
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3.1. Comment menu

Insert Comment Before
Inserts comment node before

• explicitly selected node

• OR implicitly selected element.

Insert Comment
Inserts comment node into

• explicitly selected empty element

• OR element containing caret, at caret position.

Insert Comment After
Inserts comment node after

• explicitly selected node

• OR implicitly selected element.

3.2. Processing instruction menu

Insert Processing Instruction Before
Inserts processing instruction node before

• explicitly selected node

• OR implicitly selected element.

A newly inserted processing instruction uses the last target interactively specified using menu item "Change
Processing Instruction Target". If menu item "Change Processing Instruction Target" has not yet been used,
then the target of a newly inserted processing instruction is "target".

Insert Processing Instruction
Inserts processing instruction node into

• explicitly selected empty element

• OR element containing caret, at caret position.

Insert Processing Instruction After
Inserts processing instruction node after

• explicitly selected node

• OR implicitly selected element.

Change Processing Instruction Target
Displays a dialog box that can be used to change the target of

• explicitly selected processing instruction node

• OR implicitly selected processing instruction node (that is the processing instruction node containing the
caret).
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3.3. Reference menu

About the Include tool [48] feature

Some menu items are by default absent in this menu. You need to enable them by checking "Enable the
Include Tool" in Options → Preferences, Features section.

Copy as Reference
Copies to the clipboard a reference to the selected nodes (i.e. a pointer to selected nodes). This reference can
be later pasted into another document4, using any of the normal paste commands — Edit → Paste Before
(Ctrl+U), Edit → Paste (Ctrl+V), Edit → Paste After (Ctrl+W) — in places where the grammar constraining
the target document allows to do so.

This command is enabled only for documents associated to a configuration declaring a inclusion scheme (see
Section 14, “inclusionScheme” in XMLmind XML Editor - Configuration and Deployment). DITA documents
use the conref inclusion scheme. DocBook and XHTML documents use the XInclude inclusion scheme.

By default, it is possible to copy as a reference only an element having an ID attribute or the root element of
a document. However, for documents using the XInclude inclusion scheme, this restriction may be relaxed
by using Options → Preferences, Edit section, Allow advanced use of XInclude [88] checkbox. When this
option is turned on, it becomes possible to copy as a reference any range of sibling nodes.

It is not possible to copy as reference the text selection, a reference, descendant nodes of a reference or any
node selection directly containing one or more references. If you want to do so, simply use the normal Edit
→ Copy command, as this command preserves5 existing references.

Note

The pasted reference cannot be edited in place. It is displayed with a light gray background to clearly
indicate this. Use command Edit → Document Reference → Edit Referenced Document [29] (or

tool bar button ) to open a new window allowing to edit the document containing the referenced
nodes.

Replace by Reference
Replace by an element reference

• text selection

• OR explicitly selected node or node range.

The element reference to be inserted in the document is specified using the Include tool [48].

Insert Reference Before
Insert an element reference before

• explicitly selected node or node range

• OR implicitly selected element.

The element reference to be inserted in the document is specified using the Include tool [48].

Insert Reference
Insert an element reference

• replacing text selection if any,

• OR, if there is no text selection, insert an element reference in element containing caret, at caret position.

4It can also be pasted in the same document at another location.
5But, unlike Edit → Reference → Copy as Reference, it cannot create references.
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The element reference to be inserted in the document is specified using the Include tool [48].

Insert Reference After
Insert an element reference after

• explicitly selected node or node range

• OR implicitly selected element.

The element reference to be inserted in the document is specified using the Include tool [48].

Include Text
Displays a file chooser dialog box allowing to choose a text file (of any kind: XML, HTML, .bat, C/C++,
etc). The content of this text file is then included in the document being edited at caret position.

This kind of inclusion is implemented by the means of an <xi:include parse="text"> element. Therefore,
this command is disabled unless the document being edited supports the XInclude inclusion scheme.

Untransclude Reference
Replaces included nodes by the inclusion directive (e.g. xi:include element).

Any kind of selection inside the included nodes suffices to specify the subject of this command.

Untransclude All
Replaces all the included nodes found in the document being edited by the corresponding inclusion directives.

Retransclude Reference
Inverse action of Untransclude Reference [28]: replaces inclusion directive (e.g. xi:include element) by
up-to-date included nodes.

The inclusion directive must be explicitly or implicitly selected.

Using untransclude allows to edit the inclusion directive by hand before retranscluding it. This is useful in
the two following cases:

• This allows to add attributes (typically an ID) to the conref elements created using Copy As Reference
then Paste.

• This allows to fine tune the xpointer attribute of the XIncludes created using Copy As Reference then
Paste. Example: replace xpointer="xpointer(id('disclaimer')/*[position() >= 1 and position()
<= 8])" by, simpler and more stable, xpointer="xpointer(id('disclaimer')/*)".

Retransclude All
Replaces all the inclusion directives found in the document being edited by the corresponding included nodes.

Edit Referencing Document
If current document is referenced by another document already opened in XXE and displayed in another
window, this command brings the window of this other document to front. If there is no such referencing
document, this command is silently disabled.

Example 3.2. Example: book referencing chapters

Book book.xml references chapters chap1.xml, chap2.xml, chap3.xml, etc, created in separate documents.

Clicking anywhere inside first chapter displayed in the book.xml window then using command Edit → Doc-

ument Reference → Edit Referenced Document [29] (or tool bar button ) brings the window containing
chap1.xml to front. (If needed, chap1.xml is opened in XXE.)

Now being inside the chap1.xml window, using command Edit → Document Reference → Edit Referenced

Document [29] (or tool bar button ) brings the window containing book.xml to front.
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Edit Referenced Document
If the caret or the selection is inside a reference to an element contained in another document, this command
brings the window of this other document to front. If the referenced document is not yet opened in XXE, this
command will open it.

See example [28] above.

Tip

Shift-click on this menu item to open referenced document in read-only mode.

4. Search menu
Search

Displays the Search tool [52] configured for a search session from the current caret position6 to the end of
the document.

Search Backwards
Displays the Search tool [52] configured for a search session from the current caret position6 to the beginning
of the document.

Replace
Displays the Search tool [52] configured for a search/replace session from the current caret position6 to the
end of the document.

Replace Backwards
Displays the Search tool [52] configured for a search/replace session from the current caret position6 to the
beginning of the document.

Find Next
Search last searched string from the current caret position to the end of the document. The Search tool [52]
is not displayed because it is not needed to perform this operation.

Find Previous
Search last searched string from the current caret position to the beginning of the document. The Search
tool [52] is not displayed because it is not needed to perform this operation.

Find Element
Displays the Find Element dialog box [76]. This dialog box allows to select nodes specified using an XPath
expression. This dialog box has a Simple tab which allows to perform most common search tasks without
having to learn XPath. Arbitrarily complex XPath expressions are specified using the Advanced tab.

Keyboard shortcut: Esc f (F like Find).

Find Element Again
Repeat last search. The Find Element dialog box [76] is not displayed because it is not needed to perform this
operation.

Keyboard shortcut: Esc g (G like aGain).

4.1. Bookmark menu

 This submenu is available in all editions of XMLmind XML Editor, but is hidden by default. You need to enable
it by checking "Enable the Search|Bookmark Submenu" in Options → Preferences, Features section.

6Turning off the "Start from current caret position" option allows to start searching from the beginning of the document (or from the end of
the document depending on the Direction option).
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Set/Clear
If the caret is located on a bookmark, remove this bookmark. Otherwise, add a bookmark at caret position.

Keyboard shortcut: Esc b (B like Bookmark).

Clear All
Remove all bookmarks, if any.

Go to Last Visited or Go Back
Move the caret to the last visited bookmark. If the caret is already located on the last visited bookmark, move
the caret back to its initial position. This menu item allows to move back and forth from the place where a
user is typing some text to the last visited bookmark.

What is the last visited bookmark?

• The last visited bookmark is the bookmark last selected using the menu items described below.

• A newly added bookmark is automatically made the last visited bookmark.

Keyboard shortcut: Esc j (J like Jump).

Go to Preceding
Move the caret to the bookmark whose position in the document is before the caret. That makes this bookmark
the last visited one (see Go to Last Visited or Go Back [30]).

Go to Following
Move the caret to the bookmark whose position in the document is after the caret. That makes this bookmark
the last visited one (see Go to Last Visited or Go Back [30]).

Below the above menu items, a menu item is added for the last nine bookmark which have been added to the
document being edited. Selecting a menu item moves to caret to the corresponding bookmark and thus, makes it
the last visited bookmark (see Go to Last Visited or Go Back [30]).

5. View menu
Redraw

Rebuilds the view of the whole document, no matter which text or nodes are selected.

Updating the references contained in a modular document

This command has also the side-effect of automatically updating all the references contained in a
modular document (see Copy as Reference [27]). However for a reference to be updated, the referenced
document must not have been modified in XXE and not yet saved to disk.

Example: document book.xml references chap1.xml, chap2.xml and chap2.xml. File chap1.xml,
currently opened in XXE, has been modified then saved to disk. File chap2.xml is not currently
opened in XXE. File chap3.xml, currently opened in XXE, has been modified but not yet saved to
disk. Using this command will update what has been included from chap1.xml and chap2.xml, but
not from chap3.xml, before rebuilding the view of book.xml.

Text Size
The items of this menu make it easy changing the base font size of the active document view, whether styled
or not.

Tip

Use your mouse wheel while pressing the Ctrl key (Cmd key on the Mac) rather than use the Larger
and Smaller menu items.
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Larger
Use a base font size larger by 2pt for the active document view. The largest possible base font size is
24pt.

Smaller
Use a base font size smaller by 2pt for the active document view. The smallest possible base font size is
8pt.

Normal
Use the ``normal'', default, base font size (e.g. 12pt).

Use as Default
If the active document view is a tree view, apply the current font size to all the opened tree views and
from now, use it as a default. If the active document view is a styled view, apply the current font size to
all the opened styled views and from now, use it as a default.

This is a handy alternative to specifying the default base font size in the Preferences dialog box. The default
base font size is specified in the Preferences dialog box by "Default font size" [89] for the styled view
and by "Base font size" [90] for the tree view.

Display Images

 This submenu is available in all editions of XMLmind XML Editor, but is hidden by default. You need to
enable it by checking "Enable the View|Display Images Submenu" in Options → Preferences, Features section.

Specifies how images are displayed in the active styled document view.

Normally
Display the image normally, that is, possibly scaled if this has been specified using attributes such as
width and height.

as Thumbnails
Show the bounding box of the (possibly scaled) image and, if there is enough room in this rectangle, also
show a thumbnail (at most 128x128 pixels large).

as Bounding Boxes
Show the bounding box of the (possibly scaled) image.

Use as Default
Apply the current display mode to all styled document views and from now, use it as a default.

This is a handy alternative to specifying the default display mode in the Preferences dialog box [89].

Note

• Options "as thumbnails" and "as bounding boxes" have no effect on images having an intrinsic
size smaller than 32x32 pixels. Such small images are always displayed normally.

• If the bounding box is sufficiently large, it is used to display the thumbnail (when option "as
thumbnails" has been selected) and useful information about the image (file size, image size, etc).

However, when the bounding box is small, some information may be elided. Therefore do not be
surprised if you have selected option "as thumbnails" and that for some images, you don't see any
thumbnail. Also do not be surprised if some bounding boxes contain useful information about the
image and other (smaller) bounding boxes are completely empty.

Add
Opens a dialog which allows to add a new view to current document tab. A document tab can contain up to
5 views: default central view, but also top, right, bottom, left views. A view is specified by selecting a CSS
style sheet among the available ones or, on the contrary, by selecting no style sheet at all, which implies to
use a tree view.
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Close
Closes active view. Central view, which is supposed to be the main view, cannot be closed.

The active view is the view having the keyboard focus: the caret blinks in this view, and not in the other views
of the document. To make a view the active one, simply click anywhere in it.

Below the above menu item, a menu item is added for each CSS style sheet available for current document. Selecting
the name of a style sheet causes the document view to use this style sheet. If a document view already uses the
selected style sheet, the style sheet is reloaded from its file (which is very handy when developing a new CSS style
sheet).

6.Tools menu
Declare Namespace

Displays Declare Namespace dialog box [77].

If the current document is conforming to a DTD, the dialog box allows to view the namespaces and their
prefixes but not to modify them.

Edit Attribute
Displays Attributes tool [49].

Check Validity
Displays Validity tool [57], unless no validity errors are found in current document, in which case an OK
message is displayed in the status bar.

This command is disabled if current document is not constrained by a grammar.

Tip

Current document validity is automatically checked each time the document is saved, therefore unless
you are fixing an invalid document you don't really need to explicitly use this command.

Check Spelling
Displays the Spell tool [54], unless no spelling errors are found in current document7, in which case an OK
message is displayed in the status bar.

Automatic Spell Checker
Toggle used to activate and deactivate the automatic (AKA on-the-fly) spell checker. See also option "Activate
if this is specified in the configuration file [92]".

This menu item is present only in XMLmind XML Editor Professional Edition.

Execute Command
For advanced users only. Displays a dialog box which allows to choose a command by name. This is needed
when a command is not bound to a keystroke, menu item or tool bar button. Example: command convertCase
(see Section 13, “convertCase” in XMLmind XML Editor - Commands). This facility is especially useful when
recording a macro-command [35].

6.1. Helper Application menu

This menu contains entries allowing to use third-party applications to view or edit part or all of the document being
edited.

7By default, spell checking starts at the current caret position, but this can be changed by turning off the "Start from current caret position"
option of the Spell tool.
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Open Element or Attribute Content in Helper Application
Requires an element to be implicitly or explicitly selected. Displays a dialog box allowing the select this element
or one of its attributes from a list.

Opens specified element or attribute in a third-party ``helper'' application. If the helper application cannot be
determined automatically (because it has not yet been registered using the Preferences dialog box, Helper
Applications section), the user is prompted to specify it.

Figure 3.1. The "Helper Application Not Found" dialog box

Example of use: use your web browser to open the page referenced in the url attribute of the (DocBook 4)
ulink element.

Edit Element or Attribute Content in Helper Application
Same as above except that the helper application is assumed to be an editor. If this editor is used to modify
the element or attribute, then the changes are also automatically applied to the document being edited.

This command works as follows: let's suppose the element of interest contains an image encoded using base
64 (data type xs:base64Binary).

1. This command examines the first bytes of the image and, using this signature, determines which helper
application to use.
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2. If the helper application cannot be determined (because it has not yet been registered using the Preferences
dialog box, Helper Applications section), the user is prompted to specify it.

3. It reads the image data from the element, decodes it and saves it to a temporary file.

4. It starts the helper application, an image editor, passing it the file containing the extracted image.

5. After the user quits the image editor, the command detects whether the extracted image has been modified
and, if this is the case, reloads it in the element.

Examples of use: use GIMP to edit the image file referenced in the src attribute of the (XHTML) img element.
Use Inkscape to edit the svg:svg element contained in an (DocBook 5) imagedata element.

Open Document in Helper Application
Opens the document being edited in a third-party ``helper'' application. If the helper application cannot be
determined automatically (because it has not yet been registered using the Preferences dialog box, Helper
Applications section), the user is prompted to specify it.

This entry is disabled if the document is newly created and has not yet been saved. Also note that this command
is guaranteed to fail if the document is stored on the Windows file system and is currently write-locked by
XMLmind XML Editor.

Example of use: use your web browser to preview the XHTML document being edited.

Edit Document in Helper Application
Same as above except that the helper application is assumed to be an editor. XMLmind XML Editor will
automatically reload the document after the third-party editor is used to modify it.

This entry is disabled if the document is newly created and has not yet been saved. Also note that this command
is guaranteed to fail if the document is currently write-locked by XMLmind XML Editor.

Example of use: use your favorite text editor to perform some low-level modifications on the XML document
being edited.

6.2. Spreadsheet menu

 This menu is available only in XMLmind XML Editor Professional Edition, where it is hidden by default. You
need to enable it by checking "Enable the Integrated Spreadsheet Engine" in Options → Preferences, Features
section.

Show Table Labels, Hide Table Labels
Makes tables look like spreadsheets by adding A1-style labels to their columns and to their rows. This is very
useful when you want to type cell references such as A1:C3 in a formula.

Insert/Edit Formula
If a formula (xxe-formula processing instruction) is explicitly selected, a specialized formula editor is opened
to allow the user to modify the formula.

Otherwise, a specialized formula editor is opened to allow the user to insert a new formula at caret position.
Inserting a new formula in an empty element works too: simply explicitly select this empty element and use
this menu item.

Disable Selected Formulas, Enable Selected Formulas
Disables/enables all the formulas (xxe-formula processing instruction) found in the explicit node selection
or in the text selection.

Disabling a formula means passivating it. That is, it is no longer used to update the document. In some cases,
this is a handy alternative to removing it.
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Tip

In the styled view, formulas are represented by a small F icon. Clicking on this icon with the middle
button of the mouse allows to switch the state of the formula from enabled  to disabled  and vice-
versa.

Remove Selected Formulas
Remove all the formulas (xxe-formula processing instruction) found in the explicit node selection or in the
text selection.

Auto-update Mode
This toggle may be used to switch from auto-update mode to manual update mode.

In manual update mode, only newly inserted formulas are computed. To force a full calculation, the user has
to explicitly use the Update command below.

In auto-update mode, a full calculation is automatically performed, if needed to, when the editing context
changes. For example: type some text in a paragraph, then click in (or tab to) another paragraph to trigger a
spreadsheet calculation.

Note that in both modes, a full calculation is automatically performed, if needed to, before validating or saving
the document.

Using manual update mode is recommended if you have a slow computer or if you have inserted a lot of for-
mulas in your document or if your formulas access many external documents.

See also Spreadsheet options [93].

Update
Forces a full calculation of the spreadsheet.

6.3. "Record Macro" menu

This menu allows to record a sequence of commands and to replay the recorded sequence at will.

This facility used in conjunction with Select → Find Element [20] facility or with the Search [52] tool may be
seen as an advanced, versatile, yet simple to use, form of search/replace.

Start
Starts recording a sequence of commands.

Stop
Stops recording the sequence of commands.

Cancel
Cancels the recording of a sequence of commands.

View
Displays a dialog box containing recorded macro in XML form. Very handy to paste it in an XXE configuration
file (see Section 3, “command” in XMLmind XML Editor - Configuration and Deployment).

Replay
Replays recorded sequence of commands.

Procedure 3.1. Procedure for recording a sequence of commands

1. Use the Start menu item.

2. Invoke commands as usual: use key bindings, menu items and tool bar buttons.
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Typing some text is of course supported. ``Tabbing'' from a text node to another is supported too.

The following tools can also be used during a recording: Edit [46], Attributes [49], Search [52], Charac-
ters [56].

If you use the Search tool during a recording, just use the search part; do not use the replace part. And after
the searched string is found and selected, click on the Stop button of the Search tool to give keyboard focus
back to the document view. This will allow you to continue adding more commands to the recorded sequence.

3. Use the Stop menu item.

Only editing commands can be recorded. That is, commands that modify the contents and/or the selection marks
of the document being edited. Actions such as File → Open or View → Add cannot be recorded.

At most 20 commands can be recorded. Typing contiguous characters, no matter how many, counts as a single
command.

Attempting to record the following commands will automatically cause macro recording to be canceled:

• any command triggered by a mouse click,

• Undo [21], Redo [21], Repeat [21],

• any command which fails (example: searching a string and this string is not found),

• any command which cannot be executed given current editing context (example: pasting some text to a place
where the schema forbids to do so).

Recording interactive command such as Insert After [24] works as expected: it is the command along with the
element interactively chosen by the user which is recorded, and not the interactive invocation of Edit+Insert After
(i.e. which activates the Edit tool or which displays the equivalent dialog box).

Recording command Execute Command [32] is fully supported and works as expected: it is the command executed
by Tools → Execute Command which is recorded, and not the invocation of Tools → Execute Command.

7. XML menu
This menu is a placeholder for menu specific to an XML applications, possibly defined in an XXE configuration
file.

For example, such menu is defined for XHTML. When an XHTML document is loaded into XXE, the XML menu
is automatically populated with items and its title changes from "XML" to the title declared in the configuration file
(example: "XHTML").

8. Options menu
Preferences

Displays the Preferences dialog box [80] which allows to specify a large number of user preferences.

Reload All Configurations
Reloads all configuration files found by XXE at startup time. This command is disabled if one or more docu-
ments are opened in the editor.

Without this command, testing modifications made to an existing configuration requires you to restart the
editor. Note that restarting the editor is still required to make it discover new configurations or to reload support
code (i.e. .jar files).

 This menu item is available in all editions of XMLmind XML Editor, but is hidden by default. You need
to enable it by checking "Enable the Developer Tools" in Options → Preferences, Features section.
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Install Add-ons
Displays the Install Add-ons dialog box [104], which allows to download and install, upgrade and uninstall all
sorts of add-ons. This dialog box is not available if XXE has been deployed using Java™ Web Start.

Tip

If you hold the Shift key and click on Options → Install Add-ons, you'll be able to automatically
upgrade all the installed add-ons (of course, if any and if needed to).

Note

This menu item is absent when XMLmind XML Editor has been started using Java™ Web Start.

8.1. "Customize Configuration" menu

This menu is present only in XMLmind XML Editor Professional Edition.

This menu allows end-users (i.e. non-experts) to customize the configuration associated to the document being
edited.

End-user customization of configurations by the means of this menu also works when XMLmind XML Editor is
deployed using Java™ Web Start.

The following menu items have an effect on a single configuration: the configuration of the document being edited.
For example, if you specify DocBook XSL style sheet parameter paper.type=USLetter when you are editing a
DocBook document, this will have no effect on the DocBook 5 and Simplified DocBook configurations, even if
these configurations share their Convert Document menu with the DocBook configuration.

Using any of the following menu items has an immediate effect on all the opened documents associated to the
customized configuration. That is, no need to restart XXE to benefit from the customization.

Save Document As Template
Save the document being edited as a named template. This named template is then displayed in the File →
New dialog box.

This menu item is disabled (grayed) if the document being edited has been modified and thus, needs to be
saved. Therefore you need to save the document being edited to disk prior to using this facility.

Arbitrarily complex documents may be used as templates: a document may be modular, may reference
graphics files, etc. This is needed for example to create a document template including the logo of a company.

User-defined document templates are added and removed using the "Save Document As Template" dialog
box [105].

Save Selected Element As Template
Save the selected element as a named template. This named template may then be suggested by the Edit tool,
depending on the operation to be performed and if this is allowed by the schema.

This menu item is disabled (grayed) unless an element is explicitly selected.

User-defined elements templates are added and removed using the "Save Selected Element As Template"
dialog box [107].

Save Views As Default
Save the current layout of views as the default one. Displays a simple confirmation dialog box.

Example 1: you want the CSS style sheet called "Show info about included elements" to be used by default
for all your DocBook documents.

1. Open a DocBook document.
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2. Select CSS style sheet called "Show info about included elements" in the View menu.

3. Use Options → Customize Configuration → Save Views As Default.

4. Open another DocBook document (or use File → New to create a new one) to check that your customiz-
ation has worked.

Example 2: when you open a DocBook document, you want to see the styled view in the middle, the tree view
at the left and the structure view (i.e. CSS style sheet called "Document Structure") at the bottom.

1. Open a DocBook document.

2. Use View → Add. Select "(no style sheet)" for the Left pane. Select "Document structure" for the Bottom
pane.

3. Use Options → Customize Configuration → Save Views As Default.

4. Open another DocBook document (or use File → New to create a new one) to check that your customiz-
ation has worked.

Add Keyboard Shortcut
Add keyboard shortcuts. In other terms, bind up to two keystrokes (example: "F2 u" to a command (example:
"moveElement up[implicitElement]").

User-defined keyboard shortcuts are added and removed using the "Add Keyboard Shortcut" dialog box [110].

Change Document Conversion Parameters
Change the XSL style sheet parameters (e.g. paper.type=USLetter) used when converting the document
being edited to other formats (e.g. PDF, HTML, etc).

User-defined XSL style sheet parameters are specified using the "Change Document Conversion Parameters"
dialog box [115].

9. Window menu
Split Windows Vertically

Clicking on the dashed line found at the bottom of the tab of a document view causes the window area to be
split in two parts. This allows to see two documents side by side.

If this option is turned on, the window area is split vertically. If this option is turned off (the default), the
window area is split horizontally.

Note that turning this option on and off has an immediate effect on the window area, if this area has already
been split in two parts.

Default: not checked.

Close
Closes active document.

Close All
Closes all opened documents.

Show Preceding
Displays preceding (in the order the documents have been opened or created) document tab.

Show Following
Displays following (in the order the documents have been opened or created) document tab.
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Below the above menu items, a menu item is added for each document opened in XXE. Selecting the name of a
document in this list causes this document to become the active one and thus, causes the corresponding tab to be
displayed.

10. Help menu
Getting Started

Displays a short tutorial in the help browser.

Full Tutorial
Displays the Tutorial page, which is part of the XMLmind XML Editor web site, in the web browser.

Help
Displays the help browser.

Help About
In order to display the help section related to a specific GUI component of XXE, first execute this command
(the cursor changes signaling that you are now in contextual help mode) and then click on that component.

Full Documentation Set
Displays the Documentation page, which is part of the XMLmind XML Editor web site, in the web browser.

Show Content Model
Opens a window containing an hypertext reference manual listing all elements and attributes specified in the
DTD, W3C XML Schema or RELAX NG schema of the document being edited.

This manual, which is organized like "DocBook: The Definitive Guide" by Norman Walsh and al., is intended
to help content authors understand the DTD or schema of the document being edited.

Mouse and Key Bindings
Displays a dialog box containing the mouse and key bindings (that is, the mouse or keyboard user interaction
used to trigger a command) that can be used in current document view.

 This menu item is available in all editions of XMLmind XML Editor, but is hidden by default. You need
to enable it by checking "Enable the Developer Tools" in Options → Preferences, Features section.

Plug-ins
Displays a dialog box containing information about all plug-ins currently loaded into XXE.

 This menu item is available in all editions of XMLmind XML Editor, but is hidden by default. You need
to enable it by checking "Enable the Developer Tools" in Options → Preferences, Features section.

Check for Updates
Displays a dialog box informing you about the availability of a version of XXE which is newer than the one
you are currently using.

This dialog box contains check box "Automatically check for updates". This option is turned on by default.
It allows to automatically check for updates8. This automated check is performed behind the scene, every 24
hours, once per editing session, 2 minutes after XXE has been started.

Install Evaluation Key
Allows to transform XMLmind XML Editor Personal Edition to an Evaluation Edition by installing an eval-
uation key.

XMLmind XML Editor Evaluation Edition has exactly the same features as Professional Edition. It may not
be used for purposes other than the evaluation of the Professional Edition product. The evaluation period lasts

8This feature is really unobtrusive and does not transmit any data to our servers.
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seven days. After that, XMLmind XML Editor automatically and silently returns to its initial Personal Edition
state.

This menu item displays a dialog box allowing to specify the file containing the evaluation key.

This evaluation key must have been downloaded from http://www.xmlmind.com/xmleditor/evaluate.html.

This menu item basically checks the validity of the evaluation key and then copies it to XXE_user_prefer-
ences_directory/evaluationKey.properties. After that, suffice to restart XMLmind XML Editor to ac-
tivate all the features of Professional Edition.

This menu item is absent from XMLmind XML Editor Professional Edition.

About XMLmind XML Editor
Displays the customary About dialog box.

Shift-clicking on this menu item9 adds more information (system properties, environment variables) to the
About dialog box and at the same time, copies the contents of the dialog box to the clipboard. Doing this is
recommended before sending a bug report to xmleditor-support@xmlmind.com.

9This cannot work on the Mac.
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Chapter 4.The document view area
Figure 4.1. Tab corresponding to the active document

Figure 4.2. Tab corresponding to the active document when it is in read-only mode

Notice that the tab of a read-only document has a permanent dark gray indicator at its left. This contrasts with the
tab of an editable document which is given a green indicator when this document has been modified and the changes
need to be saved to disk.

The tabs of documents belonging to the same document set [57] are all given the same background color as the
corresponding "Document Set" tool [57].

Items of the right-click popup menu:

Move Tab to the Opposite Side
Moves this tab to the opposite side of the document view area. When several documents are opened in XMLmind
XML Editor, this has the effect to split the document view area in two parts. See also Window → Split Windows
Vertically [38].

This is equivalent to clicking on the dashed line found at the bottom of a tab.

Read-only Document
This check box may be used to switch the active document from its normal, read-write, mode to a read-only
mode and the opposite way round.

Making a document read-only is useful in the following cases:
• You want to open a document without locking it (because doing so would prevent your coworkers from

modifying it).
• You want to make sure that you'll not be able to modify the opened document by mistake.

Note that there are several ways to directly open a document in read-only mode. Example: Shift-click on File
→ Open [14] menu item or on the Open button of the main tool bar [42].

Close Document
Closes the active document and switches to the next document opened in XMLmind XML Editor, if any.

This is equivalent to clicking on the blue cross found at the right of the tab.

41



Chapter 5. Main tool bar
 New

See File → New [14].

 Open
See File → Open [14].

Tip

Shift-click on this button to open a document in read-only mode.

 Save
See File → Save [14].

 Save All
See File → Save All [14].

 Undo
See Edit → Undo [21].

 Redo
See Edit → Redo [21].

 Repeat
See Edit → Repeat [21].

 Command History
See Edit → Command History [21].

 Cut
See Edit → Cut [21].

 Copy
See Edit → Copy [22].

 Paste Before
See Edit → Paste Before [22].

 Paste
See Edit → Paste [22].

 Paste After
See Edit → Paste After [23].

 Delete
See Edit → Delete [23].

 Split
See Edit → Split [25].

 Join
See Edit → Join [25].
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Chapter 6.The node selection bar
1.The node path bar
The node path bar displays the path of

• selected node if a single node has been selected

• OR first selected node if a node range has been selected

• OR node containing the caret otherwise (even if there is a text selection).

The path of a node is

• the name of the element if the node is an element,

• #text for a text node,

• #comment for a comment node,

• #processing-instruction for a processing instruction node,

preceded by the path of its parent element.

The node path bar is a very convenient tool for selecting nodes, duplicating and deleting elements:

CommandUser interaction in the node path bar

Selects this node.Click on node name.

Selects this element and then creates a new element of
same type (if the grammar constraining the document
allows to do so) after this element.

Ctrl-click on element name.

Selects this element and then creates a new element of
same type (if the grammar constraining the document
allows to do so) before this element.

Shift-click on element name.

Displays a popup menu with the following items:

Insert Same Element After
Same as command triggered by Ctrl-click on element
name.

Click on element name with right mouse button.

Insert Same Element Before
Same as command triggered by Shift-click on ele-
ment name.

Delete
Selects the node clicked upon and then deletes it (if
the grammar constraining the document allows to
do so).

Drag and drop in another application, the location of the
document being edited in XXE.

Drag the file icon 

Do not forget to save the document being edited in XXE
before dropping its location in a viewer application.

See also Drag and drop in XMLmind XML Editor [15].
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1.1. Non-editable nodes

The path of a non-editable node is displayed using a dimmed color. A non-editable node has been pasted in the
document being edited after using command Copy as Reference [27].

In order to modify such node, one must edit the document containing it in a separate window. A convenient way
to do this is to use the buttons [44] which are at the left of the node path bar.

1.2. Elements which are in non-validating mode

Normally, XMLmind XML Editor works in validating mode. In such mode, the author can only do the editing
operations which are allowed by the DTD or schema. For example, the author cannot remove required attributes
(unless he/she uses Force Removal).

When an element is found to be invalid, XMLmind XML Editor automatically switches to a lenient editing mode
for this element and all its descendants.

After the invalid element is fixed by the author, XMLmind XML Editor automatically switches back to its normal,
validating, mode.

• An element underlined in orange means that this element is in non-validating mode 1. In this mode, XMLmind
XML Editor still suggests the right attributes and child elements to the author. But these are only suggestions:
the author may add and remove any attributes and child elements he/she wants, and this, at any place and in any
number.

• An element underlined in red means that this element is in non-validating mode 2. In this mode, XMLmind
XML Editor is not able to suggest the right attributes and the right child elements to the author. The author may
add and remove any attributes and child elements he/she wants, at any place and in any number.

Note that, in the case of certain RELAX NG schemas, XMLmind XML Editor may automatically switch to a lenient
editing mode, even if the underlined element is perfectly valid. This behavior is explained in great details in XMLmind
XML Editor - Support of RELAX NG Schemas.

2. Navigation tool bar

 Find Element
See Search → Find Element [29].

 Select Link Target
See Select → Link → Select Link Target [21]

 Select Link Source
See Select → Link → Select Link Source [21]

 Edit Referenced Document
See Edit → Document Reference → Edit Referenced Document [29].

Tip

Shift-click on this button to open referenced document in read-only mode.
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 Edit Referencing Document
See Edit → Document Reference → Edit Referencing Document [28].
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Chapter 7.Tools
It is possible to display two tools at the same time. By default, XMLmind XML Editor displays both the Edit tool
and the Attributes tool. If you don't like this layout or if your screen resolution is too low to allow this, simply
click on the ``tear-off'' dashed line found in the Edit tab. This will move the Edit tool back to the pane containing
all the other tools.

More generally, clicking on the ``tear-off'' dashed line found in a tab may be used to split the tabbed pane in two
parts and/or move a tab from one part to the other. Of course, the divider used to separate the two parts may be
dragged to resize these parts.

1. Edit tool
This tool works in two steps:

1. Click on one of the following buttons:

 Replace
(See Edit → Replace [23] for a complete description of the command.)

 Insert Before
(See Edit → Insert Before [23] for a complete description of the command.)

 Insert
(See Edit → Insert [23] for a complete description of the command.)

 Insert After
(See Edit → Insert After [24] for a complete description of the command.)

 Convert
(See Edit → Convert [24] for a complete description of the command.)

 Convert [wrap]
(See Edit → Convert [wrap] [24] for a complete description of the command.)

This first action just fills the list below these buttons with all the allowed arguments (element name or text
node) for the selected command.

2. Choose an element name from the list or type its name in the text field. It is this second action which actually
triggers the command.

Procedure for specifying an argument for one of the editing commands described above:

• An element is specified by clicking on its name in the list. A single click is sufficient.

If the selected operation allows to specify a text node as its argument, the list contains not only element names
but also a "(text)" item.

• Alternatively, the element name can be specified using the text field above the list:

1. Type the element name in the field (or type "(text)" if this item is found in the list).

2. Press Enter or click on the  OK button.
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Tip

The text field supports auto-completion.

This auto-completion feature can be configured using the Options dialog box [87].

• Type Esc or click on the  Cancel button to cancel current command and to clear the form.

Procedure for specifying an element argument when the command is applied to an element of the unconstrained
type:

1. Type any element name in the text field.

Note

If the namespace of the element name has not been declared, you will have to declare it using Tools
→ Declare Namespace [32] before being allowed to specify this name.

2. Press Enter or click on the  OK button.

The type of an element is unconstrained if

• the element is contained in a document which is not constrained by a grammar,

• OR the content of the element is invalid according to the grammar used to constrain the document.

• OR the content of an ancestor of the element is invalid according to the grammar used to constrain the
document.

In all cases, XXE allows the user to add or remove any child element or text node.

In the second case, fixing the invalid element will automatically make it recover its actual, constrained, type.

Procedure for specifying an element argument that matches an element wildcard:

1. Type an element name that matches the wildcard in the text field.

Note

If the namespace of the element name has not been declared, you will have to declare it using Tools
→ Declare Namespace [32] before being allowed to specify this name.

2. Press Enter or click on the  OK button.

XXE will of course check that the name you have typed conforms to the element wildcard.

Using a W3C XML Schema or a RELAX NG schema (but not a DTD), it is possible to specify an element
type which constrains some of its child elements just to belong to a certain set of namepaces and nothing
more.

The set of allowed namespaces is called a wildcard.
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2. Include tool

Note

The Include tool is hidden by default. You need to enable it by checking "Enable the Include Tool" in
Options → Preferences, Features section.

2.1. Working with ``XML variables''

The Include tool is designed to make it quick and easy inserting ``XML variables'' in your documents.

XML variables are often-used contents: product names, product versions, copyright information, addresses, phone
numbers, etc, you need to reference in almost all your documents.

XML variables are best modelled by elements having a weak semantic and which may be inserted almost anywhere
in a document. In the case of XHTML, this element is span. In the case of DocBook, this element is phrase.

XML variables are generally collected in a single, centralized, ``pseudo-document'', created for this sole purpose.

You'll insert references to XML variables, and not copies, in your actual documents.

By working this way, if one day, the value of an ``XML variable'' changes, you don't need to manually update all
the documents making use of this value.

Unlike the Copy As Reference/Paste (Ctrl+Shift+C/Ctrl+V) approach described in the tutorial, which is a generic
way to compose any kind of modular documents, the Include tool is specialized in XML variables. For example,
do not attempt to use this tool to insert in a modular book the references to its chapters.

2.2. Using the Include tool

First of all, specify the filename or URL of the document containing all your XML variables.

This is done once for all. Up to 5 documents may be added to the list displayed by the "Contained in document"
combobox. Specified documents are remembered in order to be reused in subsequent editing sessions.

• Use the  button to add a filename or URL to the list displayed by the "Contained in document" combobox.

• Use the "Contained in document" combobox to select the document containing your XML variables.

• Use the  button to remove currently selected document from this list.

If you attempt to add an invalid (non-XML or non well-formed) or useless (contains no elements having an ID)
document to the list, you'll be informed of this fact just once and the document will nevertheless be added to

the list. In such case you'll have to use the  button to explicitly remove it from the list.

After that, the tool works in two steps:

1. Click on one of the following buttons:

 Replace by Reference
(See Edit → Reference → Replace by Reference [27] for a complete description of the command.)

 Insert Reference Before
(See Edit → Reference → Insert Reference Before [27] for a complete description of the command.)

 Insert Reference
(See Edit → Reference → Insert Reference [27] for a complete description of the command.)
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 Insert Reference After
(See Edit → Reference → Insert Reference After [28] for a complete description of the command.)

This first action just fills the list below these buttons with all the allowed arguments (element ``identifiers''
and/or "-") for the selected command.

This list will only show elements:

• directly contained (that is, not themselves included) in the document selected by the "Contained in document"
combobox,

• AND which may be copied as reference (generally this means that such element has an ID),

• AND allowed by the schema given the chosen command and the current selection.

The root element, when listed, is specified as "-".

2. Choose the identifier of the element (or "-") from the list or type it in the text field. It is this second action which
actually triggers the command.

Procedure for specifying an argument for one of the commands described above:

• The identifier of the element (or "-") is selected by clicking on it in the list. A single click is sufficient.

• Alternatively, the identifier of the element (or "-") can be specified using the text field above the list:

1. Type the identifier of the element (or "-") in the field.

2. Press Enter or click on the  OK button.

Tip

This text field supports auto-completion.

The auto-completion feature can be configured using the Options dialog box [87].

• Type Esc or click on the  Cancel button to cancel current command and to clear the form.

3. Attributes tool
• There are two methods for adding or changing the attributes of the (explicitly or implicitly) selected element:

1. Using the attribute form (the upper side of the attribute tool).This should be the method of choice for persons
who prefer to use the keyboard.

2. Using the attribute table (the lower side of the attribute tool). This should be the method of choice for persons
who prefer to use the mouse.

• Adding an attribute for an element of the unconstrained type must be done using the attribute form. Simply type

the name and value of the attribute in the attribute form and click on the  OK button (or press Enter in the
value field).
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The type of an element is unconstrained if

• the element is contained in a document which is not constrained by a grammar,

• OR the content of the element is invalid according to the grammar used to constrain the document.

In both cases, XXE allows the user to add or remove any attribute, the value allowed for these attributes
being any string.

In the latter case, fixing the invalid element will automatically make it recover its actual, constrained,
type.

• Adding an attribute that matches an attribute wildcard must be done using the attribute form. Simply type the

name and value of the attribute using the attribute form and click on the  OK button (or press Enter in the
value field). XXE will of course check that the name you have typed conforms to the attribute wildcard.

Using a W3C XML Schema or a RELAX NG schema (but not a DTD), it is possible to specify an element
type which, for example, has 3 ``ordinary'' attributes a1, a2, a3 but also any number of other attributes if
the name of these extra attributes belong to certain namespaces, for example, the "ht-
tp://www.w3.org/1999/xlink" namespace.

The set of allowed namespaces is called an attribute wildcard.

3.1. Using the attribute table

The content of the attribute table can be described as follows:

• All attributes set for the selected element are displayed by the table.

• All possible attributes for the selected element, even those not set, are also displayed by the table.

Attributes which have not been set are displayed in gray. Attributes which have been set are displayed in black.

• Attributes are listed sorted in alphabetical order.

• The names of required attributes are displayed using a bold font.

• The names of fixed attributes are displayed using an italic font.

Procedure for adding an attribute or changing its value:

1. Click on the field at the right of the attribute name. This field is editable.

2. Type the value of the attribute.

If the attribute type is enumerated, this field is a menu rather than a text field, so you can directly choose the
value of the attribute without having to type anything.

3. Press Enter to commit the change.

Procedure for removing an attribute:

1. Right-click on the row of the attribute to be removed.

2. Select the Remove item in the displayed popup menu.
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3.2. Using the attribute form

Procedure for adding an attribute or changing its value:

1. Type the name of the attribute in the name field (first field of the form).

2. Press Enter or Tab to move to the value field (second field of the form).

3. Type the value of the attribute in the value field.

4. Press Enter in the value field to commit the change. This also gives the keyboard focus back to the document
view.

Tip

Both the name and value fields support auto-completion. However auto-completion in the value field
only works for attributes having certain types, for example, any enumerated type, ID, IDREF, IDREFS.

This auto-completion feature can be configured using the Preferences dialog box [87].

Procedure for removing an attribute:

1. Select the attribute by either clicking on it in the attribute table or by typing its name in the name field (first
field of the form).

2. Press Enter to move to the value field (second field of the form).

3. Click on the right part — the down arrow — of the  Edit button.

4. Click the Remove item in the displayed menu.

Procedure for adding an attribute to an element of the unconstrained type:

1. Type any attribute name in the name field (first field of the form).

Note

If the namespace of the attribute name has not been declared, you will have to declare it using Tools
→ Declare Namespace [32] before being allowed to add the attribute.

2. Type the value of the attribute in the value field (second field of the form).

3. Press Enter in the value field to commit the change. This also gives the keyboard focus back to the document
view.

Procedure for adding an attribute that matches an attribute wildcard:

1. Type an attribute name that matches the wildcard in the name field (first field of the form).
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Note

If the namespace of the attribute name has not been declared, you will have to declare it using Tools
→ Declare Namespace [32] before being allowed to add the attribute.

2. Type the value of the attribute in the value field (second field of the form).

3. Press Enter in the value field to commit the change. This also gives the keyboard focus back to the document
view.

XXE will of course check that the name you have typed conforms to the attribute wildcard.

The attribute form contains the following buttons:

Add or change attribute
Commits the changes. Analogous to pressing Enter in the value field.

 Cancel
Cancels the non-committed changes and clears the attribute form. Analogous to typing Esc in the name or
value field.

 Edit
The right part — the down arrow — of this button displays a menu, similar to the popup menu which is dis-
played when you right-click on a row of the attributes table.

The left part of this button displays a dialog box which can be used to easily specify a value for the attribute
being edited. The value specified using this dialog box is directly assigned to the attribute.

Specialized helper dialog boxes are displayed for attributes having certain types, among these types:
• any enumerated type,
• ID, IDREF, IDREFS types,
• hexBinary and base64Binary types.

For all other types of attributes, a very simple multi-line editor is displayed. This may be useful to view or
edit attribute values which are too long to be comfortably viewed or edited using the value field.

Note that in the case of the dialog box displayed for enumerated types and ID or IDREF types, a single click
is sufficient to select a value from the displayed list. Also note that the text field above the list supports auto-
completion.

 Browse Files
Displays a file chooser dialog box. The URL or filename specified using this dialog box is is directly assigned
to the attribute.

Clicking on the right part — the down arrow — of this button displays a menu with 8 radio buttons allowing
to choose between:
• Open or save files.
• File or directories.
• Absolute or relative paths (relative paths are relative to the location of the element being edited).
• URL or plain file names.

The choices made using these radio buttons are persistent during the editing session (but not across editing
sessions like, for example, user preferences specified using the Preferences dialog box [80]).

4. Search tool
Procedure for performing a text search:

1. Type text to be searched in Search field or choose it from the menu of the combobox.
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2. Change the search options as needed (see below).

3. Type Enter in the Search field or click on the Start button.

4. During the search session

• click Skip on to skip found text,

• OR click on Skip Element to skip the element containing the found text.

5. The search session can be stopped by

• clicking on Stop,

• OR typing Esc (this also gives back the keyboard focus to the document view),

• OR by simply clicking anywhere in the document view.

Procedure for performing a text search/replace:

1. Type text to be searched in Search field or choose it from combo box menu.

2. Check the Replace toggle

3. Type replacement text in Replace field or choose it from combo box menu.

4. Change the search options as needed (see below).

5. Type Enter in the Search or Replace fields or click on the Start button.

6. During the search/replace session

• click Skip on to skip found text,

• OR click on Skip Element to skip the element containing the found text.

• OR click Replace on to replace found text.

• OR click Replace All on to replace all occurrences of searched text.

7. The search/replace session can be stopped by

• clicking on Stop,

• OR typing Esc (this also gives the keyboard focus back to the document view),

• OR by simply clicking anywhere in the document view.

Search options:

Ignore case
The search is case-insensitive. Example: "foo" matches both "foo" and "Foo".

Tip

When "Ignore case" has been checked, "Regular expression" has not been checked and both the
searched string and the replacement string contain only lower-case letters or the hyphen character
('-'), the replacement string actually used is capitalized exactly like the found string it will replace.

Example: if you specify "editor" as the search string and "modeller" as the replacement string, the
Search tool will replace "editor" by "modeller", "Editor" by "Modeller" and "EDITOR" by "MOD-
ELLER".
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Counterexample: if you specify "IBM" as the search string and "Lenovo" as the replacement string,
the Search tool will replace "IBM", "Ibm" and "ibm" by "Lenovo".

Whole word
The found string must be a word, that is, the found string must be surrounded by white spaces. Example: "foo"
matches "foo" but not "foobar".

Regular expression
The searched string must be a valid regular expression. A regular expression is specified in a syntax similar
to that used by Perl. See also http://java.sun.com/j2se/1.4.2/docs/api/java/util/regex/Pattern.html.

In such case, $1, $2, ..., $9 may be used in the replacement string to refer to the substrings matching the par-
enthesized groups of the regular expression.

$0 is replaced by the string matching the regular expression in its entirety. "$$" may be used to quote character
'$'.

Examples:

• "f(o+)" matching "foo", replaced by "g$1", gives "goo".

• "f(o+)" matching "foo", replaced by "$0bar", gives "foobar".

• "f(o+)" matching "foo", replaced by "g$$1", gives "g$1".

Smart text boundaries
Searching string "Hello world!" in an XML document is not as obvious as it seems: for example, is "Hello
world!" with word "Hello" contained in an emphasis element followed by text node " world!" supposed to
be found by XXE?

• If this toggle is checked, the answer is yes. "Hello world!" is found within "<em>Hello</em> world!"
but not within "<p>Hello </p><p>world!</p>".

This mode uses the grammar constraining current document to recognize logically contiguous text across
different types of elements.

• If this toggle is not checked, the answer is no. Each text node is separated from other text nodes whatever
the type of the element containing it.

Direction

Up
Search from the current caret position to the beginning of the document.

Down
Search from the current caret position to the end of the document.

Wrap search
Restart the search from the beginning of the document when the end of the document has been reached. (If
Direction is Down, restart the search from the end of the document when the beginning of the document has
been reached.)

5. Spell tool
Procedure for checking current document for spelling errors:

1. Click on the Start button or use Tools → Check Spelling [54].

2. During the check spelling session, use any of the buttons described below.
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3. The check spelling session can be stopped by

• clicking on Stop,

• OR typing Esc (this also gives the keyboard focus back to the document view),

• OR simply clicking anywhere in the document view.

Default language
Selects the language of the dictionary used by the spell checker when such language is not specified in the
element being checked for spelling (typically through the use of an attribute such as lang or xml:lang).

It is possible to switch from a default language to another at any time. In such case, when the default language
is actually used (that is, when lang or xml:lang attributes have not been specified), the spell checker is
automatically restarted with the other dictionary, beginning at the last word for which the spell checker has
found an error.

The last selected default language is recorded in the user preference file in order to be automatically chosen
in subsequent XXE sessions.

Example 7.1. Default language versus actual language example

In this example,

• Test.html does not have xml:lang attributes set on its elements, which means that the default language,
English, is used to spell check this document.

• Except, in span containing "le petit cha est mort" where attribute xml:lang has been set to fr. This means
that for that element only, the default language, English, is ignored and that a French dictionary will be
used.

In the above screen shot, notice that the actual language of span "le petit cha est mort", fr, is displayed at
the top/right of the Spell tool.

Start from caret
If this option is turned on, spell checking starts from the current caret position. If this option is turned off,
spell checking starts from the beginning of the document.

Replace
Replaces the erroneous word by the content of the Replace with text field.

An empty text field may be used to delete the erroneous word.
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Replace All
Replaces all occurrences of the erroneous word by the content of the Replace with text field.

This button is disabled for errors other than "Unknown word" or "Improperly capitalized word".

Ignore
Skips the word for which the spell checker has found an error.

Ignore All
Skips all occurrences of the word for which the spell checker has found an error.

This button is disabled for errors other than "Unknown word" or "Improperly capitalized word".

Skip Element
Skips the element containing the word for which the spell checker has found an error.

Learn
Records the word in the personal dictionary for currently selected language.

This button is disabled for errors other than "Unknown word" or "Improperly capitalized word".

About learned words

When a spell checking session is started, it automatically knows all the words learned during past and
current spell checking sessions.

A ``spell checking session'' is started each time:

• You click the Start button of the Spell tool.

• You open a document and auto spell checking is turned on for this document.

• Auto spell checking was turned off and you manually turn it on for the document being edited. This is
done for example, by clicking the "Automatic Spell Checker" button found at the left of the status bar.

Limitations:

• Words learned during past and current spell checking sessions are acquired when a new session is
started, and never in the middle of a session.

Example: let's suppose auto spell checking is turned on for all documents. Document A and document
B are both opened in XXE. You use the popup menu of the automatic spell checker to force XXE to
learn word "foo" in document A. You switch to document B which also contains word "foo". Word
"foo" is still underlined in document B.

• "Ignore All" words and "Replace All" words are not shared by spell checking sessions.

6. Character tool
Click on a character to insert it at caret position in current document view.

The form above the character table can be used to select the range displayed by the character table.

The size of this range is 256 characters.

A range is identified by the Unicode code of its first character. This code is displayed in hexadecimal notation
(example: "0x2700" for the dingbats range) but can be input in decimal notation (example: "9984") or in octal
notation (example: "023400").
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6.1.The “Favorites” palette

The last item of the combobox found above the character table is called Favorites. It can be used to select a custom
palette of up to 256 characters.

This palette is populated by right-clicking on a character and by choosing the "Add to Favorites" item in the popup
menu.

This contextual popup menu contains the following entries:

Copy
Copy to the clipboard the character upon which the user has right-clicked.

Add to Favorites
Add to the Favorites palette the character upon which the user has right-clicked.

Remove from Favorites
Remove from the Favorites palette the character in which the user has right-clicked.

Show Favorites
The quickest way to switch to the Favorites palette.

Change Font
Change the font used by the Character tool. This menu item displays a dialog box allowing to choose any font
present on your system. The chosen font is automatically saved as a user preference.

Revert to Default Font
Revert to the font used by default by the Character tool (which is generally Serif-14).

7. Validity tool
This tools displays the list of validity error messages (if any) found by XXE when opening a document or after
the last use of

• Tools → Check Validity [32] or Validity State [71],

• OR File → Save [14] or File → Save As [14] (validity is automatically checked each time a document is saved).

The color of the message reflects the severity of the error. See icons used by Validity State [71].

Clicking on the number of an error message selects the element where the validity error was found.

If the document is edited after its validity is checked (typically to fix some of the validity errors), clicking on some
of the error messages may have no effect because the corresponding erroneous element no longer exists.

8.The "Document Set" tool

8.1. What is a document set?

A document set is simply a set of related XML documents. These documents are related because they all contribute
to the content of the same deliverable: PDF file, EPUB file, Web site, etc.

When XMLmind XML Editor knows that some opened documents are members of the same set:

• it will more thoroughly check the links which may exist between these documents,
• it will make it easier creating links between these documents.
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Modular documents, for example a DITA map referencing a number of topics or a modular DocBook book including
a number of chapters, implicitly specify a document set. When you author such modular documents, it is strongly
recommended to first open their document set in XXE.

About document sets and the DITA key-reference mechanism

If your DITA topics make use of attributes conkeyref and keyref, then opening it as a document set
becomes near mandatory. As a matter of fact, when a DITA map contains key definitions, then the corres-
ponding document set acts not only as a link creation/validation context for its member topics, but it also
acts as a key space.

When this is the case, please also take the time to review the options of document sets. See Section 5.7.2,
“Document Set options” [91].

8.2. How to open a document set in XXE?

Use File → Document Set → Open Document Set [15] to let XXE know about a given document set. This menu
item displays a dialog box allowing to choose the file specifying the document set.

• If the selected file is a DITA map, then the members of the document set are the topics referenced in this map.
See Figure 7.1, “A document set specified by a DITA map and 3 topic members opened in XXE” [58] below.

• If the selected file is a master DocBook document (for example a modular book including a number of chapters,
each chapter being found in its own XML file), then the members of the document set are the DocBook documents
included in this master document. See Figure 7.2, “A document set specified by a modular DocBook book and
3 chapter or section members opened in XXE” [59] below.

• In all other cases, the content of the selected file is not analyzed by XXE. Instead, the selected file specifies a
directory and a filename extension. For example, selecting file file:/home/john/site/buy.html specifies
the "file:/home/john/site/*.html" glob pattern. In this example, the members of the document set are all
the files found in directory file:/home/john/site/ having an "html" extension. See Figure 7.3, “A document
set specified by a glob pattern and 3 XHTML page members opened in XXE” [59] below.

Figure 7.1. A document set specified by a DITA map and 3 topic members opened in XXE
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Figure 7.2. A document set specified by a modular DocBook book and 3 chapter or section
members opened in XXE

Figure 7.3. A document set specified by a glob pattern and 3 XHTML page members
opened in XXE

8.3.The "Document Set" tool

As you can see it in the 3 above screenshots, a document set is represented by a special tool added to the left of
XXE's main window: the "Document Set" tool. Each instance of this tool is given a specific, random, background
color. This specific background color is also given to the tabs of all the opened documents which are members of
the set.

As you will see it in next section [60], the "Document Set" tool is a convenient, interactive, navigational tool.
However the most important part of its job is done behind the scene, because opening a document set in XXE
automatically modifies the behavior of the Validity tool [57] and the Attributes tool [49]1:

• The diagnostics issued by the Validity tool about cross-reference errors will take into account the fact that the
document being checked is a member of a set.

• The target of a link is almost always specified as an attribute value (XHTML example: the href attribute of the
a element). That's why the Attributes tool, through its auto-completion feature, will suggest, not only link targets
found within the document being edited, but also link targets found in the other members of the set.

1More precisely, the opened document set is used as a context by the linkType in XMLmind XML Editor - Configuration and Deployment
and the attributeEditor in XMLmind XML Editor - Configuration and Deployment configuration elements introduced by XMLmind
XML Editor v4.9.
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Example 7.2. A simple use case

Modular book mybook.xml includes 3 chapters. Each chapter is found in its own file: chapterA.xml, chapterB.xml
and chapterC.xml.

File chapterA.xml contains:

<chapter id="chapterA">
  <title>Chapter A</title>

  <para>Link to <link linkend="nowhere">nowhere</link>. Link to <link
  linkend="sectionB1">Section B1</link>.</para>

  <section id="sectionA1">
    <title>Section A1</title>

    <para>TODO.</para>
  </section>

  <section id="sectionA2">
    <title>Section A2</title>

    <para>TODO.</para>
  </section>
</chapter>

In the above file, the first link element points to a non-existent target and the second link points to the first section
of chapterB.xml.

The user wants to check the links found in chapterA.xml and also to add an xref element pointing to the first
section of chapterC.xml. In order to do that, she/he opens chapterA.xml in XXE.

Before opening mybook.xml as a document set:

• The Validity tool reports 2 cross-reference warnings: reference to non-existent ID "nowhere" and ref-
erence to non-existent ID "sectionB1".

• When the user inserts an xref element and specifies its linkend attribute, the Attributes tool suggests: chapterA,
sectionA1, sectionA2.

After opening mybook.xml as a document set:

• The Validity tool reports 1 cross-reference warning: reference to non-existent ID "nowhere".
• When the user inserts an xref element and specifies its linkend attribute, the Attributes tool suggests: chapterA,

sectionA1, sectionA2, chapterB, sectionB1, sectionB2, chapterC, sectionC1, sectionC2.

8.4. Using the "Document Set" tool

Note

The File → Document Set submenu is hidden by default. You need to enable it by checking "Enable the
'File|Document Set' Submenu" in Options → Preferences, Features section.

This tool is displayed after you select a file specifying a document set using File → Document Set → Open Document
Set [15].
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Figure 7.4. The "Document Set" tool showing the document set corresponding to the map
of our DITA tutorial

Toolbar buttons:

 Edit document set specification
Edit in XXE the XML document used to specify this document set. This XML document is typically a DITA
map or a DocBook master document.

This button is disabled when the document set is specified by a glob pattern (e.g.
"file:/home/john/site/*.html").

 Document set options
Display a dialog box allowing to change the options, if any, of this document set.

Changing the options of a document set automatically brings this document set up-to-date.

This button is disabled for all kinds of document set, except when the document set is specified by a DITA
map. In such case, this button displays a dialog box allowing to associate a conditional processing profile (a
.ditaval file) and a target medium (print or screen) to the underlying DITA map. These settings also have
a direct effect on the list of member documents and on the visual representation of the document set2.

 Update document set
Update the list of member documents belonging to this document set and at the same time rebuild its visual
representation.

This button must be clicked after the XML document used to specify this document set (typically a DITA
map or a DocBook master document) has been modified.

There is no need to click this button after modifying member documents in XXE. When a member document
is modified and the changes are saved to disk, the visual representation of the document set is automatically
updated.

Below the toolbar is found an interactive pane containing a visual representation of the document set:

• Press Up to select the preceding element. Press Down to select the following element.

2And also on the key space, when the DITA map contains key definitions. See About document sets and the DITA key-reference mechanism [58].
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• Press Enter to open in XXE the member document corresponding to selected element.

• Click on an element to select it.

• Double-click on an element to open in XXE the member document corresponding to this element.

• Right-click on an element to first select it and then display the following popup menu:

Open
Open in XXE the member document corresponding
to selected element.

Open Document in Read-only Mode
Same as above, but the member document is
opened in read-only mode.

Open Containing Folder
Open the folder containing the member document
corresponding to selected element. This menu item
displays the "Browse Files" tool [62].

• Dragging the selected element will drag the corresponding member document inside or outside XXE.

Note that when a document is dragged and dropped onto XXE, this document is always opened or reopened in
XXE. This is not the case of all the "open document" facilities described above. Such facilities have been designed
for navigation and thus, will not reopen a document if it's already opened in XXE. Instead, the opened document
will automatically scroll to display the element of interest.

Notice that the tabs of documents [41] belonging to the same document set are all given the same background
color as the corresponding "Document Set" tool.

9.The "Browse Files" tool

Note

The File → Folder submenu is hidden by default. You need to enable it by checking "Enable the 'File|Folder'
Submenu" in Options → Preferences, Features section.

This tool is displayed after you select any of the menu items of the File → Folder [17] submenu.

This tool is similar to the file manager applications which are native to all operating systems: Windows Explorer,
Mac OS X Finder, Linux/KDE Nautilus, etc. The main advantages of using one or more "Browse Files" tools over
the native counterparts are:

• Tightly integrated in XMLmind XML Editor.
• Does not use much screen real estate.
• Makes use of all XXE plug-ins. For example, if you install the "JEuclid image toolkit plug-in" add-on, you'll

be able to preview MathML equations.
• Last but not least, if you install the "WebDAV virtual drive plug-in" add-on and/or the "FTP virtual drive plug-

in"3add-on, you'll be able to manage files stored on all sorts of remote servers. Installing such add-ons is done
simply by using Options → Install Add-ons [37].

3Requires XMLmind XML Editor Professional Edition.
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Figure 7.5. The "Browse Files" tool showing the source files of our DITA tutorial

Notice in the above screenshot that the "Show image thumbnails" option (see below [63]) is turned on and that
the icon next to "concept.dita" has a small lock, meaning that is file is currently locked4.

Toolbar buttons:

 Back
Browse previously visited folder.

 Forward
Browse previously visited folder by undoing the Back action [63].

 Go up one level
Browse parent folder.

 Split
Split the "Browse Files" tool in two parts, making it easy to drag/drop or to copy/paste files between these
tools.

 Search
Open a "Search Files" tool [65] allowing to search by their contents the XML files found in this folder.

 Show image thumbnails
This checkbox adds a thumbnail after each list item corresponding an image file.

This facility makes use of all the image toolkit plug-ins currently installed in XXE. If you are missing an image
format (e.g. SVG), please install the corresponding image toolkit plug-in (e.g. "Apache Batik image toolkit
plug-in") using Options → Install Add-ons [37].

4Details about the lock are given by the tooltip of the file icon.
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 Refresh
Update what is displayed by the "Browse Files" tool. Clicking this button is needed when the content of the
folder is modified outside XMLmind XML Editor.

Below the toolbar is found an interactive pane containing a visual representation of the folder:

• Up, Down, Shift+Up, Shift+Down may used to select one or more files. These shortcuts work as expected in
any multi-selection list.

• Press Enter to open the selected file. If the selected file is an XML file, it is opened in XXE. If the selected file
is not an XML file, a dialog box [33] is displayed allowing the user to choose a helper application.

• Click, Shift+Click, Ctrl+Click may used to select one or more files. These actions work as expected in any
multi-selection list.

• Double-click on a file to open it. If the selected file is an XML file, it is opened in XXE. If the selected file is
not an XML file, a dialog box [33] is displayed allowing the user to choose a helper application.

• Right-click on a file to first select it and then to display the following popup menu:

Open
Open the selected file. If the selected file is an
XML file, it is opened in XXE. If the selected file
is not an XML file, a dialog box [33] is displayed
allowing the user to choose a helper application.

Open Document in Read-only Mode
Same as above, but the document is opened in read-
only mode.

Open as Document Set
Open selected XML file — typically a DITA map
or a DocBook master document — as a document
set [57]. This button displays the "Document Set"
tool [57].

New Folder
Create a subfolder in current folder.

New Document
Create an XML file using the same dialog box as
the one displayed by File → New [14].

Lock
Lock selected file.

If the current folder is stored on a WebDAV server,
it is also possible to lock a subfolder of the current
folder.

Unlock
Unlock selected file.

In principle, the file must have been locked by you.
However, this menu item will attempt to unlock it
in all cases and depending on your privileges, this
action may succeed or fail.

Cut
Cut selected files.
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Copy
Copy selected files.

Paste
Paste files cut or copied using the above menu
items.

Rename
Rename selected file.

Delete
Delete selected files.

• The customary keyboard shortcuts Ctrl+A, Ctrl+X, Ctrl+C, Ctrl+V, Del, Backspace work as expected in any
file manager.

• The "Browse Files" tool is fully drag and drop enabled. It supports the copy and move operations. It does not
support the link operation.

Note that when an XML file is dragged and dropped onto XXE, the document is always opened or reopened in
XXE.

10.The "Search Files" tool

Note

The File → Folder submenu is hidden by default. You need to enable it by checking "Enable the 'File|Folder'
Submenu" in Options → Preferences, Features section.

This tool is displayed after you click the  Search [63] button in the "Browse Files" tool. (The "Browse Files"
tool is itself displayed after you select any of the menu items of the File → Folder [17] submenu.)

Figure 7.6. Search our DITA tutorial for topic files (*.dita) containing substring "link"
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Toolbar buttons

 Clear
Clear the query text field (see below), the "File name:" text field and the "search results" pane.

 Create or edit an advanced query
Display a query editor dialog box allowing to create an advanced query or to edit the current query (that is,
the one specified in the query text field).

 Help
Displays an online help for "Search Files" tool.

 Search next
Displays up to 20 more results for the current search.

 Search
Start searching or restart current search . Display at most the first 20 results.

When a search is being performed, the Search and Search next buttons are given a special Stop icon .
Clicking this icon allows to stop the search.

The query text field

Below the toolbar is found a text field where you can type a query. It's possible to type simple or advanced queries
in this text field.

Advanced queries are documented in Section 10.1, “The "Create or edit an advanced query" dialog box” [67].

A simple query such as "Hello world!" (without the quotes) means: find all XML files containing an element
whose direct textual content contains substring "hello world!" (case-insensitive).

This is very different from web search engines such as Google™ where query "Hello world!" (without the quotes)
means: find all pages containing word "hello" and word "world" (case-insensitive).

Note that this simple text search facility is always case-insensitive. Also note that the whitespace in the textual
content of elements, attributes, comments and processing-instruction is always normalized while traversing the
content of an XML file. That is, the possible indentation of the XML file will not affect the results of the search.

The query text field may be left empty, in which case the search will be performed on the basenames of the files.
See below.

The "search files by name" form

The "Search subfolders" checkbox allows to perform the search, not only in the current folder, but also recursively
in all its subfolders.

Below the "Search subfolders" checkbox is found a "File name:" text field where you can type a glob pattern. This
glob pattern is used to match the basename of the files being searched.

When this field is left empty, XXE will search all the files known to be XML (the union of *.xml, *.dita,
*.ditamap, *.dbk, *.xsl, *.xsd, *.fo, etc).

Tip

Note that, by default, .htm, .html and .shtml files are not considered to be XML files. Only .xhtml
files are considered to be XML files. Therefore, if you always create XHTML files and nevertheless give
your files extensions such as .htm, .html or .shtml, do not forget to specify "*.*htm*" in the "File
name:" text field.
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Note that the query text field may be left empty, in which case the search will be performed on the basenames of
the files. For example, specify "*.{svg,png}" in the "File name:" field and leave blank the query field in order
to list all SVG and all PNG files.

The "search results" pane

Below the above toolbar and text fields, is found an interactive pane containing the results of a search:

• Press Up to select the preceding result. Press Down to select the following result.

• Press Enter to open in XXE the document corresponding to selected result.

• Click on a result to select it.

• Double-click on result to open in XXE the document corresponding to this result.

• Right-click on a result to first select it and then to display the following popup menu:

Open
Open in XXE the document corresponding to selec-
ted result.

Open Document in Read-only Mode
Same as above, but the document is opened in read-
only mode.

Open Containing Folder
Open the folder containing the document corres-
ponding to selected result. This menu item displays
the "Browse Files" tool [62].

• Dragging the selected result will drag the corresponding document inside or outside XXE.

Note that when a document is dragged and dropped onto XXE, this document is always opened or reopened in
XXE. This is not the case of all the "open document" facilities described above. Such facilities have been designed
for navigation and thus, will not reopen a document if it's already opened in XXE. Instead, the opened document
will automatically scroll to display the element of interest.

10.1.The "Create or edit an advanced query" dialog box

The "Search Files" tool is not limited to simple text searches. You can use it to perform more elaborate searches.
For example: find all documents containing an element whose id attribute starts with "topic":

67

Tools



In the above screenshot, notice the query being used: "@id =~ ^topic". The syntax of this query [69] is easy to

remember. However, fortunately, you don't even need to do this effort. Suffice to click on  "Create or edit an
advanced query" to display a query editor dialog box.

Figure 7.7. The "Create or edit an advanced query" dialog box

Description of the text fields and comboboxes from top to bottom and left to right:

Text field "Parent elements match:"
Specifies the parent element and also possibly the ancestors of the subject of the search.

An empty "Parent elements match:" text field means: whatever the parent or ancestors.
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Subject type combobox
Specifies the node type of the subject of the search: element, attribute, processing-instruction or comment.

Subject name text field
Specifies the name of the subject of the search when this subject is an element or attribute. Specifies the target
of a processing-instruction when the subject of the search is a processing-instruction.

• A non-qualified name such as "para" matches any name having "para" as its local part . That is, the
namespace and the prefix of a name are not considered.

• A qualified name such as "db:para" matches any name having "db" as its prefix and "para" as its local
part. The namespace of a name is not considered.

• A name specified using Clark's notation such as "{http://docbook.org/ns/docbook}para" matches any
name have "http://docbook.org/ns/docbook" as its namespace and "para" as its local part. The prefix
of a name is not considered.

Use "{}" to specify the absence of namespace. Example: "{}para".

• In a name specification, an "*" wildcard may be used in the local part, the prefix or the namespace. Examples:
"db:*", "*:para", "{*}para".

An empty subject name text field means: whatever the name of the element or attribute or whatever the target
of the processing-instruction.

Match operation combobox
Specifies how the textual content of the subject is matched with the searched value:
• the textual content contains the searched value,
• OR the textual content is equal to the searched value,
• OR the textual content contains a substring matching the searched value, which is a regular expression.

All these operations are case-insensitive.

Searched value
Specifies the searched value, some plain text or a regular expression, depending on the chosen the match op-
eration.

The supported syntax for regular expressions is documented here.

An empty searched value text field means: whatever the textual content of the subject.

Examples:

• Find documents containing literal elements containing a text equal to "XXE": Element name matches: literal;
Searched value: XXE.

• Find documents containing table elements having an xml:id attribute: Parent elements match: table; Attribute
name matches: xml:id.

• Find documents containing comments: simply select "Comment" in the Subject type combobox.

• Find documents containing the <?xxe-relaxng-schema> processing-instruction: PI target equals: xxe-relaxng-
schema.

• Find documents containing absolute HTML links: Parent elements match: a; Attribute name matches: href;
Containing substring matching regular expression: ^http://.

10.2. Syntax of search queries
query -> [ subject ]? [ op ]? [ value ]?
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subject -> [ ancestors ]? simple_subject

ancestors -> [ name '/']+

simple_subject -> element | attribute |
processing-instruction | comment

element -> name

attribute -> '@'name

processing-instruction -> 'processing-instruction(' target ')'

comment -> 'comment()'

name -> local_name | 
prefix ':' local_name | 

        '{' [ namespace ]? '}' local_name

local_name -> NCName | '*'

prefix -> NCName | '*'

namespace -> anyURI | '*'

target -> NCName | '*'

op -> '=*' | '=' | '=~'

value -> plain_text_or_regular_expression

The default subject is: any element.

The default op is: =*.

The default value is: any value.

DescriptionOp

The textual content of the subject contains the searched value.=*

The textual content of the subject is equal to the searched value.=

The textual content of the subject contains a substring matching the searched value, which
is a regular expression.

=~

The supported syntax for regular expressions is documented here.

Examples:

• Find documents containing elements containing substring "XXE": =* XXE or more simply XXE

• Find documents containing attributes containing substring "XXE": @* =* XXE

• Find documents containing literal elements containing a text equal to "XXE": literal = XXE

• Find documents containing table elements having an xml:id attribute: table/@xml:id =

• Find documents containing comments: comment() =

• Find documents containing the <?xxe-relaxng-schema> processing-instruction: processing-instruction(xxe-
relaxng-schema) =

• Find documents containing absolute HTML links: a/@href =~ ^http://
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Chapter 8. Status bar
1. Validity state
Clicking on this button displays Validity tool [57], unless no validity errors are found in current document, in
which case an OK message is displayed in the status bar.

This button is disabled if current document is not constrained by a grammar.

Tip

Current document validity is automatically checked each time the document is saved, therefore, unless
you are fixing an invalid document, you don't really need to explicitly use this button.

The icon contained in this button shows the validity state of current document:

MeaningIcon

The document is valid and has no semantic errors.

The document is valid but has semantic warnings. This happens when the document being edited
is itself a W3C XML Schema or a RELAX NG schema or when a user-defined validateHook re-
ports such warnings (See Section 32, “validateHook” in XMLmind XML Editor - Configuration
and Deployment).

The document is valid but has semantic errors. This happens when the document being edited is
itself a W3C XML Schema or a RELAX NG schema or when a user-defined validateHook reports
such errors (See Section 32, “validateHook” in XMLmind XML Editor - Configuration and Deploy-
ment).

The document has minor validity errors such as bad cross-references.

Tip

Working on a document which has bad cross-references is very common so you should
not be alarmed by this situation.

The document has validity errors signaling bad values for attributes or for elements.

Note

With a DTD, this can only happen for attribute values because the text contained in an
element cannot be constrained by this type of grammar.

This document has severe validity errors such an invalid child sequence inside an element. It is
not a good idea to keep working on a document with such severe validity errors because XXE has
not been designed to be convenient to use in such situation.

Tip

After fixing some structure errors using XXE, save and then reload the document.

This will automatically discard superfluous white space which was not detected at first
because of the validity errors. This trick is much faster that trying to remove invalid white
space text nodes by hand.
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2. Document cache indicator

Note

The document cache indicator is hidden by default. You need to enable it by checking "Enable the Docu-
ment Cache Indicator" in Options → Preferences, Features section.

 Document cache
As of v4.9, XXE makes a heavy use of its document cache. This indicator allows to have a feedback while
the document cache is caching documents. Its tool tip shows the number of documents currently cached as
well as the capacity of the cache. The number of cached documents is also rendered visually.

This indicator is not a button. You'll have to use Options → Preferences, Advanced, "Cached data" section to
configure or clear the document cache.

3. Status messages

 Show Message Log
Displays a dialog box containing last messages reported by XXE.

These messages are sorted by category. One of the most useful category is "Command Execution" which
contains the messages reported during the execution of the last command. Commands such as DocBook →
Convert Document → Convert to PDF are really verbose, that's why this category is so useful.

Tip

It is also possible to display the same dialog box by right-clicking in the message area of the status
bar.

4. Automatic spell checker

 / Automatic Spell Checker
See Tools → Automatic Spell Checker [32].

This button is present only in XMLmind XML Editor Professional Edition.

5. Overwrite mode
INS/OVR

INS indicates Insert Mode: typing a character inserts it at caret position.

OVR indicates Overwrite Mode: typing a character replaces the character found at caret position by the typed
character. If the caret is positioned at the very end of a text (or comment or processing-instruction) node, then
typed characters are simply inserted there.

Pressing the INS/OVR button allows to switch from Insert Mode to Overwrite Mode and vice versa. The
shortcut associated to this button is by default Esc Insert (press Esc, release Esc, then press Insert).

6. Clipboard utilities

Clicking on this button  (or right-clicking in the text field next to it) displays a dialog box showing the content
of system clipboard.
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6.1. Clipboard content

Next to the above button, a read-only text field permanently shows a short description of current clipboard content:

• an element name if a single element has been copied or cut to the clipboard,

• OR #text for a text node or for a sequence of characters,

• OR #comment for a comment node.

• OR #processing-instruction for a processing instruction node,

• OR the number of nodes (between square brackets) if more than one node have been copied or cut to the clipboard
. Example "[5]" if the five list items of this itemized list have been copied to the clipboard.
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Chapter 9. Dialog boxes
1.The URL chooser dialog box
The URL chooser dialog box allows to specify the location of a file or directory on the local file system and, if
virtual drive plug-ins have been installed1, on remote (e.g. HTTP, FTP) file systems. This file or directory may
be an existing one or a file or directory to be created; it depends on the command displaying this dialog box.

This dialog box is available only in XMLmind XML Editor Professional Edition.

This dialog box is similar to the "Open Web Location" dialog box found in many Web browsers. To use it, simply
type in its text field the URL (Uniform Resource Locator — see syntax [76] below) of a file or directory.

Now rather than typing an URL, you can select it using a file chooser dialog box:

Browse local files
Allows to choose a local file or directory using the standard file chooser dialog box.

Always works, whatever is specified in the text field.

Browse remote files
Allows to choose a file or directory found on the local file system and, if virtual drive plug-ins have been in-
stalled, on remote (e.g. HTTP, FTP) file systems.

Cannot work if the text field is totally blank. You have to type2 at least the URL of the initial directory you
would like to browse.

Note that the special chooser dialog box displayed after clicking on this button has a simple yet handy, integrated
file manager (similar, albeit simpler, to the "Browse Files" tool [62]). To use it, simply right-click anywhere
on the file list:

1A virtual drive plug-in allows XMLmind XML Editor to edit documents stored in places other than the local file system. This is done by
emulating a hierarchical file system.

Installed plug-ins can be listed using Help → Plug-ins [39].

All sorts of add-ons, including virtual drive plug-ins, can be downloaded and installed using Options → Install Add-ons [37].
2Or choose an item from the dropdown menu next to the text field. This menu lists last recently visited URLs.
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Clear
Erases the contents of the text field where the URL is typed.

The dropdown menu next to the Clear button
(Disabled unless virtual drive plug-ins have been installed.)

Instead of erasing the text field, this menu allows to replace its contents by the protocol part of an URL, e.g.
"http://", "ftp://", etc. The list of these prefixes depend on which virtual drive plug-ins have been installed.

Moreover, keyboard shortcuts are automatically associated with the prefixes. For example, press Ctrl+H to
replace the contents of the text field by "http://".

Specifying the "http://" URL of a document found on a WebDAV server

Assumes that WebDAV virtual drive plug-in has been installed and that the option "Use URL chooser

rather than file chooser" has been selected, that is, you see  in the tool bar.

Before using the Browse remote files button, make sure to type in the text field the URL of an initial
directory which is WebDAV enabled.

Example: you have typed "http://www.acme.com/" as an initial URL. After clicking on the Browse remote
files button, you get the following error message: "Cannot connect to http://www.acme.com/: ht-
tp://www.acme.com/ does not support WebDAV". Try to type the URL of a subdirectory such as
"http://www.acme.com/publish/" because, may be in the "www.acme.com" server, directory "/" is not
WebDAV enabled, while directory "/publish/" is.
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Syntax of Uniform Resource Locators

An URL (Uniform Resource Locator), often called Internet Address in Web browsers, has (to make it simple)
three parts:

1. The protocol part. Example: "http://" in URL "http://www.xmlmind.com/xmleditor/down-
load.shtml".

Unlike Web browsers, XMLmind XML Editor requires you to specify the protocol.

2. The authority part, often a server, sometimes empty. Example: "www.xmlmind.com" in URL "ht-
tp://www.xmlmind.com/xmleditor/download.shtml".

Example of URL with an empty authority: file:///C:/temp/documenation.zip. Because the authority
is empty, this URL could be specified as file:/C:/temp/documentation.zip.

3. The file path part. Example: "/xmleditor/download.shtml" in URL "http://www.xmlmind.com/xmled-
itor/download.shtml".

File path components, that is, directories, are separated by forward slashes ('/'), whatever is the platform
running XMLmind XML Editor.

The file path of a directory must end with a '/'. Example: "http://www.xmlmind.com/xmleditor/" is
the URL of directory /xmleditor/.

More examples:

• http://www.xmlmind.com/store/buy.php

• http://lupo.pixware.fr/~john/

• https://www.acme.com:8080/registry/customers.xml (8080 is the port number of the www.acme.comWeb
server)

• ftp://zenda.prisoner.tv/pub/docs/refman.zip

• ftp://john:sesame@zenda.prisoner.tv/pub/docs/refman.zip (same as above with a username "john" and
password "sesame").

• file:///home/john/documentation.zip

• file:/home/john/

• file:///C:/Documents%20and%20Settings/john/documentation.zip (spaces must be escaped as "%20")

2.The "Find Element" dialog box
This dialog box allows to select nodes specified using an XPath expression. This dialog box has a Simple tab [76]
which allows to perform most common search tasks without having to learn XPath. Arbitrarily complex XPath
expressions are specified using the Advanced tab [77].

The search starts at explicitly selected node, if any, and at implicitly selected element otherwise.

2.1.The "Simple" tab

Example 1: find element having attribute id equals to introduction:

1. Select "First in document". Make sure the Element field is empty.
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2. Check Having attribute. Type "id" in the text field. Select "Equals to". Type "introduction" in the next text
field.

3. Make sure Containing text is not checked.

4. Click OK.

Example 2: navigate from element para to next element para:

1. Click at the very beginning of your document.

2. Select "Following current node". Type "para" in the Element field.

3. Make sure Having attribute is not checked.

4. Make sure Containing text is not checked.

5. Click OK.

6. Type Esc g (that is, invoke Find Element Again [29]) to move to next para, if any.

Example 3: find element html:pre having a class attribute and containing some text matching regular expression
"print\w+\(":

1. Select "First in document". Type "html:pre" in the Element field.

If the namespace corresponding to prefix "html" is the default namespace of the document, it is also possible
to simply type "pre".

2. Check Having attribute. Type "class" in the text field. Make sure the next text field is empty.

3. Check Containing text. Select "Matching RE". Type "print\w+\(" in the text field.

4. Click OK.

2.2.The "Advanced" tab

Specify an XPath expression in the corresponding text field.

This expression is evaluated in the context of the explicitly selected node, if any, and in the context of the implicitly
selected element otherwise.

The evaluation of the XPath expression must return a nodeset. If this nodeset exclusively contains contiguous
siblings, all the nodes in the nodeset are selected. Otherwise, first node (in document order) of the nodeset is selected.

If the evaluation of the expression returns attributes, the corresponding elements are selected.

It is not possible to select the document node or sibling nodes of the root element.

3.The "Declare Namespace" dialog box
This dialog box can be used

• To declare a namespace used by the name of an attribute or an element (it is required to do so before adding the
element or the attribute) or used in the value of the attribute or in the textual content of the element (for example,
when the document being edited is a schema).

In practice, this is very rarely needed because document templates generally contain declarations for all the
namespaces they might use.

• To change the ``prefix'' of a namespace.
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What is called a ``prefix'' here should be called the nickname or the mnemonic of the namespace. Without
nickname "xsi" for namespace "http://www.w3.org/2001/XMLSchema-instance", an attribute name such
as "xsi:schemaLocation" would be displayed as "{http://www.w3.org/2001/XMLSchema-instance}schem-
aLocation" by the GUI of XXE, which is quite unreadable.

Real namespace prefixes only exist while the document is being loaded and while the document is being saved.
Do not try to add an xmln attribute to elements to specify an namespace and its prefix. XXE does this automat-
ically each time the document is saved, the nicknames declared using this dialog box being used preferably to
automatically generated prefixes such as ns, ns2, ns3, etc.

• To make a namespace the ``default'' namespace, that is the namespace for which no prefix is displayed (for
element names, not for attribute names).

It is not recommended to mark a namespace as being ``default'' if some elements in the document have names
without a namespace. In such case, it would be impossible to tell if name "title" is "title" with no namespace
or is in fact "{http://www.foo.com/namespace}title", where "http://www.foo.com/namespace" has been
marked as being the default namespace.

However, when the current document is conforming to a DTD, this dialog box can only be used to view the
namespaces and their prefixes and not to edit them.

Procedure for declaring a namespace:

1. You may have to clear the form by clicking on the  Cancel button

2. Specify the URI of the namespace in the Namespace field.

3. Specify the ``prefix'' of the namespace in the Prefix field.

Specifying a prefix is mandatory even if the namespace is to be marked as ``default''.

4. Optionally mark it as being the `default'' namespace by checking the Default toggle.

5. Type Enter in any field or click on the  OK button.

Procedure for changing the declaration of a namespace:

1. Select the namespace declaration to be edited by clicking on its row in the table.

2. Specify the ``prefix'' of the namespace in the Prefix field.

Specifying a prefix is mandatory even if the namespace is to be marked as ``default''.

3. Optionally mark it as being the ``default'' namespace by checking the Default toggle.

4. Type Enter in any field or click on the  OK button.

4.The spreadsheet formula editor
Formula

Type a formula in this text area.

Unlike in most spreadsheet software,

• A formula can contain spaces.

• Use of local variables and intermediate formulas is allowed.

• Comment lines are allowed and must start with '#'.

78

Dialog boxes



• Use newlines to separate intermediate formulas and comment lines.

Example:

vat = `document("tutorial/VATrates.html#france_vat", .)`
# Trim the '%' sign at the end of vat.
= left(vat, len(vat) - 1)

Warning

Do not use names for your local variables that look like cell references. Example: 'x' will work, but
not 'x1'. That is, [a-zA-Z][a-zA-Z]*[1-9][1-9]* (as well as true/TRUE/false/FALSE — the formula
language is case insensitive) are reserved identifiers.

 Help about selected function
Select a function name in the Formula text area and click on this button to switch to the other tab and display
online help about the selected function. Shortcut: F1.

 Evaluate selected text
Select an expression in the Formula text area and click on this button to evaluate it and display a dialog box
containing the result of this evaluation. Shortcut: F2.

This is handy if you want to experiment with a predefined function you don't really understand.

 Evaluate formula
Click on this button to evaluate the whole formula and display a dialog box containing the result of this eval-
uation. Shortcut: F3.

Format
The format fields are useful to separate calculation from formatting.

Use case: let's suppose your formula computes an amount of money. You need to insert in the document this
amount nicely formatted, preceded by string "Total: " and followed by string " (excluding taxes)".

Of course, this can be done like this:

amount = ...
= "Total: " & numbervalue(amount, "0.00") & " (excluding taxes)"

An alternative is to use the Format fields. First field contains a prefix which is prepended to the formatted
result. Second field contains a date or number format used to format the raw result. A combobox allows to
specify the locale used to interpret this format. Third field contains a suffix which is appended to the formatted
result.

Therefore, specify "Total: " in the first field. Choose "#,##0.00" from the combobox. Specify " (excluding
taxes)" in the third field.

Change value of attribute
A formula computes a value. This value can be used to add/replace the text node immediately after the formula
or this value can be used to add/replace an attribute of the element containing the formula.

If you want to use a formula to change an attribute, check this toggle and use the associated combobox to
specify the name of this attribute.

Disabled
Check this toggle to disable the formula being edited.

Disabling a formula means passivating it. That is, it is no longer used to update the document. In some cases,
this may be a handy alternative to removing it.
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Tip

In the styled view, formulas are represented by a small F icon. Clicking on this icon with the middle
button of the mouse allows to switch the state of the formula from enabled  to disabled  and vice-
versa.

5.The "Preferences" dialog box
The preferences specified in this dialog box are stored in XXE_user_preferences_dir/preferences.properties,
a Java™ property file (an ISO-8859-1 text file using a very simply key :value format).

XXE user preferences directory is:

• $HOME/.xxe5/ on Linux.

• $HOME/Library/Application Support/XMLmind/XMLEditor5/ on the Mac.

• %APPDATA%\XMLmind\XMLEditor5\ on Windows XP, Vista and 7.

Example: C:\Documents and Settings\john\Application Data\XMLmind\XMLEditor5\ on Windows XP.
C:\Users\john\AppData\Roaming\XMLmind\XMLEditor5\ on Windows Vista and 7.

If you cannot see the "Application Data" directory using Microsoft Windows File Manager, turn on
Tools>Folder Options>View>File and Folders>Show hidden files and folders.

5.1. New options

Immediately save newly created document
When a new document is created using File → New, File → Open as Template or File → Open Copy and this
toggle is checked, XXE will immediately prompt the user for a save file name. This save file name is used to
actually create on disk the file corresponding to the new document.

Note that even when this toggle is not checked, XXE may immediately prompt the user for a save file name.
This will happen for composite document templates, that is, document templates referencing graphics files
and/or including document modules.

Default: not checked.

5.2. Open options

Use the native file chooser in preference to the multi-platform file chooser
If this toggle is checked, the native file chooser will be used in preference to Java's multi-platform file chooser.

Note that automatically appending the proper extension to the selected save filename (see option "Ensure that
a save filename has an extension" [84]) is not possible when this option has been turned on.

Default: checked on the Mac, not checked on Windows, disabled (grayed out) on the other platforms.

When no DTD or schema, guess ignorable white space
If this toggle is checked, when opening a document not constrained by a DTD or a schema, white space
characters are stripped from elements containing child elements separated by white space.

This heuristic is generally a good one for XML data.

Default: checked.

When no DTD or schema, simulate a DTD
If this toggle is checked, a dynamic, non constraining, pseudo DTD is used for documents not conforming to
a DTD or schema.

80

Dialog boxes



The pseudo DTD simply remembers all attributes and child elements added to each element during the editing
session. Thanks to this pseudo DTD, the pick lists of the Edit and Attributes tools are always filled with
sensible values.

Default: checked.

Ignore <?xml-stylesheet?>
If this toggle is checked, xml-stylesheet processing instructions specifying which style sheets to use for the
newly loaded document are ignored. If the XXE configuration associated to the newly loaded document specifies
CSS style sheets, these style sheets are used instead.

Using this option is useful if <?xml-stylesheet?> specifies a style sheet for use by a Web browser such as
Mozilla and not a style sheet for use by XXE.

Default: not checked.

Inform about non-editable document parts
If this toggle is checked and if the document being opened is modular (that is, contains references to nodes
coming from other documents), XXE display a dialog box informing the user that included nodes have been
marked as non-editable.

Default: checked.

Lock documents stored on the local filesystem
If this toggle is checked, the file containing the document being opened in the editor is automatically locked
using an advisory, application-level, lock.

In practice, this means that:

• Applications other XXE can open and modify the document being edited in an instance of XXE.

• If you try to open in XXE a document being edited in another instance of XXE (run by you or by one of
your coworkers), XXE will inform you that the file is locked and will tell you who is locking it. After that
you'll be able to open the document but, if you modify it, you'll have to save it to another location.

Caveat: In order to use this facility, you and all your coworkers possibly editing the same files, need to turn
this option on. If one of your coworkers forgets to do it, XXE will not be able to detect that the file being
opened is locked, and in such case, your coworker may overwrite a document being edited by another person.

How to forcibly remove a lock

A lock is implemented by the means of a hidden text file containing information about who has
locked the corresponding document.

On Windows, the lock file corresponding to document C:\doc\doc.xml is C:\doc\doc.xml.LOCK
(with the hidden attribute set on this file).

On the other platforms, the lock file corresponding to document /home/john/doc/doc.xml is
/home/john/doc/.doc.xml.LOCK.

Manually deleting the lock file forcibly removes the lock set on the corresponding document. Note
that it is harmless to delete such lock files and this, at any time.

Default: not checked.

When possible, lock documents stored on remote filesystems
Unlike the above toggle, this form applies only to files stored on filesystems other than the local one (WebDAV,
FTP, Zip, etc).

This group of options is present only in XMLmind XML Editor Professional Edition.
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Preferred lock mode
Specifies the type of lock [82] used for the document being edited, when the underlying document store
supports locking. Currently, only WebDAV supports document locking.

Note that the mode specified here is just a wish. XXE will adapt the lock mode to what is actually supported
by the underlying document store. For example, if the Shared mode has been chosen by the user and the
underlying document store only supports Exclusive locking, the document being edited will be locked
using an Exclusive lock.

Default: Exclusive

Identifier as a lock owner
Specifies a free form string identifying you as the person locking a document. This string is presented to
other users wishing to know who is locking a document. It is recommended to specify your email address
(example: jdoe@acme.com).

Default: empty string which implies user_name@host_name (example: jdoe@fast.acme.com)

Table 9.1. Lock Types

DescriptionLock type

The document being edited in not locked.None

The document being edited is locked using a shared
lock.

Shared

A shared lock does not prevent you from overwriting
a document shared-locked by another author but a
least, you are informed that the document is being
``used'' by this other author. (In such case, you'll
generally want to contact him to decide what to do.)

The document being edited is locked using an exclus-
ive lock.

Exclusive

An exclusive lock prevents you from overwriting a
document exclusively-locked by another author.

5.3. Save options

Encoding
Specifies the encoding used for XML files saved by XXE (if save options have not been specified in an XXE
configuration file — see below).

Default: the original encoding of the file.

Save characters outside encoding as entity references
If this toggle is checked, all characters not supported by the encoding are saved as entity references.

Example: the Euro sign is not supported by the ISO-8859-1 encoding. If this toggle is checked, the Euro sign
is saved as "&euro;". If this toggle is not checked, the Euro sign is saved as "&#8364;".

Of course, for a character to be saved as an entity reference, the corresponding entity must have been defined
in the DTD.

Example: the Euro sign is not supported by the ISO-8859-1 encoding. If there is no entity defined for this
currency symbol, the Euro sign is saved as "&#8364;" whether the toggle is checked or not.

Default: checked.
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Always save these characters as entity references
Specifies which characters, even if they are supported by the encoding, are always saved as entity references.

Example: the Copyright sign is supported by the ISO-8859-1 encoding but you may prefer to see it saved as
"&copy;". In such case, specify "169" in this text field.

This attribute contains a list of character ranges. A character range is either a single character or an actual
range char1:char2.

A character may be specified using its Unicode character number, in decimal (example: 233 for e acute), in
hexadecimal (example: 0xE9) or in octal (example: 0351).

Because names are easier to remember than numbers, a character may also be specified using its entity name
as defined in the DocBook 4.2 DTD (example: eacute). Note these symbolic specifications are supported
whatever is the DTD or schema of the document being saved.

Examples: nbsp 160 0xA0 0240 reg 174 0x00ae 0256 pound:yen 163:165 0xA3:0xA5 0243:0245

Default: empty.

Ignored if toggle "Save characters outside encoding as entity references [82]" is not checked.

Indent
If this toggle is checked, XML files saved by XXE are indented (if save options have not been specified in an
XXE configuration file -- see below).

The fields and toggles that follows in the Indent frame may be used to parametrize indentation.

Default: checked.

Indentation
Specifies the number of space characters used to indent a child element relatively to its parent element.

Default: 2.

Max. line length
Specifies the maximum line length for elements containing text interspersed with child elements.

Default: 78.

This value is only used as a hint: XML files created by XXE may contain lines much longer than the specified
length.

Add open lines
If this toggle is checked, an open line is added between the child elements of a parent element (if the content
model of the parent only allows child elements).

Default: checked.

Favor interoperability with HTML and SGML
If this toggle is checked:

• Empty elements having a non empty content are saved as "<tag></tag>".

• Empty elements having an empty content are saved as "<tag />" (with a space after the tag).

Default: checked.
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Table 9.2. XHTML examples

Toggle not checkedToggle checked

<p/><p></p>

<br/><br />

Do not indent unconstrained documents
If this toggle is checked, XML files generated by XXE when saving documents not constrained by a DTD,
W3C XML Schema or RELAX NG schema, are not indented, even if the Indent toggle is checked.

Note that when this toggle is not checked, XXE uses very simple heuristics to indent unconstrained documents.
Indenting such documents this way may add white space to places where it is significant.

Default: not checked.

Override settings specified in config. files
The above options can also be specified in a configuration file customizing XXE for a specific XML application.

If this is the case, when the configuration is in use, what has been specified in the Options dialog box is com-
pletely ignored, unless this toggle is checked.

Default: not checked.

Automatically save modified documents
If this toggle is checked, XXE will automatically save modified documents.

Default: not checked.

Max. modifications before saving
A modified document will be automatically saved after specified number of modifications. Typing a character
counts as a modification.

Default: 300.

Idle time (seconds) before saving
If a modified document is no longer edited during specified number of seconds, this document is automatically
saved, even if the "Max. modifications before saving" count has not yet been reached.

This option allows to make the auto-save feature as non-intrusive as possible.

Default: 30.

Ensure that a save filename has an extension
If this toggle is checked, XXE automatically appends an extension to the save filenames (File → Save As,
File → Save Copy, etc) having no extension at all.

The extension is guessed based on the current filename of the document to be saved. For example, if you save
/tmp/page.html as /home/john/index, XXE automatically appends ".html". When the extension cannot
be guessed this way, XXE fallbacks to ".xml".

Note that automatically appending the proper extension to the selected save filename is not possible when
option "Use the native file chooser in preference to the multi-platform file chooser" [80] has been turned on.

Default: checked.

Before saving, make a backup copy of the file
If this toggle is checked, a copy of the original file is made (same name but ending with '~') before saving the
modified copy.
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Note that backup files are created at the beginning of the editing session and not each time a file is saved. This
makes the backup files much more useful. For example a diff between foo.xml~ and foo.xml will show you
what you did during last editing session.

Also note that this feature is supported only for save files stored on the local file system. For example, backup
files will never be created on a WebDAV server.

Default: checked.

Automatically update references in modular documents
If this toggle is checked, references found in modular documents are automatically updated each time a refer-
enced document is saved to disk.

Example: document book.xml references chapter1.xml and chapter2.xml. File chapter2.xml is modified
and saved to disk using XXE. Nodes included in book.xml coming from chapter2.xml are automatically
updated.

Counter-example: document book.xml references chapter1.xml and chapter2.xml. File chapter2.xml
references section1.xml and section2.xml. File section2.xml is modified then saved to disk using XXE.
Nodes included in book.xml indirectly coming from section2.xml are not automatically updated. In such
case, if you really want to update book.xml, you'll have to use View+Redraw (Ctrl+L) See note about Updating
the references contained in a modular document [30].

Default: checked.

5.4. Print options

Note

The options for the page footer are not described here because they are identical to those used for the
page header (described below).

Screen resolution
Specifies the screen resolution in DPI (Dot Per Inch) used when printing. This resolution directly determines
the amount of text a printed page can contain.

Default: 100dpi.

Begin
The page header has 3 areas: begin (the left for left-to-right languages), middle, end (right). This field specifies
the text printed at the left of the page header.

Default: empty.

Each area can contain a mix of text and variables [86]

Middle
Specifies the text printed at the center of the page header.

Default: empty.

End
Specifies the text printed at the right of the page header.

Default: empty.

Color
Specifies the color of the text of the page header.

Default: gray.
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Note that the font used for the page header is the default font of the style sheet (see the View options [88]
below).

Underline [Overline]
Specifies if a thin line is to be printed below the page header [above the page footer].

Default: checked.

Table 9.3. Substituted Variables

DescriptionVariable

File name of the document being edited%F

Same as %F but shortened to approximately 30 characters%f

Base name of the document being edited%B

Current date%D

Current time%T

Equivalent to localized "page %I of %C"%P

Current page number%I

Total page count%C

5.5. Edit options

Use integrated input method support
When an input method (e.g. Japanese Romaji Input) has been selected by the user,
• If this toggle is checked, a composition area, managed by the XML editor, is displayed inside the document

view, below the caret.
• If this toggle is not checked, a composition window, managed by the operating system, is displayed outside

the main window of the XML editor.

Figure 9.1. Composition area displayed below the caret

Default: not checked. (Slightly more efficient if you never use input methods.)

Note

This feature cannot be made to work on Linux. It should work fine only on Windows and on the
Mac.

Clicking with middle button pastes system selection
If this toggle is checked, clicking with the middle button (or with the mouse wheel) pastes the characters
copied to the ``system selection''.

On platforms not supporting system selection (all but generic Unix/Linux), this action pastes the content of
an internal clipboard.

Default: not checked.

Add interactive left margin to the styled view
If this toggle is checked, the editor adds a gray margin at the left of the styled document views. This margin
allows to trigger special, customizable, actions when the user clicks in it. By default, these actions are:
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• Clicking in this margin selects the ``block'' (paragraph, row, row group, table) in front of the click location.
• Clicking again without moving the mouse, selects the parent of the selected element. Clicking again without

moving the mouse, selects the grand-parent, and so on.

Do not click several times too fast otherwise the editor will think you are double-clicking or triple-clicking
and therefore, selecting elements this way would not work.

• Clicking in this margin while pressing the Shift key extends the node selection to the block which is in
front of the click location.

Default: not checked.

Append mode
Specifies how to quickly complete what is being typed in an autocompletion-enabled text field.

None
There is no quick way to complete what is being typed (other than using Up and Down arrows).

Automatic
What is being typed is automatically completed to compose first possible suggestion.

Manual
The user needs to explicitly press on the space bar (or on Ctrl+Space, if some of the choices contain
whitespaces) to complete as much as possible what has been typed.

Example: the list of choices is "aaz aaa bbz bbb ccz ccc". The user types "b".

None
Nothing happens and pressing on the space bar has no effect.

Automatic
The text field is automatically updated to contain "bbz".

Manual
Nothing happens, but pressing on the space bar will add a "b" to what has been typed (which gives "bb").

Default: Manual.

In the choice list, only show suggestions
If this toggle is checked, the list which displays possible choices (e.g. elements to be inserted in the document)
is kept as short as possible.

Default: not checked.

By default, such list displays all possible choices, whether matching what has been typed in the autocompletion-
enabled text field or not.

Example: the list of choices is "aaz aaa bbz bbb ccz ccc". The user types "b".

If this toggle is not checked, the list contains "aaz aaa bbz bbb ccz ccc" and item "bbz" is highlighted.

If this toggle is checked, the list contains "bbz bbb" and item "bbz" is highlighted.

Automatically select an attribute
When toggle Never is not checked, Tools → Edit Attribute (Ctrl+E) automatically selects an attribute of the
element. The selected attribute is determined as follows, in this order:

1. First required attribute containing the "???" placeholder value.

2. First attribute, required or not, containing the "???" placeholder value.

3. If toggle Unique required attribute is checked, unique required attribute, whatever its value.
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Default: First attribute containing a placeholder value.

Max. undo actions
Specifies the maximum number of undo (redo) actions a user will be able to perform. Limited to 100 because
a single undo action may consume a great deal of memory.

Default: 20.

Allow advanced use of XInclude
By default, command Edit → Reference → Copy as Reference [27] allows to copy as a reference only the
root element of a document or an element having an ID. If this toggle is checked, it becomes possible to copy
as a reference any range of sibling nodes.

Default: not checked.

Warn about advanced use of XInclude
This checkbox is disabled unless "Allow advanced use of XInclude [88]" has been checked.

If this toggle is checked, you'll be informed when what you are copying as a reference qualifies as "an advanced
use of XInclude". Typically you'll be informed that the element you are copying as a reference has no ID at-
tribute.

If you check Allow advanced use of XInclude [88], it is also strongly recommended to also turn this option
on.

Default: not checked.

5.6. View options

Wrap words wider than available space
If this toggle is checked, words which are wider than the space available in the document view, are wrapped.
For example, when this toggle is not checked (note the horizontal scrollbar):

When this toggle is checked:
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This option, which slightly modifies the behavior of word wrap in both the tree view and in the styled view,
is useful to deal with long URLs and with languages such as Japanese or Chinese which do not use spaces
between words.

Default: not checked.

Display images
Specifies how by default, images are displayed in styled views:

normally
Display the image normally, that is, possibly scaled if this has been specified using attributes such as
width and height.

as thumbnails
Show the bounding box of the (possibly scaled) image and, if there is enough room in this rectangle, also
show a thumbnail (at most 128x128 pixels large).

This option allows to avoid out of memory errors when opening documents containing a large number
of high-resolution images.

as bounding boxes
Show the bounding box of the (possibly scaled) image.

This option allows to speed up opening documents containing a large number of high-resolution images.

Note that options "as thumbnails" and "as bounding boxes" have no effect on images having an intrinsic size
smaller than 32x32 pixels. Such small images are always displayed normally.

Default: normally.

5.6.1. "CSS stylesheet defaults" subsection

The following options parameterize the CSS style sheet used to visualize the document or to print it.

Setting some of these preferences will have no visible effect if the style sheet author has specified the corresponding
properties in the style sheet. For example, if the user's preferred background is specified in the CSS stylesheet defaults
subsection as being light yellow and if the style sheet author has specified the root element background-color
as being white, the document will be rendered with a white background.

Serif font family
Specifies the font family used for property value font-family:serif.

Default: Serif (the Java™ default serif font family).

SansSerif font family
Specifies the font family used for property value font-family:sans-serif.

Default: SansSerif (the Java™ default sans-serif font family).

Monospaced font family
Specifies the font family used for property value font-family:monospace.

Default: Monospaced (the Java™ default monospaced font family).

Default font family
Specifies the default value for property font-family.

Default: SansSerif.

Default font size
Specifies the default value for property font-size. See also View → Text Size [30].
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Default: 12pt.

Default background
Specifies the default value for property background-color. (Displays standard color chooser dialog box.)

Default: white.

Default text color
Specifies the default value for property color. (Displays standard color chooser dialog box.)

Default: black.

5.6.2. "Tree view settings" subsection

The following options allow to configure the fonts, colors and level of details of the tree view.

Except for "Fonts and colors", the following options apply only to the ``stand-alone'' tree views. That is, they do
not apply to the ``mini'' tree views embedded in a styled view (e.g. DocBook colspec and spanspec elements are
rendered as ``mini'' tree views within the styled view).

Base font size
The sizes of all the fonts used to render a tree view are computed relatively to this font size. See also View
→ Text Size [30].

Default: 12pt.

Fonts and colors
Displays a dialog box [101] allowing to specify the fonts3 and colors used to render a tree view.

Show attributes
Toggles the display of the attributes in the tree view.

Default: checked.

Show characters in text nodes
Toggles the display of text node characters in the tree view.

Default: checked.

Show characters in comment nodes
Toggles the display of comment node characters in the tree view.

Default: checked.

Show characters in processing-instruction nodes
Toggles the display of processing-instruction node characters in the tree view.

Default: checked.

5.7.Tools options

5.7.1. Validate options

Filter duplicate ID errors found in modular documents
Pasting in a document two references to the same element will cause the Validity tool to display duplicate ID
errors. This is a problem because the author didn't do any mistake by pasting these two references and because
too many of these ``false'' duplicate ID errors may hide real duplicate ID errors. That's why turning on this
option will discard such ``false'' duplicate ID errors from the Validity tool.

3Font family and font style, but not the font size which is computed using "Base font size" [90].
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Default: checked.

Automatically show Validity tool
Document validity is automatically checked each time the document is saved to disk. If this toggle is checked,
when validity errors are found, the Validity tool ``tab'' is automatically selected in order to display the error
messages.

Default: not checked.

5.7.2. Document Set options

The following options specify which actions are to be automatically performed by XXE after a document set [57]
is opened using File → Document Set → Open Document Set [15] and/or after a document set is explicitly refreshed

using  Refresh [61].

Automatically update all inclusions in member documents
Turning on this option is useful only if your DITA topics make use of attribute conkeyref.

Default: not checked.

Automatically redraw member documents
Turning on this option is useful only if your DITA topics make use of attribute keyref and when some of the
keyrefs point to image files.

Default: not checked.

Automatically validate member documents
Turning on this option is generally recommended.

Default: checked.

5.7.3. Spell options

Options used by both the automatic and ``traditional'' spell checkers:

Ignore case
If this toggle is checked, ignore capitalization errors.

Default: not checked.

Ignore mixed-case words
If this toggle is checked, do not check words containing case mixing (e.g. "SpellChecker").

Default: not checked.

Ignore words with digits
If this toggle is checked, do not check words containing digits (e.g. "b2b").

Default: checked.

Ignore URL-like words
If this toggle is checked, ignore words looking like URLs or file names (e.g. "www.xxx.com" or "c:\boot.ini").

Default: checked.

Ignore duplicate words
If this toggle is checked, do not signal two successive identical words as an error.

Default: not checked.
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Check punctuation
If this toggle is checked, punctuation checking is enabled: misplaced white space and wrong sequences, like
a dot following a comma, are detected.

Default: not checked.

Allow compounds words
If this toggle is checked, all words formed by concatenating two legal words with an hyphen are accepted. If
the language allows it, two words concatenated without hyphen are also accepted.

Default: checked.

Allow general prefixes
If this toggle is checked, a word formed by concatenating a registered prefix and a legal word is accepted. For
example if "mini-" is a registered prefix, accepts "mini-computer".

Default: checked.

Allow file extensions
If this toggle is checked, accepts any word ending with registered file extensions (e.g. "myfile.txt", "in-
dex.html", etc).

Default: checked.

Favor quality over speed
For use on a fast computer. Does not influence the number of suggestions (always limited to 15).

Default: not checked.

Activation of the automatic (AKA on-the-fly) spell checker.

This group of options is present only in XMLmind XML Editor Professional Edition.

Never activate the automatic spell checker
When a document is opened, never activate the automatic spell checker, even if this is specified in the config-
uration file associated to the opened document.

Default: not checked.

Always activate the automatic spell checker
When a document is opened, always activate the automatic spell checker, even if this is not specified in the
configuration file associated to the opened document.

Default: not checked.

Activate if this is specified in the configuration file
When a document is opened, activate the automatic spell checker if this is specified in the configuration file
associated to the opened document (using the spellCheckOptions configuration element, see Section 26,
“spellCheckOptions” in XMLmind XML Editor - Configuration and Deployment).

Default: checked.

5.7.4. Helper applications options

File types
List of file types. Each file type has an associated helper application. This helper application is assumed to be
able to open files detected as having this type. A helper application may be a viewer or an editor.

Default: the "text/plain" file type:

• On Windows: text/plain:txt:::notepad "%F"
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• On the Mac:

• for a version older than Mac OS X 10.5 (e.g. Tiger): open -t "%F",

• starting from Mac OS X 10.5 (Leopard): open -W -n -t "%F".

See also Helper applications on the Mac [104].

• On Unix: text/plain:txt:::xterm -e vi "%F"

Buttons acting on this list:

Add
Displays the "Helper Application Editor" dialog box [102] in order to add a new file type to the list.

Edit
Displays the "Helper Application Editor" dialog box [102] in order to view or modify selected file type.

Remove
Removes selected file type from the list.

Default viewer
Specifies which default viewer to use in case the type of the file to be opened has not been detected. In practice,
commands making use of the default viewer typically assumes that it is in fact a Web browser. This implies
that these commands assume that a default viewer can open URLs as well as filenames and that it can open
text, HTML, GIF, PNG and JPEG files.

This field must contain a command line interpreted by the native shell of the platform: cmd.exe on Windows
and /bin/sh on the Mac and on Unix.

This command line must reference one of these two substituted variables: %U and %F. In principle, %U is replaced
by the URL of the file to be opened by the helper application and %F is replaced by a filename. In practice, %U
is just a hint meaning: the helper application can open URLs as well as filenames.

Default: depends on the platform:

• On Windows: start "" "%U"

• On the Mac: open "%U"

• On Unix: dynamically detected. By default: firefox "%U"

Buttons acting on this field:

Reset
Resets the field to its default value (see above).

Choose
Displays the standard file chooser in order to specify an application (e.g. a .exe or a .bat file on Windows).
String " "%F"" is automatically appended to the chosen application.

See also Helper applications on the Mac [104].

5.7.5. Spreadsheet options

 This group of options is available only in XMLmind XML Editor Professional Edition, where it is hidden by
default. You need to enable it by checking "Enable the Integrated Spreadsheet Engine" in Options → Preferences,
Features section.

Open spreadsheets in auto-update mode
Specifies that spreadsheets are to be opened in auto-update mode.
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In manual update mode, only newly inserted formulas are computed. To force a full calculation, the user has
to explicitly use Tools → Spreadsheet → Update [35].

In auto-update mode, a full calculation is automatically performed, if needed to, when the editing context
changes. For example: type some text in a paragraph, then click in (or tab to) another paragraph to trigger a
spreadsheet calculation.

Note that in both modes, a full calculation is automatically performed, if needed to, before validating or saving
the document.

Using manual update mode is recommended if you have a slow computer or if you have inserted a lot of for-
mulas in your document or if your formulas access many external documents.

Default: checked.

Maximum number of iterations allowed for calculations in spreadsheet
Specifies the maximum number of iterations allowed for calculations in spreadsheet. This limit is used to
prevent the spreadsheet engine from looping in case of cycles in formulas.

Default: 20.

5.8. Window options

Show both tree and styled views
If this toggle is checked, XXE will automatically create two views for a newly opened or newly created doc-
ument. That is, by default, a document tab will contain a tree view and a styled view side by side.

This option has of course no effect on documents for which no CSS style sheet is available.

Default: not checked.

Place tree view at right
If this toggle is checked, the tree view is to be placed at the right of the styled view.

Default: not checked.

Tree view width
Specifies the width of the tree view in percentage of the available window area.

Default: 33%.

5.9. Install add-ons options

Note

This preference sheet is absent when XMLmind XML Editor has been started using Java™ Web Start.

Download add-ons from these servers
Add-ons available for download are listed in .xxe_addon files. The list of ``servers'' below this checkbox
contains the URLs of these .xxe_addon files.

• Use button Add to add an URL to the list.

• Use button Edit to modify the selected URL.

• Use button Remove to remove the selected URL from the list.

• Use button Reset to reset the list to a standard value. Clicking this button displays a dialog box allowing to
choose between three different strategies:
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Use the primary add-on server
Recommended choice if you are running one of the two most recent versions of XMLmind XML Editor.

Use the secondary add-on server
Use this server when the primary add-on server is temporarily down.

Use the add-on archive
Use the archive if you are running a version older than the two most recent versions of XMLmind XML
Editor.

Default: checked. The default value of the list of ``servers'' is:

• http://www.xmlmind.com/xmleditor/_usercontrib/list.xxe_addon

• http://www.xmlmind.net/xmleditor/_download/list-${XXE_VERSION}.xxe_addon (for example,
variable ${XXE_VERSION} is replaced by "3_5_2" if the version of the running XML Editor is v3.5.2)

• http://www.xmlmind.net/xmleditor/_download/list.xxe_addon

Search add-ons in this directory
Zip files containing add-ons may have been downloaded using a Web browser and then copied to a local dir-
ectory (for example, because you have problems downloading add-ons directly from XXE). In such case,
check this box and specify in the text field below it this local directory.

Note that this directory may also contain unzipped add-ons (not recommended though). This is useful because
sometimes Web browsers have the bad habit of automatically unzipping the downloaded Zip files.

Default: not checked. No local directory containing Zip files.

Install add-ons in the user's preferences directory
Install all types of add-ons in XXE_user_preferences_dir/addon/, where XXE_user_preferences_dir is:

• $HOME/.xxe5/ on Linux.

• $HOME/Library/Application Support/XMLmind/XMLEditor5/ on the Mac.

• %APPDATA%\XMLmind\XMLEditor5\ on Windows XP, Vista and 7.

Example: C:\Documents and Settings\john\Application Data\XMLmind\XMLEditor5\ on Windows
XP. C:\Users\john\AppData\Roaming\XMLmind\XMLEditor5\ on Windows Vista and 7.

If you cannot see the "Application Data" directory using Microsoft Windows File Manager, turn on
Tools>Folder Options>View>File and Folders>Show hidden files and folders.

This radiobutton is disabled (grayed) if you have insufficient privileges to create files in this directory.

Default: not checked.

Install add-ons in XXE installation directory
Install all types of add-ons in XXE_install_dir/addon/, where XXE_install_dir is, for example, on Win-
dows, C:\Program Files\XMLmind_XML_Editor.

This radiobutton is disabled (grayed) if you have insufficient privileges to create files in this directory.

Default: not checked.

Installation directory depends on the add-on
Add-ons which depend on a specific version of XXE are installed in XXE_install_dir/addon/, other add-
ons are installed in XXE_user_preferences_dir/addon/.
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This way, the add-ons which depend on a specific version of XXE, are automatically uninstalled when, in the
future, you'll upgrade the application. The other add-ons, which do not on a specific version of XXE, are not
uninstalled when, in the future, you'll upgrade the application.

In practice, the following add-ons are installed in XXE_install_dir/addon/:

• XSL-FO processor plug-ins.

• Image toolkit plug-ins.

• Non-XML format plug-ins.

• Virtual drive plug-ins.

• Configurations, customizing XXE for a given document type, which include custom commands written in
Java™.

On the other hand, the following add-ons are installed in XXE_user_preferences_dir/addon/:

• Translations of XXE to languages other than English.

• Spell checker dictionaries other than the English one.

• Configurations, customizing XXE for a given document type, which don't include custom commands
written in Java™.

Note that this radiobutton is disabled (grayed) if you have insufficient privileges to create files in the
XXE_user_preferences_dir/addon/ directory or in the XXE_install_dir/addon/ directory, that is, when
there is no possible choice for the installation directory.

Default: checked.

5.10. General options

Use a unique instance of XMLmind XML Editor
If this toggle is checked, a unique instance of XMLmind XML Editor is used to open all your XML documents.
For example, if you double-click on the icon of an XML document in the file ̀ `explorer'', the running instance
is used to open this XML document. When this toggle is not checked, a new instance of XXE is started in
order to load the document clicked upon.

If there is no running instance of XXE, a new instance is started. If the running instance is hidden by other
windows or is iconified, it is made visible before opening the requested document.

This feature also works fine from the command line. For example, on Linux, if this toggle is checked, executing
"xxe mydoc.xml &" will cause the running instance to be used to open mydoc.xml.

If you need to change this option, make sure to close all running instances expect one. Then change the option
in the last instance and close it. Then restart XXE.

Default: not checked.

Port
Specifies the TCP/IP port used by different instances of XXE to communicate with each other. It is highly
recommended to use a port in the dynamic/private range: 49152 to 65535.

Default: 49987

Automatically reopen last opened document
This option is examined just after XXE is started, when no documents to be opened have been explicitly spe-
cified (e.g. by double-clicking on an XML file or by using command line options). When turned on, this option
forces XXE to reopen the last document opened during the preceding editing session.
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See also the -last [119] command line option for a handy alternative.

Font size
May be used to change the base font size of XXE menus and dialog boxes.

Default: default base font size of Java™ applications.

Locale
May be used to force the language used in XXE menus and dialog boxes. For example, may be used to force
the use of English on a machine where the default locale is German.

Default: default locale of the machine running XXE.

Style
May be used to change the look and feel of XXE user interface.

Default: the system look and feel, except on Linux/Unix, where the cross-platform look and feel (Metal) is
used.

5.10.1. Features Options

Features which are not useful in the general case are hidden by default. You need to check the toggle corresponding
to a feature and then restart XXE in order to enable this feature.

Enable the "File|Document Set" Submenu
Check this toggle to enable the File → Document Set submenu [15].

Feature name: OpenDocumentSet.

Enable the "File|Folder" Submenu
Check this toggle to enable the File → Folder submenu [17].

Feature name: OpenFolder.

Enable the Include Tool
Check this toggle to enable Edit → Reference → Replace By Reference, Edit → Reference → Insert Reference
Before, Edit → Reference → Insert Reference, Edit → Reference → Insert Reference After and the Include
tool.

Feature name: IncludeTool.

Enable the "Search|Bookmark" Submenu
Check this toggle to enable the Search → Bookmark submenu [29].

Feature name: Bookmarks.

Enable the "View|Display Images" Submenu
Check this toggle to enable the View → Display Images submenu [31].

Feature name: ImageViewportMode.

Enable the Integrated Spreadsheet Engine
Check this toggle to enable Tools → Spreadsheet and the Options → Preferences, Tools|Spreadsheet group
of options.

Feature name: Spreadsheet.

This option is present only in XMLmind XML Editor Professional Edition.

Enable the Developer Tools
Check this toggle to enable Options → Reload All Configurations and Help → Mouse and Key Bindings.
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Feature name: DeveloperTools.

Enable the Document Cache Indicator
Check this toggle to display in the status bar an indicator allowing to monitor the activity of the document

cache of XMLmind XML Editor. More information about this indicator in  Document cache [72].

Feature name: DocumentCacheTool.

5.11. Advanced options

5.11.1. Cached data options

Uncheck the checkbox to disable the corresponding cache.

Click the Clear button to make the corresponding cache empty. Note that all the following caches are automatically
cleared each time you install a new version of XXE.

Caution

If you are a consultant developing an XXE configuration on the behalf of a group of writers, you'll almost
certainly need to disable all the following caches.

Quick Start cache
This cache exists only when XMLmind XML Editor is run as a desktop application. It does not exist when
XXE is run as an applet or when it has been started using Java™ Web Start.

The lists of configuration objects discovered by XXE during its startup (.xxe configuration files, XML catalogs,
translations of XXE messages, spell-checker dictionaries, all kinds of plug-ins, customize.xxe_gui files,
etc) are compiled and cached for slightly faster subsequent startups.

Once these lists have been compiled and cached in directory XXE_user_prefer-

ences_dir [80]/cache/start/, a configuration file such as docbook.xxe is loaded only when this is really
needed, that is, when you open a DocBook document. In other words, if you never open a DocBook document
(and if you never use File → New) during your editing session, then the docbook.xxe configuration file will
not be loaded at all.

Default state: checked.

Caution

This cache is automatically cleared when you install add-ons using Options → Install Add-ons and
also when you upgrade XXE. If, for any reason you cannot install an add-on using Options → Install
Add-ons and have to install this add-on manually by unzipping it in one of the two addon/ directories,
do not forget to clear the quick start cache before restarting XXE.

Password cache
XXE allows to open documents stored on WebDAV, FTP, SFTP, etc, servers. Such servers generally require
the user to authenticate himself.

In order to do this, XXE prompts the user for his username and password. Once this is done, the credentials
are always cached for subsequent use within the same editing session.

Moreover, if the user check the "Remember these username and password" checkbox of the authentication
dialog box, the credentials are saved to the user preferences file for use in subsequent editing sessions.

The password cache cannot be disabled.
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Tip

If you typed an incorrect username and/or password, you'll probably want to click the Clear button
of this Password cache. Doing this forces XXE to prompt you again for your credentials.

Document cache
This document cache is needed because some of the components of XXE (e.g. the XPath document() function
in XMLmind XML Editor - Commands) have to quickly access the contents of documents which have not been
explicitly opened in the XML editor by the user.

Default state: checked. Default size: 100.

Schema cache
When an instance document conforming to a grammar (DTD, W3C XML Schema or RELAX NG Schema)
is opened in XXE, the grammar is checked for validity, then the instance document is checked for validity.

Checking a grammar for validity may be a lengthy operation for a medium-size W3C XML schema and for
a large DTD such as DocBook. (This implies that this cache is not useful if you exclusively use small or me-
dium size DTDs such as XHTML.)

Therefore, if the cache is enabled, XXE checks the grammar the first time it is used by an instance document
and then caches it for subsequent uses. The grammar is cached
1. in memory,
2. on disk using a fast loading binary format (DTD, W3C XML Schema, but not RELAX NG Schema).

The directory used to store the fast loading binary files is XXE_user_prefer-

ences_dir [80]/cache/schema/.

The cache records the location and date of the source files of the grammar. If these source files are removed
or modified, the cache will automatically discard the obsolete cached grammar. Of course, this forces XXE
to load an up-to-date grammar from the source files.

Note that the existence and date of remote source files (that is, grammar files located on a HTTP or FTP
server) are not checked by the schema cache.

Default state: checked. Default size: 10.

5.11.2. Proxies options

Note

This preference sheet is absent when XMLmind XML Editor has been started using Java™ Web Start.
In such case, proxy servers must be configured using the Java™ Control Panel.

A proxy server is a service which allows clients such Web browsers or XMLmind XML Editor to make indirect
network connections to other HTTP, FTP, etc, servers. A common proxy server is a caching Web proxy. This
proxy provides a nearby cache of Web pages and files available on remote Web servers, allowing clients to access
them quickly and reliably.

That's why, if you have problems listing or downloading available add-ons using Options → Install Add-ons, may
be your organization uses a proxy server to make connections to the Internet and in such case, this proxy server
needs to be declared using this preference sheet.

Direct connection to the Internet
Do not use the services of proxy servers, if any. Make direct connections to the Internet.

Default: checked if Java™ 1.4 is used to run XXE; otherwise not checked.
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Use system settings
Use what has been specified in the ̀ `control panel'' of your desktop/operating system. For example, on Windows,
you'll find these settings in Control Panel > Internet Options > Connections tab > LAN Settings.

Only available if Java™ 1.5+ is used to run XXE. Only works on Windows and on Linux/Gnome.

Default: checked if Java™ 1.5+ is used to run XXE; otherwise not checked and disabled.

Manual proxy configuration
Specify which proxy server to use for which network protocol. Please ask your network administrator to help
you fill this form.

Default: not checked.

HTTP proxy
Specifies the host name of the proxy server to use when HTTP connections are made.

Default: none.

(HTTP proxy) Port
Specifies the port number of the proxy server to use when HTTP connections are made.

Default: 80.

HTTPS proxy
Specifies the host name of the proxy server to use when HTTPS connections are made.

Default: none.

(HTTPS proxy) Port
Specifies the port number of the proxy server to use when HTTPS connections are made.

Default: 443.

FTP proxy
Specifies the host name of the proxy server to use when FTP connections are made.

Default: none.

(FTP proxy) Port
Specifies the port number of the proxy server to use when FTP connections are made.

Default: 80.

SOCKS proxy
Specifies the host name of the SOCKS V4 or V5 proxy server to use when network connections of any
sort are made.

Default: none.

(SOCKS proxy) Port
Specifies the port number of the SOCKS V4 or V5 proxy server to use when network connections of any
sort are made.

Default: 1080.

Authenticate SOCKS user
Check this toggle if the SOCKS proxy server of your organization requires you to authenticate
yourself before using its services.

Default: not checked.
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(SOCKS) User name
Your name as a user of the SOCKS proxy server.

Default: the login name of the user.

(SOCKS) Password
Your password as a user of the SOCKS proxy server.

Default: the empty string.

No proxy for
When XMLmind XML Editor runs on these hosts, do not the services of proxy servers, if any. Make
direct connections to the Internet.

Default: "localhost 127.0.0.1".

6.The "Tree view fonts and colors" dialog box
This dialog box is displayed by clicking "Fonts and colors" [90] in Options → Preferences, View section, "Tree
view settings" subsection. It allows the specify the fonts and colors used to render a tree view.

Note that the sizes of the fonts used to render a tree view are not specified in this dialog box. Instead, they are
specified by "Base font size" [90].

In order to specify a font or a color,

1. Click on a numbered link in the top pane.

In the case of the above screenshot, the user has clicked on [4] which corresponds to modifying "Attribute
name color".
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2. Doing this activates a font chooser or a color chooser in the bottom pane, depending on the kind of property
being modified.

In the case of the above screenshot, "Attribute name color" is a color, therefore the color chooser is activated
and the font chooser is grayed out.

Note that some colors are allowed to be transparent (background and border colors) and some are not (text
colors). For example, if you specify Transparent for "Attribute name color", an error will be reported.

3. Specify a font or a color.

4. Click  (Apply).

The top, preview, pane is automatically updated to reflect your choice.

Other buttons:

Reset
Discard all the changes. Revert to the initial fonts and colors.

Defaults
Discard all the changes. Revert to the default (that is, ``factory'') fonts and colors.

7.The "Helper Application Editor" dialog box
This dialog box allows to view or modify a file type listed in the Helper applications preferences sheet [92].
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A file type is specified by at least one of the following characteristic:

MIME type
The official (or just well-known) formal name of the file type. Generally returned by Web servers to their
client Web browsers. Non-registered MIME types typically start with string "application/x-".

A MIME type may end with a wildcard. Example: "image/*" matches "image/gif", "image/jpeg", etc.

Examples: text/plain, image/jpeg, application/excel, application/x-java-help-index.

Filename extension
If the filename or URL of a file ends with specified ".extension", then this file is detected as having this file
type.

An extension may or may not start with a dot. This is unimportant because, in all cases, a leading dot would
be automatically stripped.

Examples: txt, jpeg, jpg, xls.

Magic string
For some file formats, the first bytes of a file are always the same and therefore, can be considered as being
the signature of this file type.

If a file starts with specified first bytes, then this file is detected as having this file type. This type of detection
is supposed to work like magic, hence the name: ``magic string''.

A magic string may be specified by a the hexadecimal representation of a sequence of bytes (example, one of
the two TIFF magic strings: 4949) or by a quoted sequence of ASCII characters (same example, one of the
two TIFF magic strings: "II").

Examples: TIFF: "II" or 4949, "MM"or 4D4D; GIF: "GIF87a", "GIF89a"; PNG: 89504E47; PDF: "%PDF-".

XML name pattern
If the root element of an XML file has a name which matches specified pattern, then this XML file is detected
as having this file type.

An XML name pattern follows this syntax:

( '{' namespace_URI? '}' )? local_part

One of local_part or namespace_URI may be equal to wildcard "*"

Examples: {*}svg, {http://www.w3.org/1998/Math/MathML}:math.

Each file type has an associated helper application. This helper application is assumed to be able to open files de-
tected as having this type. A helper application may be a viewer or an editor.

Description
Description of the file type. Not mandatory, just recommended. This text is displayed in the File types list of
the Helper applications preferences sheet [92].

MIME type
One or more MIME types (see definition [103] above) separated by spaces.

Filename extension
One or more extensions (see definition [103] above) separated by spaces.

Magic string
One or more magic strings (see definition [103] above) separated by spaces.
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XML name pattern
One or more XML name patterns (see definition [103] above) separated by spaces.

Helper application
This field must contain a command line interpreted by the native shell of the platform: cmd.exe on Windows
and /bin/sh on the Mac and on Unix.

This command line must reference one of these two substituted variables: %U and %F. In principle, %U is replaced
by the URL of the file to be opened by the helper application and %F is replaced by a filename. In practice, %U
is just a hint meaning: the helper application can open URLs as well as filenames.

The Open in XMLmind XML Editor button allows to use XXE as an ̀ `internal'' helper application. For example,
associating XXE to .mml files allows to edit the MathML documents referenced in a DocBook 4 document.

This button merely specifies (xxe) "%U" (notice the parentheses around xxe) as the command template of
the helper application. It is of course possible to directly type this command template, or the following read-
only variant: (xxe) -ro "%U", in the Helper application field.

The Choose Helper Application button displays the standard file chooser in order to specify an application
(e.g. a .exe or a .bat file on Windows). String " "%F"" is automatically appended to the chosen application.

Helper applications on the Mac

When an application (that is, a folder having a name ending with hidden suffix ".app", containing
a package bundle) has been selected by the user, the Choose Helper Application button automatically
prepends:

• for a version older than Mac OS X 10.5 (e.g. Tiger): "open -a",

• starting from Mac OS X 10.5 (Leopard): "open -W -n -a".

Example: "open -W -n -a /Applications/Inkscape "%F"".

Options "-W -n" mean: start a new instance of the application and wait until this instance has exited.
These options are required when the helper application is used to edit the content of an element,
the content of an attribute or the whole document.

In practice, this means that, on Mac OS X versions older than 10.5, a helper application can only be
used for viewing purposes and this, even if the helper is an editor.

8.The "Install Add-ons" dialog box
This dialog box allows to download and install and/or upgrade and/or uninstall one or more add-ons. This dialog
box is not available if XXE has been deployed using Java™ Web Start.

In order to uninstall an add-on, select the Uninstall tab and click on the checkbox of the add-on (looks like this ,
when clicked looks like this ). It is also possibly to select the rows of the add-on table by using the Up and
Down arrows and to toggle the state of the corresponding checkbox by pressing the space bar.

In order to install or upgrade an add-on, select the Install tab and click on the checkbox of the add-on.

The checkbox of an upgrade looks like this . In such case, there is no need to also explicitly uninstall the
corresponding add-on because this is done automatically for you. (However it is harmless to do so.)

Important

XXE integrated add-on manager assumes that proxy servers, if any, have been properly specified using
the Proxies section [99] of the Preferences dialog box.
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Tip

The rows of the Uninstall add-on table have a light yellow background when the corresponding add-on
is installed in the user preferences directory, and a light blue background when the corresponding add-on
is installed in XXE installation directory.

In both cases, a row is disabled (grayed) if you have insufficient privileges to uninstall the corresponding
add-on.

Tip

If a problem occurs when listing the add-ons available for download and/or when uninstalling/installing
the add-ons, use the "Show Message Log" button of the status bar, category "Install Add-ons", to see
logged error messages.

9.The "Save Document As Template" dialog box
This dialog box is displayed by menu item Options → Customize Configuration → Save Document as Tem-
plate [37]. Basically, it allows the user to specify a name for the newly created document template.

The name of a document template may contain any character, including spaces.

The name of a document template may be identical to the name of one of the existing document templates. This
allows to replace an existing document template by a new one.

In the above screen shot, we can see that:
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• The user is creating a new document template called "XMLmind Book".

• Previously, the user has replaced predefined template called "Refentry" by a "Refentry" document template
of its own.

• Previously, the user has created another document template called "XMLmind article".

9.1. Organizing the content of the File   New dialog box

Optional document template properties Category and Order allow to better organize the content of the File → New
dialog box.

Category
Specifies the category of the new document template. A category consists in one or more segments separated
by character '/'. By default, the category of a document template is the name of the configuration in which
this template has been specified.

Order
Specifies the relative order of the new document template within its category. Default value is 100.

For example, stock category "XHTML" includes all the templates specified in stock configurations "XHTML Strict"
and "XHTML Transitional". These stock document templates are "Page (Strict)" and "Page (Transitional)".
Let's suppose a user wants to create a new document template template conforming to the Transitional DTD.

In the above screen shot, we can see that:

• The user is creating a new document template called "XMLmind Page".
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• The user wants it to be found in the same category ("XHTML") as the stock XHTML templates.

• The user wants it to be found after the "Page (Transitional)" stock template (its order, 300, is greater than
200).

• Note that the above dialog box does not list all the document templates belong to category "XHTML", but instead
it lists all the document templates specified the the configuration called "XHTML Transitional".

9.2. Removing a previously defined document template

This dialog box also allows to remove user-defined document templates. In order to do this, simply click on a
template in the "Existing document templates" list and then click on the Remove button.

Note that this operation takes immediate effect: clicking on the Cancel button of the "Save Document As Template"
dialog box will not cancel the deletion of the template4.

You can only remove the document templates you have created. You cannot remove predefined (grayed) document
templates.

In the above screen shot, notice how removing user-defined template called "Refentry" would restore the predefined
template having the same name.

10.The "Save Selected Element as Template" dialog box
This dialog box is displayed by menu item Options+Customize Configuration → Save Selected Element as Tem-
plate [37]. Basically, it allows the user to specify a label for the newly created element template.

Giving a label to an element template is needed to support different templates for the same element type. For ex-
ample, in a DocBook document, select a table element and use Options+Customize Configuration → Save Selected
Element as Template to label it as "L1". Then select another table element and use the same menu item to label
it as "L2". This gives you two table element templates, one called "L1" and the other called "L2".

The label of an element template must be a valid NMTOKEN. It cannot contain whitespace.

The element name and label of a template may be identical to the element name and label of one of the existing
templates. This allows to replace an existing template by a new one.

4The Cancel button of the "Save Document As Template" dialog box just cancels the action of creating a new template.
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In the above screen shot, we can see that:

• The user is creating a new table element template called "invoice".

After creating this template, it will be displayed in the "Existing element templates" list as "table(invoice)",
"table" being the element name of the template and "invoice" being its label.

• Previously, the user has created another table element template labelled "3x3".

• Previously, the user has replaced predefined "table(simple)" template by a "table(simple)" template of its own.

10.1. Advanced options

Use only if the parent element matches the following XPath
Normally an element template is suggested by the Edit tool whatever the parent element where this template
is to be inserted. But in some cases, generally with W3C XML schemas and with RELAX NG schemas and
not with DTDs, you'll want the template to be usable only in certain contexts.

Example: your schema defines two title elements: a job title which is a possible child element of person
and author elements and the optional title (i.e. a caption) of table and figure elements.

You intend to define several job title templates. Example: element template "title(arch)" is defined as
<title>Software Architect</title>.

Of course, you don't want to see "title(arch)" listed by the Edit tool when you are about to give a title to a
table.
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In such case:

1. Click on the "Use only if the parent element matches the following XPath" radio button.

2. Type XPath expression "person|author" in the text field below the radio button.

This means: suggest "title(arch)" but only when the template is to be inserted in a person or an author element.

Note that a very small subset of XPath is supported here:

XPath 1.0 subset

The XPath 1.0 subset is the one defined in "XML Schema Part 1: Structures, Identity-constraint
Definitions", except that absolute XPaths (/foo/bar, //bar, etc) are also supported.

XPath      ::=    Path ( '|' Path )*
Path       ::=    ('/'|'//')? ( Step ('/'|'//') )* ( Step | '@' NameTest )
Step       ::=    '.' | NameTest
NameTest   ::=    QName | '*' | NCName ':' '*'

Both abbreviated syntax and non-abbreviated syntax are supported.

This replaces the default, automatically generated, element template
This option is best explained by an example.

Out of the box, if you insert a table element in a DocBook document, in fact, you insert predefined table
template called "table(simple)".

The "table(simple)" template has two rows and two columns which makes it much more useful that the default,
automatically generated, table template which just contains a single cell5.

Note that when a single named template such as "table(simple)" replaces the default, automatically generated,
element template, the Edit tool does not display its label. For example, in the case of the DocBook table, the
Edit tool displays "table"6 and not "table(simple)".

Now, what if you prefer to use a table having 3 rows and 3 columns plus a thead header as your default
table?

1. Create the table by inserting the rows, cells and header you want.

2. Select this table.

3. Use Options → Customize Configuration → Save Selected Element as Template.

4. The "Existing element templates" list shows you that a predefined template already replaces the default,
automatically generated, one. You can see this because "table(simple)" is displayed in italic.

You need to label your own template like the existing one in order to replace it. Therefore specify "simple"
in the Label of the element template field.

5. Click on check box "This replaces the default, automatically generated, element template".

10.2. Removing a previously defined element template

This dialog box also allows to remove user-defined element templates. In order to do this, simply click on a template
in the "Existing element templates" list and then click on the Remove button.

5The default, automatically generated, element template is the simplest, valid, element allowed by the schema.

Most of the time this heuristic gives good results. However in some cases, the default, automatically generated, element template, is, well, too
simple to be useful.
6There is no ambiguity and this is shorter to type.
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Note that this operation takes immediate effect: clicking on the Cancel button of the "Save Selected Element As
Template" dialog box will not cancel the deletion of the template7.

You can only remove the element templates you have created. You cannot remove predefined (grayed) element
templates.

In the above screen shot, notice how removing user-defined "table(simple)" template would restore the predefined
template having the same element name and label.

11.The "Add Keyboard Shortcut" dialog box
This dialog box is displayed by menu item Options → Customize Configuration → Add Keyboard Shortcut [38].
It allows the user to specify a keyboard shortcut that will invoke a predefined command, last recorded macro-
command or a user-defined macro-command.

In the above screen shot, the user adds a shortcut for command "insertCharSequence" with parameter "- mdash".
This command will be invoked after character "-" (dash) is typed.

7The Cancel button of the "Save Selected Element As Template" dialog box just cancels the action of creating a new template.
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Procedure 9.1. Adding a keyboard shortcut

1. Specify a keystroke. A keystroke is either:

• A typed character specified the Typed Character field.

A typed character is any character you can type using any combination/sequence of pressed keys. A typed
character often does not correspond to a key of your keyboard. For example, on an US keyboard, there is
no $ key. You need to press on key 4 and on key Shift at the same time in order to type the '$' character.

• OR a pressed key specified using the Pressed Key combo box.

A pressed key must correspond to a key actually found on your keyboard. For example, do not choose key
$ on an US keyboard because there is no such key. On the other hand, you may choose it on a French
keyboard which has a $ key8.

You'll often want to also specify the modifier keys (Ctrl, Shift, etc) which must be pressed at the same
time as the main key specified in the Pressed Key combo box. Any combination of modifier keys may be
chosen using the Pressed Key Modifiers combo box.

2. Optionally specify a second keystroke. In such case, the command will be invoked by the sequence: first
keystroke immediately followed by second keystroke.

3. Specify the command invoked by your custom shortcut. There are three possible options for this:

Command
The command invoked by your custom keyboard shortcut is a predefined command (documented in
Chapter 6, Commands written in the Java™ programming language in XMLmind XML Editor - Com-
mands).

You may choose one of the last executed commands by using the list displayed by the "Choose from last
executed command" button.

Last recorded macro
The command invoked by your custom keyboard shortcut is the last recorded macro-command (see Tools
→ Record Macro [35]).

Other macro-command
The command invoked by your custom keyboard shortcut is a custom macro-command that you'll type
in the text area below the "Other macro-command" radio button.

It is recommended to restrict yourself to specifying one of the last executed commands or last recorded macro.
Attempting to use the other options is harmless, but unless you know what you are doing (for example, because
you have posted a support request to the <xmleditor-support@xmlmind.com> public mailing list), the
commands specified the hard way will probably not work.

However, if you decide to follow the hard way, you must know that:

• The Command field, allowing to specify the name of a command, supports auto-completion.

• Clicking on the Documentation link will open in the Web browser the reference manual in XMLmind XML
Editor - Commands describing the command of interest9. This is almost always needed in order to specify
in the Parameter field a valid parameter for the command.

• If you type a custom macro-command in the text area, do not bother declaring namespace prefixes. Consider
that "http://www.xmlmind.com/xmleditor/schema/configuration" is declared as being the default
namespace, that "cfg" is declared as a prefix for namespace "http://www.xmlmind.com/xmledit-

8Suprising, isn't it?
9This requires an access to the Internet if XMLmind XML Editor is deployed using Java™ Web Start.
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or/schema/configuration" and that all namespace prefixes declared in the document being edited (see
Tools → Declare Namespace [32]) are in scope also here.

4. Click OK.

Other example:

In the above screen shot, the user adds a shortcut for command "insert after[implicitElement] #template(fig-
ure,screenshot)". This command will be invoked when the Insert key will be pressed at the same time as the
Control and Shift keys.

Previously, by using the Edit tool, the user has inserted in the document being edited a figure element containing
a screenshot child element10. Having done this now allows her/him to pick this command from the list displayed
by the "Choose from last executed command" button, instead of typing the command name and its parameter.

10She/he picked figure(screenshot) from the list of elements suggested by the Edit tool.
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Note

Many keystrokes may not be used to define custom keyboard shortcuts. Clicking on the "Existing Keyboard
Shortcuts" tab will give you an idea of this fact.

Examples:

• You may not use Ctrl+O because this keystroke is reserved for menu item File → Open.

• You may not use Ctrl+I because this keystroke is reserved for menu item Edit → Insert.

• You cannot use single keystroke Esc because this would prevent existing keyboard shortcuts Esc g
(bound to menu item Select → Find Element), Esc x (bound to menu item Tools → Execute) , etc,
from working11.

• You cannot use keystroke Home, for example followed by a second Home keystroke, because existing
keyboard shortcut Home (bound to command "moveDotTo lineBegin") would prevent your custom
shortcut from working.

Moreover certain keystrokes are reserved by Java™ (e.g. Tab, Alt) or by the operating system (e.g. there
are loads of these on the Mac). Attempting to use these keystrokes for your custom keyboard shortcuts
will almost certainly not work.

11.1. Removing a previously defined keyboard shortcut

This dialog box also allows to remove user-defined keyboard shortcuts.

11Using Esc followed by a second, carefully chosen, keystroke should work fine.
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In the above screen shot, notice how removing user-defined keyboard shortcut Ctrl+Shift+Insert (invoking
command "insert after[implicitElement] #template(figure,screenshot)") would restore the predefined
keyboard shortcut (invoking command "insertNode sameElementBefore[implicitElement]").

Procedure 9.2. Removing a keyboard shortcut

1. Click on the "Existing Keyboard Shortcuts" tab.

2. Select the keyboard shortcut to be removed by clicking on it.

You can only remove the keyboard shortcuts you have created. You cannot remove predefined (grayed)
keyboard shortcuts.

3. Click on the Remove button.

Note that this operation takes immediate effect: clicking on the Cancel button of the "Add Keyboard Shortcut"
dialog box will not cancel the deletion of the keyboard shortcut12.

12The Cancel button of the "Add Keyboard Shortcut" dialog box just cancels the action of creating a new keyboard shortcut.
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12.The "Change Document Conversion Parameters"
dialog box
This dialog box is displayed by menu item Options → Customize Configuration → Change Document Conversion
Parameters [38]. This dialog box allows to specify the XSL style sheet parameters (e.g. paper.type=USLetter)
used when converting the document being edited to other formats (e.g. PDF, HTML, etc).

Procedure 9.3. Adding a user-defined parameter

1. Select the conversion for which you want to specify parameters by using the "Group of parameters" combo
box.

In the above screen shot, the user has selected the conversion of DocBook documents to PDF or PostScript.

2. Click on the Add button.

Tip

If, for example, you want to redefine paper.type from A4 to USLetter as shown in the above screen
shot. Select the paper.type parameter by clicking on it and then click on the Add button. This will
spare you the effort of retyping paper.type as the name of the parameter you want to add.

3. Specify the name of the parameter and its value in the dialog box displayed by the Add button and then click
OK.
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The value of a parameter may contain whitespace, including newline characters.

4. Click OK if you are done or use "Group of parameters" combo box and the Add, Edit and Remove buttons
to specify more parameters.

In the above screen shot:

• The user has added parameter body.font.master=11. (The default value of this parameter, as specified in the
XSL style sheet, is 10.)

Notice the star which precedes newly added and newly modified parameters.

• The user has redefined parameter paper.type to USLetter.

Notice how the user-defined parameter follows the predefined, grayed, parameter.

Tip

The Documentation link is supposed to open in your favorite Web browser the reference manual of the
XSL style sheet parameters.

Therefore, If you select a parameter by clicking on it and then click on the Documentation link, you should
be able to read the documentation of this parameter.

However, this is not guaranteed to work because:

1. This generally requires an access to the Internet.

2. This documentation is not always available. For example, there is no documentation about the XHTML
XSL style sheets yet. In such case, you need to send a support request to the
<xmleditor-support@xmlmind.com> public mailing list to learn how the document conversion process
can be parametrized.

Procedure 9.4. Modifying a user-defined parameter

1. Select the conversion for which you want to specify parameters by using the "Group of parameters" combo
box.

2. Select the parameter to be modified by clicking on it.

3. Click on the Edit button.

Predefined, grayed, parameters cannot be modified.
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4. Specify the value of the parameter in the dialog box displayed by the Edit button and then click OK.

Tip

It also possible to change the name of the parameter here. Doing this will simply add a new parameter
or replace an existing one.

In fact, the Add and Edit buttons may almost be used interchangeably.

5. Click OK if you are done or use "Group of parameters" combo box and the Add, Edit and Remove buttons
to specify more parameters.

Procedure 9.5. Removing a user-defined parameter

1. Select the conversion for which you want to specify parameters by using the "Group of parameters" combo
box.

2. Select the parameter to be removed by clicking on it.

3. Click on the Remove button.

Predefined, grayed, parameters cannot be removed.

4. Click OK if you are done or use "Group of parameters" combo box and the Add, Edit and Remove buttons
to specify more parameters.

12.1.The "Parameter Set Chooser" dialog box

The "Change Document Conversion Parameters" dialog box has a Parameter Set menu which allows to load and
save named parameter sets. A parameter set is the set of all the XSL style sheets parameters specified by a user
using the "Change Document Conversion Parameters" dialog box. This facility is almost indispensable to deal
with the DocBook profiling XSL style sheets. Using such style sheets requires the user to quickly switch from one
parameter set (e.g. containing profile.condition=newbie) to another (e.g. containing profile.condition=ex-
pert).

117

Dialog boxes



Figure 9.2. The "Parameter Set Chooser" dialog box

Reset
Removes all the parameters currently specified by the user in the "Change Document Conversion Parameters"
dialog box. The effect of Reset is thus to restore the stock configuration by removing all the user's customiza-
tions.

Example: parameter paper.type=USLetter is specified in both the docb.toPS.transformParameters and
docb.toRTF.transformParameters groups. Selecting Reset from the Parameter Set menu means removing
these two occurrences of the paper.type parameter.

Load
Displays the "Parameter Set Chooser" dialog box to let the user specify an existing parameter set. The contents
of this parameter set is then used to overwrite all the parameters currently specified by the user in the "Change
Document Conversion Parameters" dialog box.

Example: the user loads a parameter set called "USLetter" containing just paper.type=USLetter in both
the docb.toPS.transformParameters and docb.toRTF.transformParameters groups. Selecting Load
from the Parameter Set menu means removing all the currently specified parameters from all the parameter
groups and then adding paper.type=USLetter to both the docb.toPS.transformParameters and
docb.toRTF.transformParameters groups.

Save
Displays the "Parameter Set Chooser" dialog box to let the user specify the name of a parameter set. The in-
tegral contents of the "Change Document Conversion Parameters" dialog box at the save time is then copied
to this parameter set.
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Appendix A. Command line options
1. Command line
xxe [advanced_option]*
    [ [ -read ] file_or_URL_to_be_opened ]*
    | -last
    | -new config template save_file_or_URL

Options:

file_or_URL_to_be_opened

Open specified document in normal read/write mode.

-read file_or_URL_to_be_opened

Open specified document in read-only mode.

-new category template save_file

Command-line equivalent to using File → New.

category
Specifies the (case-insensitive) name of the category of the document template. A category consists in
one or more segments separated by character '/'.

By default, the category of a document template is the name of the configuration in which this template
has been specified.

Example 1: actual categories : XHTML or xhtml. (Category "XHTML" includes all the templates specified
in configurations "XHTML Strict" and "XHTML Transitional".)

Example 2: categories which are in fact configuration names: DocBook or docbook, "DocBook v5+". (The
document templates of DocBook 4 and 5 are not sorted into categories.)

template
Specifies the (case-insensitive, possibly localized) name of a document template. Example: "Seite
(Streng)" ("Page (Strict)" in German).

Alternatively, you can specify the basename (without any extension) of the file containing the document
template. Doing this should work whatever your locale. Example: "page_strict".

Use "-" to specify the first available document template. This option is mainly useful with configurations
having a single document template such as "Slides".

save_file_or_URL
Specifies the filename or URL of the newly created document. Note that specifying such filename does
not create the corresponding save file. You'll have to use File → Save or File → Save As to actually save
the newly created document.

Use "-" to let XMLmind XML Editor choose this filename for you (as it does it when you use File →
New).

Examples:

• Create a new Slides1 presentation. The filename of the new presentation is MyPresentation.xml. This
file will be found in the current working directory.

-new slides - MyPresentation.xml

1Requires installing the corresponding add-on.
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• Create a new XHTML page conforming to the strict DTD and let XXE choose the filename for you:

-new XHTML Seite -

or:

-new xhtml page_strict -

or:

-new xhtml - -

• Create a new DocBook section in file sections/s4.xml (relative to the current working directory):

-new docbook section sections/s4.xml

-last

Forces XXE to reopen the last document opened during the preceding editing session. Note that this option
cannot be used when one or more file_or_URL_to_be_openeds have been specified.

See also the "Automatically reopen last opened document [96]" option for a handy alternative.

Advanced options:

-putpref key value

Adds or replace preference specified by key/value to the set of the user's preferences.

The set of the user's preferences is normally modified using the Preferences dialog box [80].

For example, in the case of the Encoding [82] option, the preference key is encoding.

xxe -putpref encoding Windows-1252

The reference of all preference keys is found below [121].

-putprefs property_file_or_URL

Similar to -putpref except that several key/value pairs may be read from specified property file. Example:

xxe -putprefs /etc/xxe/preferences.properties

-delpref key

Removes preference specified by key from the set of the user's preferences.

-auth credentials
This option can be used to specify authentication credentials for a given server. This allows to connect to the
specified server without interactively asking the user to enter a username and a password.

String credentials consists in 6 fields: host, port, prompt, scheme, username, password, in that order,
separated by a newline character ('\n'). Fields host, port, prompt, scheme can be left empty, which means:
match any. The UTF-8 bytes of the string are then encoded in base-64.

Command-line utility "java -cp xxe.jar com.xmlmind.netutil.SimpleAuthenticatorModule" allows
to generate such encoded string. Example: encode string "\n\nDocument Store\n\nvictoria\nsecret":

/opt/xxe/bin$ java -cp xxe.jar com.xmlmind.netutil.SimpleAuthenticatorModule \
victoria secret - "Document Store"
CgpEb2N1bWVudCBTdG9yZQoKanZpY3RvcmlhCnNlY3JldA==

/opt/xxe/bin$ xxe -auth CgpEb2N1bWVudCBTdG9yZQoKanZpY3RvcmlhCnNlY3JldA== \
http://www.acme.com/docstore/push_up.xml &
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-open file_or_URL_to_be_opened, -print file_or_URL_to_be_opened

First file_or_URL_to_be_opened may be preceded by -open or -print, which are ignored. This may be
useful when XXE is started by Java™ Web Start. Example: "javaws http://www.acme.com/xxe/xxe.jnlp
-open /docs/doc.xml".

2. Preference keys

Corresponding OptionDefaultTypeKey

Use integrated input method
support [86]

falsebooleanactiveInputMethodCli-

ent

Add open lines [83]truebooleanaddOpenLines

Install add-ons in the user's
preferences directory [95]

bestuser|system|bestaddonInstallDir

Download add-ons from
these servers [94]

serversservers|directory|bothaddonSource

When addonSource=serv-
ers, this key specifies the

See Download add-ons
from these servers [94].

list of URLs separated by
newline characters ('\n')

addonServers

list of ``servers''. See
Download add-ons from
these servers [94].

When addonSource=dir-
ectory, this key specifies

nonethe filename of an existing
directory

addonDir

the local directory. See
Search add-ons in this direct-
ory [95].

Allow advanced use of
XInclude [88]

falsebooleanallowAdvancedXInclude

Allow compounds
words [92]

truebooleanallowCompound

Allow file extensions [92]truebooleanallowFileExtensions

Allow general prefixes [92]truebooleanallowPrefixes

Append mode [87]manualnone, auto or manualappendSuggestionMode

Check for Updates [39]truebooleanautoCheckForUpdates

Specifies the minimal
amount of time, in seconds,

86400 (24 hours)positive integerautoCheckForUpdates.in-

terval

between two automated
checks. See Check for Up-
dates [39].

Specifies the amount of
time, in seconds, after

120 (2 minutes)integer between 10 and
14400

a u t o C h e c k F o r U p -

dates.after

which the automated check
is started. See Check for
Updates [39].

Max. modifications before
saving [84]

-300-1000000-1000000 (number
of operations; negative
means disabled)

autoSaveInterval

Idle time (seconds) before
saving [84]

3010-86400 (number of
seconds)

autoSaveTimeout

Automatically select an at-
tribute [87]

placeholdernever, placeholder or re-
quired

autoSelectAttribute
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Corresponding OptionDefaultTypeKey

Activate if this is specified
in the configuration
file [92]

seeConfigenumeration (never, al-
ways, seeConfig)

autoSpellCheck

Clicking with middle button
pastes system selection [86]

falsebooleanbutton2PastesSystemSe-

lection

Always save these charac-
ters as entity refer-
ences [83]

empty stringspecification as in Always
save these characters as en-
tity references [83]

charsSavedAsEntityRefs

Check punctuation [92]falsebooleancheckPunctuation

Immediately save newly
created document [80]

falsebooleancopyDocumentTemplate

Default background [90]255 255 2553 0-255 integers separated
by spaces (specify red,
green, blue)

defaultBackground

Default font family [89]falsebooleandefaultFontIsSerif

Default font size [89]128-24 (pt)defaultFontSize

Default text color [90]0 0 03 0-255 integers separated
by spaces (specify red,
green, blue)

defaultForeground

Document cache [99]100integer between 0 and 5000.
Specify 0 to disable the
cache.

documentCache

Do not indent unconstrained
documents [84]

falsebooleand o n t I n d e n t U n c o n -

strainedDocs

Encoding [82]UTF-8any encoding supported by
Java™ or "ORIGINAL_EN-
CODING"

encoding

Ensure that a save filename
has an extension [84]

truebooleanensureSaveFileHasExten-

sion

Favor interoperability with
HTML and SGML [83]

truebooleanfavorInteroperability

Section 5.10.1, “Features
Options” [97]

empty string (no features)list of feature names (Link-
Tool, IncludeTool, etc),

featureList

separated by newline char-
acters

Filter duplicate ID errors
found in modular docu-
ments [90]

truebooleanfilterDuplicateIDs

Font size [97]-18-24 (pt) or -1 (means: sys-
tem's default)

fontSize

FTP proxy [100]nonehost name or host addressftpProxyHost

(FTP proxy) Port [100]80integerftpProxyPort

When no DTD or schema,
guess ignorable white
space [80]

truebooleang u e s s I g n o r a b l e -

Whitespace

Begin [85]empty [%F]textheaderBegin [footerBe-
gin]
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Corresponding OptionDefaultTypeKey

Color [85]128 128 128 [128 128 128]3 0-255 integers separated
by spaces (specify red,
green, blue)

headerColor [footerCol-
or]

End [85]empty [%P]textheaderEnd [footerEnd]

Middle [85]empty [empty]textheaderMiddle [footer-
Middle]

File types [92]see File types [92]stringh e l p e r A p p l i c a -

tions.entries The format of this string is:

entries --> ( entry ('\n' entry)* )?

entry --> mime_types ':' extensions ':' 
          magic_strings ':' 
          xml_name_patterns ':' 
          command

mime_types --> ( mime_type (',' mime_type)* )?
extensions --> ( extension (',' extension)* )?
magic_strings --> ( magic_string (',' magic_string)* )?
xml_name_patterns --> ( xml_name_pattern (',' xml_name_pattern)* )?

In any of the above fields, 
character ':' must be escaped using "\072"
and character ',' must be escaped using "\054".

magic_string --> HEXADECIMAL_NUMBER

xml_name_pattern --> ( '{' namespace_URI? '}' )? local_part
One of local_part or namespace_URI 
may be equal to "*".

Default viewer [93]see Default viewer [93]stringhelperApplications.de-

faultViewer

HTTP proxy [100]nonehost name or host addresshttpProxyHost

(HTTP proxy) Port [100]80integerhttpProxyPort

HTTPS proxy [100]nonehost name or host addresshttpsProxyHost

(HTTPS proxy) Port [100]443integerhttpsProxyPort

Indentation [83]2integer (negative means not
indented)

indent

Ignore case [91]falsebooleanignoreCase

Ignore words with di-
gits [91]

truebooleanignoreDigits

Ignore duplicate words [91]falsebooleanignoreDuplicates

Ignore mixed-case
words [91]

falsebooleanignoreMixedCase

I g n o r e  < ? x m l -
stylesheet?> [81]

falsebooleanignoreStyleSheetPI

Ignore URL-l ike
words [91]

truebooleanignoreURL

Inform about non-editable
document parts [81]

truebooleaninfoAboutReadOnlyInclu-

sions

Display images [89]imageimage, thumbnail or boximageViewportMode
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Locale [97]-language (e.g. fr) or lan-
guage_COUNTRY (e.g.
fr_CA) or - (means default)

locale

Lock documents stored on
the local filesystem [81]

falsebooleanlockLocalDocuments

Preferred lock mode [82]exclusiveshared, exclusive or nonelockMode

Identifier as a lock own-
er [82]

empty string which implies
user_name@host_name

stringlockOwner

Style [97]-Java™ class name of a
PLAF or - (means default)

lookAndFeelClassName

Before saving, make a
backup copy of the file [84]

truebooleanmakeBackupFiles

Max. line length [83]78positive integermaxLineLength

Favor quality over
speed [92]

falsebooleanmaxSuggestionForce

Max. undo actions [88]201-100maxUndo

Monospaced font fam-
ily [89]

Monospacedfont family namemonospaceFontFamily

No proxy for [101]"localhost 127.0.0.1"list of host names, host ad-
dresses and domain names

nonProxyHosts

(e.g. .acme.com) separated
by spaces

In the choice list, only show
suggestions [87]

falsebooleanonlyShowSuggestions

???TITLE??? [91]validateone or more of transclude,
redraw, validate separ-
ated by commas

onUpdateDocumentSet

Override settings specified
in config. files [84]

falsebooleanoverrideConfiguration

Use system settings [100]systemnone|system|applicationproxySettings

Quick Start cache [98]truebooleanquickStartCache

Automatically reopen last
opened document [96]

falsebooleanreopenLastOpenedFile

Save characters outside en-
coding as entity refer-
ences [82]

truebooleansaveCharsAsEntityRefs

Schema cache [99]10integer between 0 and 100.
Specify 0 to disable the
cache.

schemaCache

Screen resolution [85]10050-100 (Dot Per Inch)screenResolutionWhen-

Printing

SansSerif font family [89]SansSeriffont family namesansSerifFontFamily

Serif font family [89]Seriffont family nameserifFontFamily

Add interactive left margin
to the styled view [86]

falsebooleansetInteractiveMargin

Show both tree and styled
views [94]

falsebooleanshowBothViews
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Automatically show Valid-
ity tool [91]

falsebooleanshowValidityPaneOnSave

Use a unique instance of
XMLmind XML Edit-
or [96]

falsebooleansingleInstance

Port [96]499871-65535singleInstancePort

(SOCKS) Password [101]the empty stringencoded stringsocksPassword

Authenticate SOCKS
user [100]

falsebooleansocksProxyAuthentica-

tion

SOCKS proxy [100]nonehost name or host addresssocksProxyHost

(SOCKS proxy) Port [100]1080integersocksProxyPort

(SOCKS) User name [101]the login name of the userstringsocksUser

Open spreadsheets in auto-
update mode [93]

truebooleanspreadsheetAutoRecalc

Maximum number of itera-
tions allowed for calcula-
tions in spreadsheet [94]

202-2000spreadsheetMaxItera-

tions

Place tree view at right [94]falsebooleantreeViewAtRight

Fonts and colors [90](without a space after ';')
"SansSerif-Bold; Sans-

(without a space after ';')
"markupFont; textFont;

treeViewFontsAndColors

Serif; Monospaced;verbatimTextFont;

ffffff; e0f0f0;b a c k g r o u n d C o l o r ;

808080; 8b008b;readOnlyColor; markup-

008b8b; 00008b;Color; elementNameCol-

000000; 8b1c62;or; attributeNameCol-

006400; f0f0f0;

ffe0e0; e0ffe0"
or; attributeValueCol-

or; textColor; comment-

Color; piColor; text-

BorderColor; comment-

BorderColor; piBorder-

Color"

Base font size [90]128-24 (pt)treeViewFontSize

Show attributes [90]truebooleantreeViewShowAttribute

Show characters in com-
ment nodes [90]

truebooleantreeViewShowComment

Show characters in pro-
c e s s i n g - i n s t r u c t i o n
nodes [90]

truebooleantreeViewShowPI

Show characters in text
nodes [90]

truebooleantreeViewShowText

Tree view width [94]3310-90treeViewPercent

Underline [Overline] [86]truebooleanunderlineHeader [over-
lineFooter]

Automatically update refer-
ences in modular docu-
ments [85]

truebooleanupdateInclusionsOnSave

When no DTD or schema,
simulate a DTD [80]

truebooleanuseHelperDocumentType
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Use the native file chooser
in preference to the multi-
platform file chooser [80]

true on the Mac, false on
the other platforms

booleanuseNativeFileChooser

Use the URL Chooser [14]falsebooleanuseURLChooser

Split Windows Vertic-
ally [38]

falsebooleanverticalSplit

Warn about advanced use
of XInclude [88]

falsebooleanwarnAboutAdvancedXIn-

clude

Wrap words wider than
available space [88]

falsebooleanwrapLongWords

3. Environment variables
All scripts used to start XXE (that is, xxe, xxe.bat and xxe.jstart) automatically define system properties cor-
responding to the following environment variables.

Note that, due to limitations in Apple's Java™ launcher, you cannot use the following environment variables on
the Mac2.

DescriptionValueVariable name

All the directories referenced in this list are recursively
scanned by XXE during its startup to dynamically dis-
cover add-ons.

List of directory names
separated by semi-colons
(';').

XXE_ADDON_PATH

More info in chapter "The lookup phase during XXE
startup" of Section 1, “Dynamic discovery of add-ons”
in XMLmind XML Editor - Configuration and Deploy-
ment.

Specifies which GUI to use for newly started XXE.Filename (relative or abso-
lute) or URL of an XXE

XXE_GUI

More info in XMLmind XML Editor - Customizing the
User Interface.

GUI specification
(.xxe_gui) file.

Specifies the location of a user preferences property file
different from the default one: XXE_user_prefer-
ences_dir/preferences.property.

Filename of a property fileXXE_USER_PREFER-
ENCES

This alternate user preferences property file is created
(if needed to)/read from/written to by XXE exactly like
the default one.

Note that the hierarchy of directories containing this al-
ternate user preferences property file is also created by
XXE when it does not already exist.

4. System properties
In principle, there is no need to use the following, very low-level, system properties.

2This is the case only with XMLEditor.app, the application bundle contained in the .dmg distribution. If you are a local guru or a consultant
you may prefer to download and install the xxe-*-mac.zip distribution rather than the xxe-*.dmg distribution.

After unzipping this archive in a directory of your choice, XMLmind XML Editor may be started using the XXE_install_dir/bin/xxe
shell script. Unlike XMLEditor.app which leverages Apple's Java™ launcher, the xxe shell script makes it easy working with environment
variables such as XXE_GUI, XXE_ADDON_PATH, etc.
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DescriptionValueProperty name

This property contains the names of all XSL-FO pro-
cessor plug-ins. Examples: "FOP;XFC", "XEP". For use
by some XSLT style sheets.

List of XSL-FO processor
names separated by semi-
colons (';').

XSL_FO_PROCESSORS

Clicking on the Reset button of the "Install add-on"
preferences of the Preferences dialog box resets the list

List of ".xxe_addon" URLs
separated by semi-colons
(';').

XXE_ADDON_DOWN-
LOAD_LOCATION

of download URLs to the value specified by this prop-
erty.

If this property is not set, by default, the list of download
URLs is

• http://www.xmlmind.com/xmleditor/_usercon-
trib/list.xxe_addon

• http://www.xmlmind.net/xmleditor/_down-

load/list-${XXE_VERSION}.xxe_addon (for ex-
ample, variable ${XXE_VERSION} is replaced by
"3_5_2" if the version of the running XML Editor is
v3.5.2)

• ht tp: / /www.xmlmind.net /xmledi tor /_down-
load/list.xxe_addon

Specifies the user preferences which are forced by an
applet version of XXE. Some user preferences are forced

List of user preference
name/value pairs separated

X X E _ A P -
PLET_FORCED_PREFER-
ENCES because values other than the forced ones do not makeby whitespace. Values con-

sense in the context of this applet. For example, the
Viewer applet forces autoSpellCheck [92] to never.

taining space characters
must be quoted.

The default value of this system property depends on the
kind of applet. For example, it's "treeViewShowText
true treeViewShowAttribute true treeViewShowPI

true treeViewShowComment true copyDocumentTem-

plate false linkCheckerMode local" for the Editor1
and Editor2 applets.

Applets deployed by third-party integrators should use
-putpref [120] arguments rather than specifying this
system property in xxe.jnlp.

Prints on the console messages tracing the resolution by
the XML catalog resolver of system identifiers.

Strictly positive integer (the
larger, the more verbose)

XXE_CATALOG_RE-
SOLVER_VERBOSITY

Workaround for the following problem: “when opening
a document stored on a server requiring user authentica-

Strictly positive number of
milliseconds

XXE_CONFIRM_CRE-
DENTIALS_DELAY

tion (e.g. a WebDAV server), a user who typed an incor-
rect username or password is never prompted again for
her/his credentials”.

Example: -DXXE_CONFIRM_CREDENTIALS_DELAY=1000,
means wait for at least 1000 milliseconds before consid-
ering that the credentials specified by the user have been
accepted by the server.

When system property XXE_CONFIRM_CREDEN-

TIALS_DELAY has been specified to an appropriate num-
ber of milliseconds, a user who typed an incorrect user-
name or password is automatically prompted again for
her/his credentials. However, this workaround, based on
a heuristic, may be tricky to configure and may be not
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DescriptionValueProperty name

usable for some protocols. For example, it seems to work
for HTTP and it gets in the way for FTP.

Causes the WebDAV client to print DAV requests and
responses on the console.

Any (example: 1; suffice to
set this property).

XXE_DAV_TRACE

Causes the WebDAV client to use absolute paths rather
than full URIs in the Destination and If headers.

Any (example: 1; suffice to
set this property).

XXE_DAV_USE_SIMPLE_REFS

Doing this is allowed by RFC 4918, but not by (obsolete)
RFC 2518.

This may be useful when operating through a reverse
proxy that does rewrite the Host request header, but not
WebDAV-specific headers.

Used by the WebDAV client.Any (example: 1; suffice to
set this property).

XXE_DAV_URI_ENCOD-
ING_USES_8859_1

Specifies that the WebDAV server expects and returns
URIs where accented characters (to make it simple) are
escaped using the customary %HH form but where HH is
the hexadecimal code of an ISO-8859-1 character.

The standard mandates HH to be UTF-8 codes, not ISO-
8859-1 codes.

For example, this flag is needed for Apache/mod_dav
running on an ``old'' Linux server where the file system
encodes filenames using ISO-8859-1.

Specifies the location of a FOP configuration file.URL of a user-defined FOP
configuration file

XXE_FOP_CONFIG

Note that, because this URL is resolved using the XML
catalogs of XXE, this allows to bundle a custom FOP
configuration file with the FOP plug-in, prior to deploy-
ing XXE using Java™ Web Start.

Procedure:

1. Create the custom FOP configuration file in
FOP_plugin_dir/conf/fop.conf.

2. Create XML catalog fop_catalog.xml in FOP_plu-
gin_dir/. This file should contain:

<catalog
  xmlns="urn:oasis:names:tc:entity:¬
xmlns:xml:catalog">
  <rewriteURI uriStartString="fop-plugin:" 
              rewritePrefix="."/>
</catalog>

3. Run deploywebstart in XMLmind XML Editor -
Configuration and Deployment.

4. Add

<property name="XXE_FOP_CONFIG"
  value="fop-plugin:conf/fop.conf"/>

to the xxe.jnlp file generated by deploywebstart.

Used by the FTP virtual drive plug-in. Disable session
resumption (by default, it's enabled).

Any (example: 1; suffice to
set this property).

XXE_FTP_DISABLE_SES-
SION_RESUMPTION
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DescriptionValueProperty name

Session resumption is a feature of SSL/TLS, which
speeds up the establishment of secure connections by
caching certain cryptographic parameters during the first
connection, such that they may be used in subsequent
connections. This is particularly handy for FTPS which
opens a new connection for each file transfer. Occasion-
ally it can cause problems when establishing secure
connections on data-channels, so this flag is provided
for disabling the feature and thus forcing a full exchange
of cryptographic data for every file.

For example, when XXE is a client of the vsftpd FTP
server:

With vsftpd option require_ssl_reuse=YES (default)
This system property must not be set.

With vsftpd option require_ssl_reuse=NO
This system property must be set (e.g;
-DXXE_FTP_DISABLE_SESSION_RESUMPTION=1)

Example: -DXXE_JAVA_IMAGE_TOOLKIT_EX-

CLUDE="bmp;wbmp"

List of file extensions separ-
ated by semi-colons (';').

X X E _ J A V A _ I M -
AG E _ TO O L K I T _ E X -
CLUDE

This would prevent the built-in Java™ 1.5 image toolkit
from handing BMP images.

This is useful in case you find an external image toolkit
which handles specified image extensions better than the
built-in Java™ image toolkit.

Specifies the default timeout used for creating network
connections and reading responses. A negative or null
number means: wait indefinitely.

A number of milliseconds.X X E _ N E T -
WORK_TIMEOUT

Used at various places in XMLmind XML Editor, for
example by WebDAV and FTP virtual drives.

Built-in default value is 120,000ms (2mn).

Do not anti-alias text in document views. Ignored on the
Mac where text is always anti-aliased.

Any value. Suffice for this
system property to be set.

XXE_NO_TEXT_ANTI-
ALIASING

Slightly changes the way namespace prefixes are declared
in an XML save file, when the document being saved
conforms to a DTD.

Any value. Suffice for this
system property to be set.

X X E _ P R E -
DECLARE_NAMESPACE_PRE-
FIXES

• -DXXE_PREDECLARE_NAMESPACE_PREFIXES=1 means:
pre-declare on the root element all the namespace
prefixes found in the document (regardless on whether
this is allowed by the DTD).

• The standard method is: declare a namespace prefix
when needed to (regardless on whether this is allowed
by the DTD).

Both methods are flawed. In the general case, XXE
simply cannot generate XML documents in which the
xmlns attributes are validated against a DTD.
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DescriptionValueProperty name

When transcluding DITA conrefs, check the compatibil-
ity of the domains of the referencing document with the
domains of the referenced document.

Any value. Suffice for this
system property to be set.

XXE_STRICT_CONREF

Same as XXE_FOP_CONFIG [130], but applies to
RenderX XEP rather than to Apache FOP.

URL of a user-defined XEP
configuration file

XXE_XEP_CONFIG

Reserved. Do not use.-javaws.XXE.*
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